ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

4 Pages V   1 2 3 > »   
Start a new topic Add Reply
> It87x, ITE Super I/O Plug-in Topic
THe KiNG
post Dec 9 2010, 09:09 PM
Post #1
Here we discuss the IT87x (ITE) Super I/O Plug-in

You can download the latest code from assembla using terminal like this:

QUOTE


Latest binary you will find in Downloads section

PLEASE POST HERE ONLY BUGS, IDEAS RELATED TO IT87x (ITE) Super I/O ONLY!
zorglub
post Dec 22 2010, 04:23 PM
Post #2
I successfully added support for the IT8721F as follows:

CODE
Index: IT87x.cpp
===================================================================
--- IT87x.cpp    (revision 449)
+++ IT87x.cpp    (working copy)
@@ -79,6 +79,7 @@
        case IT8716F:
        case IT8718F:
        case IT8720F:
+        case IT8721F:
        case IT8726F:
        case IT8752F:
            model = id;
@@ -140,6 +141,7 @@
         case IT8716F: return "IT8716F";
         case IT8718F: return "IT8718F";
         case IT8720F: return "IT8720F";
+        case IT8721F: return "IT8721F";
         case IT8726F: return "IT8726F";
         case IT8752F: return "IT8752F";
    }
Index: IT87x.h
===================================================================
--- IT87x.h    (revision 449)
+++ IT87x.h    (working copy)
@@ -48,6 +48,7 @@
     IT8716F = 0x8716,
     IT8718F = 0x8718,
     IT8720F = 0x8720,
+    IT8721F = 0x8721,
     IT8726F = 0x8726,
    IT8752F = 0x8752
};


This gives me two temp readings, three fans, cpu vid in iStat Menus 2.0 out of the box.
Temp and fan readings are correct (same as Win7).
CPU vid is clearly incorrect but I have not had time to investigate yet.

Please consider adding to svn.
Slice
post Dec 23 2010, 08:01 AM
Post #3
Done.
Attached File  SuperIOFamily.kext.zip ( 89.86K ) Number of downloads: 261
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.1, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
zorglub
post Dec 24 2010, 09:06 PM
Post #4
The IT8721F is more sensitive than other chips in the family (12mV increment instead of 16mV).
The gain can be configured on some lines (3, 7, and 8 as far as I can tell).
It supports up to 9 voltage readings.

CODE
Index: IT87x.cpp
===================================================================
--- IT87x.cpp    (revision 465)
+++ IT87x.cpp    (working copy)
@@ -52,6 +52,12 @@
long IT87x::readVoltage(unsigned long index)
{
    bool* valid;
+    if (model == IT8721F) {
+        int gain = 12;
+        if ((index == 3) || (index == 7) || (index == 8))
+            gain = 24;
+        return readByte(ITE_VOLTAGE_BASE_REG + index, valid) * gain;
+    }
    return readByte(ITE_VOLTAGE_BASE_REG + index, valid) << 4;
}

@@ -217,7 +223,7 @@
    
    // Voltage
    if (configuration) {
-        for (int i = 0; i < 8; i++)
+        for (int i = 0; i < 9; i++)
        {                
            char key[5];

Enrico
post Dec 25 2010, 07:37 AM
Post #5
Merry Christmas to everyone! With this new version of fakesmc (3.0) Istat doesn't show me fan1 rpm but only GPU0... Fan1 = 0rpm.. I've Ite IT8718F. With fakesmc 2.7 and plugins I had fan 1 rpm shown correctly in istat without any modification in dsdt.
This is my smc util -l -f output if can help you to discover the problem. Thank you for help.


#KEY [ui8 ] (bytes 00 00 00 20)
MSSD [si8 ] (bytes 03)
OSK0 [ch8*] (bytes 6f 75 72 68 61 72 64 77 6f 72 6b 62 79 74 68 65 73 65 77 6f 72 64 73 67 75 61 72 64 65 64 70 6c)
MSPS [{msp] (bytes 00)
LSSB [{lso] (bytes 01 01)
NVPR [ui8 ] (bytes 00)
CLKT [ui32] 223 (bytes 00 00 64 df)
LSOF [flag] (bytes 01)
REV [{rev] (bytes 01 30 0f 00 00 03)
CLKH [{clh] (bytes 00 00 70 80 00 01 19 40)
EPCI [flag] (bytes 01)
FNum [ui8 ] (bytes 02)
ACID [ch8*] (bytes ba be 3c 45 c0 03 10 43)
MOST [ui16] 3 (bytes 80 03)
NTOK [ui8 ] (bytes 01)
NATJ [ui8 ] (bytes 00)
OSK1 [ch8*] (bytes 65 61 73 65 64 6f 6e 74 73 74 65 61 6c 28 63 29 41 70 70 6c 65 43 6f 6d 70 75 74 65 72 49 6e 63)
TC0D [sp78] (bytes 1d 00)
TC1D [sp78] (bytes 1b 00)
TC2D [sp78] (bytes 1a 00)
TC3D [sp78] (bytes 1b 00)
TG0D [sp78] (bytes 30 00)
TG0H [sp78] (bytes 2c 00)
F0Ac [fpe2] 987 (bytes 0f 6c)
F0ID [ch8*] (bytes 47 50 55 20 30)
TN0P [sp78] (bytes 29 00)
TA0P [sp78] (bytes 1f 00)
Th0H [sp78] (bytes fe 00)
VC0C [fp2e] (bytes 49 80)
VM0R [fp2e] (bytes 7a 80)
NATi [ui16] 0 (bytes 00 00)
MSDW [ui8 ] (bytes 01)


Fan #0:
Actual speed : 987 Key[F0Ac]
Minimum speed: 0
Maximum speed: 0
Safe speed : 0
Target speed : 0
Mode : auto

Fan #1:
Actual speed : 0 Key[F1Ac]
Minimum speed: 0
Maximum speed: 0
Safe speed : 0
Target speed : 0
Mode : auto
Slice
post Dec 25 2010, 04:17 PM
Post #6
QUOTE (zorglub @ Dec 25 2010, 01:06 AM) *
The IT8721F is more sensitive than other chips in the family (12mV increment instead of 16mV).
The gain can be configured on some lines (3, 7, and 8 as far as I can tell).
It supports up to 9 voltage readings.

Thank you for the contribution. I updated svn sources with it.
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.1, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
Enrico
post Dec 26 2010, 08:17 AM
Post #7
I tried the latest build but still no Fan 1 rpm..
OonihiloO
post Jan 7 2011, 03:13 PM
Post #8
Hi since rev 471, i've lost the reading of ambiant temp, not a big problem, but just to inform you
X58A-UD3R rev 2.
Core i7-950
Apple Genuine Ati Radeon 5770
Last Revision of Kabyl's Branch (for 5770 Support)
10.6.6 Retail :Dsdt patched, FakeSmc + Plugins, Legacy889, Lnx2Mac's kext for Network
Enrico
post Jan 9 2011, 05:11 AM
Post #9
QUOTE (Enrico @ Dec 25 2010, 08:37 AM) *
Merry Christmas to everyone! With this new version of fakesmc (3.0) Istat doesn't show me fan1 rpm but only GPU0... Fan1 = 0rpm.. I've Ite IT8718F. With fakesmc 2.7 and plugins I had fan 1 rpm shown correctly in istat without any modification in dsdt.
This is my smc util -l -f output if can help you to discover the problem. Thank you for help.


#KEY [ui8 ] (bytes 00 00 00 20)
MSSD [si8 ] (bytes 03)
OSK0 [ch8*] (bytes 6f 75 72 68 61 72 64 77 6f 72 6b 62 79 74 68 65 73 65 77 6f 72 64 73 67 75 61 72 64 65 64 70 6c)
MSPS [{msp] (bytes 00)
LSSB [{lso] (bytes 01 01)
NVPR [ui8 ] (bytes 00)
CLKT [ui32] 223 (bytes 00 00 64 df)
LSOF [flag] (bytes 01)
REV [{rev] (bytes 01 30 0f 00 00 03)
CLKH [{clh] (bytes 00 00 70 80 00 01 19 40)
EPCI [flag] (bytes 01)
FNum [ui8 ] (bytes 02)
ACID [ch8*] (bytes ba be 3c 45 c0 03 10 43)
MOST [ui16] 3 (bytes 80 03)
NTOK [ui8 ] (bytes 01)
NATJ [ui8 ] (bytes 00)
OSK1 [ch8*] (bytes 65 61 73 65 64 6f 6e 74 73 74 65 61 6c 28 63 29 41 70 70 6c 65 43 6f 6d 70 75 74 65 72 49 6e 63)
TC0D [sp78] (bytes 1d 00)
TC1D [sp78] (bytes 1b 00)
TC2D [sp78] (bytes 1a 00)
TC3D [sp78] (bytes 1b 00)
TG0D [sp78] (bytes 30 00)
TG0H [sp78] (bytes 2c 00)
F0Ac [fpe2] 987 (bytes 0f 6c)
F0ID [ch8*] (bytes 47 50 55 20 30)
TN0P [sp78] (bytes 29 00)
TA0P [sp78] (bytes 1f 00)
Th0H [sp78] (bytes fe 00)
VC0C [fp2e] (bytes 49 80)
VM0R [fp2e] (bytes 7a 80)
NATi [ui16] 0 (bytes 00 00)
MSDW [ui8 ] (bytes 01)


Fan #0:
Actual speed : 987 Key[F0Ac]
Minimum speed: 0
Maximum speed: 0
Safe speed : 0
Target speed : 0
Mode : auto

Fan #1:
Actual speed : 0 Key[F1Ac]
Minimum speed: 0
Maximum speed: 0
Safe speed : 0
Target speed : 0
Mode : auto

In the latest revision I still have problems with fan 1..
bruno nascimento
post Jan 12 2011, 05:24 PM
Post #10
Hi!


My motherboad: m3a78-em
the sensor in this motherboard is: IT8712F chip at 0x290
i have installed the fakeSMC 3.10 with ACPIMONITOR, SUPERIOFAMILY and RADEONMONITOR

and my question is:
How i define a constant value to fan rpm?

I want this because my fan stay 100% all time,
and is impossible to stay side this loud machine!



i downloaded the sources from http://subversion.assembla.com/svn/fakesmc/HWSensors
but I don't know where I can set a constant value for fan rpm.


anyone can help me?



thanks.
eMatoS
post Jan 27 2011, 01:04 AM
Post #11
I'm having the same problem as Enrico and Bruno.
With FakeSMC version 2.7.2 I have full fan control:
CODE
26/01/11 21:46:50    kernel    SMCITEController: Found ITE IT8720F Super I/O chip
26/01/11 21:46:51    kernel    SMCITEController: Forcing Fan 0 to 0%
26/01/11 21:47:04    kernel    SMCITEController: Forcing Fan 0 to 100%
26/01/11 21:47:16    kernel    SMCITEController: Forcing Fan 0 to 102%
26/01/11 21:47:16    kernel    SMCITEController: Fan #0 MAX=2003rpm MIN=643rpm
26/01/11 21:47:16    kernel    SMCITEController: Forcing Fan 1 to 0%
26/01/11 21:47:26    kernel    SMCITEController: Forcing Fan 1 to 100%
26/01/11 21:47:38    kernel    SMCITEController: Forcing Fan 1 to 100%
26/01/11 21:47:38    kernel    SMCITEController: Fan #1 MAX=2766rpm MIN=0rpm

This is version 3.1.0, it gives me fan readings but no fan control:
CODE
26/01/11 21:40:42    kernel    IT87x: found ITE IT8720F

I've found the new version to be very fast at boot time, with v2.7.2 I have to restart iStatsMenu to get fan readings. At the end I had to go back to 2.7.2 cause the fans will surely drive me crazy.
GA-Z68AP-D3 rev1 UEFI / i7 2600K @ 4,5GHz / ATI Radeon HD5770 1GB / Wireless TP-LINK TL-WN881ND / Bluetooth 2.1 IOGEAR GBU421
GenericUSBXHCI for USB3 / RealtekRTL81xx for LAN / Clover UEFI / ML 10.8.4 / iMac12,2
Azuma028
post Apr 4 2011, 06:10 AM
Post #12
Did it support iTE IT8728 chip in the meantime.? blink.gif
Mac OS X 10.6.7 (MacBookPro4,1) ● GA-PA65-UD3-B3 ● Intel Core i7 2600 3.4GHz ● 2x4GB DDR3 Corsair 1333Mhz ● Realtek RTL8111E Enthernet ● Realtek ALC889 ● ATI Radeon HD 4650
Mojodojo
post Apr 6 2011, 06:38 AM
Post #13
QUOTE (Azuma028 @ Apr 4 2011, 09:10 AM) *
Did it support iTE IT8728 chip in the meantime.? blink.gif


It's not supported yet. But if you post your boot log here with "it87x: found unsupported chip ID=????" I could add this ID to list.
GA-Z87X-UD3H • Haswell i5-4670K • 8Gb G.Skill Sniper • Zotac GTX 680 • D-Link DWA-556 Wi-Fi • ALC898 & Creative Recon3D USB & Asus Xonar U3 USB
Azuma028
post Apr 6 2011, 10:19 AM
Post #14
QUOTE (Mojodojo @ Apr 6 2011, 03:38 PM) *
It's not supported yet. But if you post your boot log here with "it87x: found unsupported chip ID=????" I could add this ID to list.


Thank you so much =] laugh.gif laugh.gif
Here is my log:

IT87x: [Warning] found unsupported chip ID=0x8728

Is it enough?

This post has been edited by Azuma028: Apr 8 2011, 10:48 AM
Mac OS X 10.6.7 (MacBookPro4,1) ● GA-PA65-UD3-B3 ● Intel Core i7 2600 3.4GHz ● 2x4GB DDR3 Corsair 1333Mhz ● Realtek RTL8111E Enthernet ● Realtek ALC889 ● ATI Radeon HD 4650
Mojodojo
post Apr 8 2011, 04:37 PM
Post #15
QUOTE (Azuma028 @ Apr 6 2011, 01:19 PM) *
Thank you so much =] laugh.gif laugh.gif
Here is my log:

IT87x: [Warning] found unsupported chip ID=0x8728

Is it enough?


Done!
GA-Z87X-UD3H • Haswell i5-4670K • 8Gb G.Skill Sniper • Zotac GTX 680 • D-Link DWA-556 Wi-Fi • ALC898 & Creative Recon3D USB & Asus Xonar U3 USB
Azuma028
post Apr 8 2011, 11:46 PM
Post #16
QUOTE (Mojodojo @ Apr 9 2011, 12:37 AM) *
Done!

Thank you so much for helping, but, I am not sure how to build a kext by xCode...
May I have a built kext file? Thanks=]
Mac OS X 10.6.7 (MacBookPro4,1) ● GA-PA65-UD3-B3 ● Intel Core i7 2600 3.4GHz ● 2x4GB DDR3 Corsair 1333Mhz ● Realtek RTL8111E Enthernet ● Realtek ALC889 ● ATI Radeon HD 4650
Slice
post Apr 9 2011, 06:01 AM
Post #17
QUOTE (Azuma028 @ Apr 9 2011, 03:46 AM) *
Thank you so much for helping, but, I am not sure how to build a kext by xCode...
May I have a built kext file? Thanks=]

Try
Attached File  IT87x.kext.zip ( 16.21K ) Number of downloads: 261
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.1, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
Azuma028
post Apr 9 2011, 07:21 AM
Post #18
QUOTE (Slice @ Apr 9 2011, 02:01 PM) *
Try
Attached File  IT87x.kext.zip ( 16.21K ) Number of downloads: 261




Ya! It works perfectly=]
Thanks! laugh.gif
Mac OS X 10.6.7 (MacBookPro4,1) ● GA-PA65-UD3-B3 ● Intel Core i7 2600 3.4GHz ● 2x4GB DDR3 Corsair 1333Mhz ● Realtek RTL8111E Enthernet ● Realtek ALC889 ● ATI Radeon HD 4650
dinobot
post Apr 9 2011, 04:34 PM
Post #19
Hello,
First thanks for all of your hard work.
I think I'm having trouble with the IT878, in V boot it with fintek is a recurring issue. In older versions of FakeSMC etc I could control some of the fans and see some of the temps. Now I can see north, core 1, core 2, gpu diode, etc. but no fans. I ran smc_util and got this
CODE
#KEY [ui8 ] (bytes 00 00 00 1a)
MSSD [si8 ] (bytes 03)
OSK0 [ch8*] (bytes 6f 75 72 68 61 72 64 77 6f 72 6b 62 79 74 68 65 73 65 77 6f 72 64 73 67 75 61 72 64 65 64 70 6c)
MSPS [{msp] (bytes 00)
LSSB [{lso] (bytes 01 01)
NVPR [ui8 ] (bytes 00)
CLKT [ui32] 255 (bytes 00 00 a7 ff)
LSOF [flag] (bytes 01)
REV [{rev] (bytes 01 30 0f 00 00 03)
CLKH [{clh] (bytes 00 00 70 80 00 01 19 40)
EPCI [flag] (bytes 01)
FNum [ui8 ] (bytes 00)
ACID [ch8*] (bytes ba be 3c 45 c0 03 10 43)
MOST [ui16] 3 (bytes 80 03)
NTOK [ui8 ] (bytes 01)
NATJ [ui8 ] (bytes 00)
OSK1 [ch8*] (bytes 65 61 73 65 64 6f 6e 74 73 74 65 61 6c 28 63 29 41 70 70 6c 65 43 6f 6d 70 75 74 65 72 49 6e 63)
TC0D [sp78] (bytes 2b 00)
TC1D [sp78] (bytes 26 00)
TG0D [sp78] (bytes 39 00)
FGC0 [freq] (bytes 01 2c)
TA0P [sp78] (bytes 29 00)
TN0P [sp78] (bytes 24 00)
VC0C [fp2e] (bytes 47 80)
NATi [ui16] 0 (bytes 00 00)
MSDW [ui8 ] (bytes 01)

With no fans listed.
I'm running 10.6.7 on an intel core 2 duo on a dg41rq with a evga 9800gt. Thanks
Slice
post Apr 10 2011, 05:56 AM
Post #20
Show your kernel.log related to sensors, to famesmc and plugins.
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.1, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2

4 Pages V   1 2 3 > » 
Add Reply Start a new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members: