ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

8 Pages V  « < 6 7 8  
Start a new topicClosed
> My Bootloader, Chameleon 2 based
tmacyunn1
post Aug 16 2011, 01:51 PM
Post #141
QUOTE (Slice @ Aug 16 2011, 11:33 AM) *
Next message may be wake from hibernate... Try "Use ForceWake=y to override" or something with SleepImage.
My bootloader vs trunk will try to wake from hibernate.

Sorry for that, I try to remove the /var/vm/sleepimage and use "ForceWake=yes", but it still exist , can't boot up.
Windows 7 x64 SP1+ Mavericks 10.9.0
CPU : I5-2450m Ram : 8G=4*2G Graphics : HD3000(Disabled AMD6630m BY DSDT) Ethernet: RTL8136 Wireless: AR9280 Audio Card: ALC269 Clover version: 2330
.
Slice
post Aug 17 2011, 06:32 AM
Post #142
QUOTE (tmacyunn1 @ Aug 16 2011, 05:51 PM) *
Sorry for that, I try to remove the /var/vm/sleepimage and use "ForceWake=yes", but it still exist , can't boot up.

One thing that meklort points me. If "RestartFix" is missing then bootloader may crash.
Write RestartFix=PS2 into boot.plist.
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.2, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
tmacyunn1
post Aug 18 2011, 03:08 AM
Post #143
QUOTE (Slice @ Aug 17 2011, 07:32 AM) *
One thing that meklort points me. If "RestartFix" is missing then bootloader may crash.
Write RestartFix=PS2 into boot.plist.

It's weird, I have done it already, remove the openhaltrestart.kext and set RestartFix=PS2, even delete the sleep image from /var/vm/sleepimage. But it auto restarts again.
Windows 7 x64 SP1+ Mavericks 10.9.0
CPU : I5-2450m Ram : 8G=4*2G Graphics : HD3000(Disabled AMD6630m BY DSDT) Ethernet: RTL8136 Wireless: AR9280 Audio Card: ALC269 Clover version: 2330
.
Slice
post Sep 1 2011, 07:33 PM
Post #144
QUOTE (tmacyunn1 @ Aug 18 2011, 07:08 AM) *
It's weird, I have done it already, remove the openhaltrestart.kext and set RestartFix=PS2, even delete the sleep image from /var/vm/sleepimage. But it auto restarts again.

I'm sorry but I don't know what is the problem. I can't reproduce the bug.
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.2, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
bautzen
post Sep 5 2011, 10:09 AM
Post #145
QUOTE (Slice @ Sep 1 2011, 07:33 PM) *
I'm sorry but I don't know what is the problem. I can't reproduce the bug.


Hi Slice, thank you for your 'miracle' that resolved my dual core boot on NC6400 and NC4400 T7200 cpu on dual core mode: not more random KP about CPU01 Failed to start, CPU halted and then "no HPTEs ....". With this your chameleon, every boot it's OK. Thank you!

Anyway, I noticed something related to screensaver and sleep after applied your bootloader: not more autosleep and automatic screensaver. In other words, if I put the notebook manually in stop it works fine (after your PNLF fix) and if I test screensaver works great, but they don't start automatically. Only the monitor in stop works automatically.

I have graphicsenabler=YES and FixRestart=PS2. I have GMA950 code in my DSDT so maybe I don't need "graphicsenabler", what do you think about? I'm using a smbios.plist of MacBook2,1 because it seems more similar to my HW (GMA950, Intel T7200 etc) or do you think that I have to let your default MacBookPro4,1?
Do you think that my issues with autosleep and autoscreensaver could be related to bootloader or not?
I have just tried to remove all com.apple.screensaver.*.plist and Systempreferences.plist, but without success.

Regards

Pat

This post has been edited by bautzen: Sep 5 2011, 10:13 AM
Slice
post Sep 11 2011, 10:40 AM
Post #146
With Dell Latitude D420 (aka MacBook1,1) with GMA950 I have full working graphics without GraphicsEnabler, just DSDT fixes. Screensaver and panel brightness works like a charm.
Attached File  DSDT.dsl_D420_10052011.zip ( 17.97K ) Number of downloads: 34
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.2, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
Slice
post Jan 7 2012, 09:02 AM
Post #147
Chameleon is dead. It is no more exists for me.
I see Chameleon team is not proposing to apply my patches, let it be.
Now I am using Clover.
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.2, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2

8 Pages V  « < 6 7 8
ClosedStart a new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members: