ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

 
Start a new topic Add Reply
> Help On Nvidia Geforce 9300 Gs 256mb, Driver need to get CI / QE and Resolution Working Correctly
hobong Sofian
post May 13 2010, 07:47 AM
Post #1
Hi everyone
I'm new on OSX86 I can not get my NVidia GeForce working properly.
It Doesn't support Quartz Extreme and Core Image is still working on software not Hardware Accelerated. On My CRT Monitor the maximum resolution is 1024x768 @ 85 Hz

Here's my Spec

OSX 10.5.8

Bus : PCIe
PCIe Lane Width : x16
VRAM : 256MB
Vendor ID : 0x10de
Dev ID : 0x06e1
Revission ID : 0x00a1

Output : VGA + TV + DVI

I Have tried use NVidia 9000 Series Driver + NVEnabler but still no luck sad.gif

Can anyone on this forum help me to get this device working properly ?
Thank You.
weizh126
post Jul 3 2010, 02:50 PM
Post #2

CODE
Device (PEGP)
            {
                Name (_ADR, 0x00010000)
                Device (GFX0)
                {
                    Name (_ADR, Zero)
                    Name (_SUN, One)
                    Method (_DSM, 4, NotSerialized)
                    {
                        Store (Package (0x18)
                            {
                                "@0,compatible",
                                Buffer (0x0B)
                                {
                                    "NVDA,NVMac"
                                },

                                "@0,device_type",
                                Buffer (0x08)
                                {
                                    "display"
                                },

                                "@0,name",
                                Buffer (0x0F)
                                {
                                    "NVDA,Display-A"
                                },

                                "@1,compatible",
                                Buffer (0x0B)
                                {
                                    "NVDA,NVMac"
                                },

                                "@1,device_type",
                                Buffer (0x08)
                                {
                                    "display"
                                },

                                "@1,name",
                                Buffer (0x0F)
                                {
                                    "NVDA,Display-B"
                                },

                                "NVCAP",
                                Buffer (0x18)
                                {
                                    /* 0000 */    0x04, 0x00, 0x00, 0x00, 0x00, 0x00, 0x01, 0x00,
                                    /* 0008 */    0xFE, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x0A,
                                    /* 0010 */    0x00, 0x00, 0x00, 0x00
                                },

                                "VRAM,totalsize",
                                Buffer (0x04)
                                {
                                    0x00, 0x00, 0x00, 0x10
                                },

                                "device_type",
                                Buffer (0x0D)
                                {
                                    "NVDA,GeForce"
                                },

                                "model",
                                Buffer (0x18)
                                {
                                    "Nvidia GeForce 9300M GS"
                                },

                                "rom-revision",
                                Buffer (0x26)
                                {
                                    "Nvidia GeForce 9300M GS OpenGL Engine"
                                },

                                "hda-gfx",
                                Buffer (0x0A)
                                {
                                    "onboard-1"
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }
                }
            }

in my DSDT
Good luck~~
bisk
post Feb 21 2011, 05:31 PM
Post #3
Sooooo ...

Anybody get QE and resoolution management working on the HP TouchSmart IQ500 series ?

Specifically, I have the IQ506.

These are the ones with the NVidia GeForce 9300M GS / 256 onboard video.

I have tried the posted DSDT mod and was still welcomed by a black screen sad.gif

Perhaps I am putting it into the wrong part of the DSDT.aml or maybe it's not supposed to be on the PCIe bus ?

Any thoughts out there ?

TIA,

bisk

Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: