ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

49 Pages V  « < 47 48 49  
Start a new topicClosed
> Monitoring With Fakesmc
Slice
post Dec 12 2010, 09:59 AM
Post #961
I will propose to good testers some trick:
If nVidia monitoring doesn't work for you and in kernel.log you see
CODE
Nov 29 19:36:01 localhost kernel[0]: Error reading BIOS

then try to upload the VideoBios using RC5 features
CODE
  UseNvidiaROM=Yes|No     Use an alternate Nvidia ROM image
                            (path:  /Extra/<vendorid>_<devid>.rom)
  VBIOS=Yes|No            Inject VBIOS to device-properties.

It is interesting for me.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.4, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
Konsti
post Dec 13 2010, 09:33 AM
Post #962
QUOTE (Slice @ Dec 12 2010, 11:59 AM) *
I will propose to good testers some trick:
If nVidia monitoring doesn't work for you and in kernel.log you see
CODE
Nov 29 19:36:01 localhost kernel[0]: Error reading BIOS

then try to upload the VideoBios using RC5 features
CODE
  UseNvidiaROM=Yes|No     Use an alternate Nvidia ROM image
                            (path:  /Extra/<vendorid>_<devid>.rom)
  VBIOS=Yes|No            Inject VBIOS to device-properties.

It is interesting for me.

Thanks for giving us this tip, Slice. Can you please point us to a guide how to extract VGA BIOS from e.g. Ubuntu (via USB stick)? I don't think I can do that via MacOSX and don't have Windows installed on my mobo sad.gif Thanks!
Vanilla 10.6.8 (64-bit) on Shuttle XPC SG31G2 V2 • Intel Q9550 (Quad-Core 2.830 GHz) • 4GB RAM (OCZ DDR2) • Intel X25-M SSD SATA (80 GB) • nVidia GeForce 8400GS (512 MB) • Latest BIOS is SG31S30G

Vanilla 10.6.8 (64-bit) on Gigabyte GA-P55M-UD4 • Intel Core i7-860 (2.8 GHz) • 8GB RAM (Kingston HyperX DDR3) • OCZ Vertex II SSD sATA (90 GB) • nVidia GeForce 9500GT (1024 MB) • Latest BIOS is F11

Latest Chameleon 2 RC5 trunk • New open-source FakeSMC 3.1.0 • IntelCPUMonitor & SuperIOFamily plugins • AppleLPC active/sleep working • SMBios set as MacPro3,1 (Q9550) and iMac11,1 (Core i7-860) • Graphics acceleration QC/QE now via DSDT entry only/removed EFI string in com.apple.Boot.plist • No Shutdown Fix in DSDTs
westwaerts
post Dec 13 2010, 03:02 PM
Post #963
QUOTE (Slice @ Dec 12 2010, 10:59 AM) *
I will propose to good testers some trick:
If nVidia monitoring doesn't work for you and in kernel.log you see
CODE
Nov 29 19:36:01 localhost kernel[0]: Error reading BIOS

then try to upload the VideoBios using RC5 features
CODE
  UseNvidiaROM=Yes|No     Use an alternate Nvidia ROM image
                            (path:  /Extra/<vendorid>_<devid>.rom)
  VBIOS=Yes|No            Inject VBIOS to device-properties.

It is interesting for me.


thx slice for the hint,
in my log i got no error reading the bios but

09.12.10 18:14:09 kernel Vendor ID 7f7f7f7f 7f7f7f7f
09.12.10 18:14:09 kernel Device ID 7f7f7f7f 7f7f7f7f
09.12.10 18:14:09 kernel 7f7f7f7f7f7f7f7f7f7f7f7f7f7f7f7f

which i actually dont know where it is referencing to.
First Unit: i7 2600k, GA-Z68MA-D2H-B3, ATI HD 5670
10.7.5
00diabolic
post Dec 17 2010, 09:33 AM
Post #964
I am really confused about this new fakeSMC. I have been using 2.5 for a while now and decided to give this new version a shot. First off please correct me if I have any part of this process wrong.

Step 1. I went to E/E and deleted fakeSMC 2.5 and deleted kext cashe
Step 2. I took the new FakeSMC from slice and put it in S/L/E <--- is that right? I got KP doing this so I googled away for an answer as to why.

I found that there is another version made by mozodojo AKA Super Zan-Zan that runs from E/E. So I installed this version in E/E and it works and I get my temps as I did before with 2.5. I have an x3100 and would like to use that plugin but now that I have mozodojo version running can I use that plugin?

From what it looks like the 2 projects have merged to make one project. Is that correct? Is this the main tread for that combined project now? Or is it this one? --> http://www.projectosx.com/forum/index.php?showforum=165

I am just confused about what plugins work for my system and where there supposed to be installed and what DSDT fixes I need to do to make them work if any.

There seems to be no comprehensive guide in existence on how to properly install or setup this new fakeSMC.. Maybe its still in the works somewhere but I cant find it through googling so far and If I'm lost I'm sure others are to.

Here are my system specs...
Lenovo 3000 N200 0769AVU Laptop/Macbook 4,1 90% Model match
OS: Leo 10.6.5 Snow Uni + Chameleon 2.0rc4 Testing: AnVAL - ACPI Loader
CPU: Intel Core2Duo T9300 2.5GHz 800fsb running at 738fsb due to Bios/SMBIOS issue... would love to fix that.
RAM: 4GB DDR2 @ 667MHz Dual Channel
Video: Intel X3100 965 Express CI/QE work default OSX kext
Sound: HDA 0862 works with VoodooHDA feb 2010 only
Wifi: BCM4328 Draft N card seen as Airport Extream 3rd Party
Webcam: Chicony Device ID 04f2 B013 Works with manycam!!
NW* Network: Broadcom 5906 Netlink Ethernet

Here is my LSPCI info.. That should tell all you would need.
CODE
00:02.0 "VGA compatible controller" "Intel Corporation" "Mobile GM965/GL960 Integrated Graphics Controller" -r0c "Lenovo" "Unknown device 383e"
00:02.1 "Display controller" "Intel Corporation" "Mobile GM965/GL960 Integrated Graphics Controller" -r0c "Lenovo" "Unknown device 383e"
00:1a.0 "USB Controller" "Intel Corporation" "82801H (ICH8 Family) USB UHCI Controller #4" -r03 "Lenovo" "Unknown device 3846"
00:1a.1 "USB Controller" "Intel Corporation" "82801H (ICH8 Family) USB UHCI Controller #5" -r03 "Lenovo" "Unknown device 3847"
00:1a.7 "USB Controller" "Intel Corporation" "82801H (ICH8 Family) USB2 EHCI Controller #2" -r03 -p20 "Lenovo" "Unknown device 3849"
00:1b.0 "Audio device" "Intel Corporation" "82801H (ICH8 Family) HD Audio Controller" -r03 "Lenovo" "Unknown device 384e"
00:1c.0 "PCI bridge" "Intel Corporation" "82801H (ICH8 Family) PCI Express Port 1" -r03 "" ""
00:1c.1 "PCI bridge" "Intel Corporation" "82801H (ICH8 Family) PCI Express Port 2" -r03 "" ""
00:1c.2 "PCI bridge" "Intel Corporation" "82801H (ICH8 Family) PCI Express Port 3" -r03 "" ""
00:1c.3 "PCI bridge" "Intel Corporation" "82801H (ICH8 Family) PCI Express Port 4" -r03 "" ""
00:1d.0 "USB Controller" "Intel Corporation" "82801H (ICH8 Family) USB UHCI Controller #1" -r03 "Lenovo" "Unknown device 3843"
00:1d.1 "USB Controller" "Intel Corporation" "82801H (ICH8 Family) USB UHCI Controller #2" -r03 "Lenovo" "Unknown device 3844"
00:1d.2 "USB Controller" "Intel Corporation" "82801H (ICH8 Family) USB UHCI Controller #3" -r03 "Lenovo" "Unknown device 3845"
00:1d.7 "USB Controller" "Intel Corporation" "82801H (ICH8 Family) USB2 EHCI Controller #1" -r03 -p20 "Lenovo" "Unknown device 3848"
00:1e.0 "PCI bridge" "Intel Corporation" "82801 Mobile PCI Bridge" -rf3 -p01 "" ""
00:1f.0 "ISA bridge" "Intel Corporation" "82801HEM (ICH8M) LPC Interface Controller" -r03 "Lenovo" "Unknown device 3840"
00:1f.1 "IDE interface" "Intel Corporation" "82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller" -r03 -p8a "Lenovo" "Unknown device 386d"
00:1f.2 "SATA controller" "Intel Corporation" "82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller" -r03 -p01 "Lenovo" "Unknown device 386c"
00:1f.3 "SMBus" "Intel Corporation" "82801H (ICH8 Family) SMBus Controller" -r03 "Lenovo" "Unknown device 3842"
04:00.0 "Network controller" "Atheros Communications Inc." "AR928X Wireless Network Adapter (PCI-Express)" -r01 "Hewlett-Packard Company" "Unknown device 3042"
06:00.0 "Ethernet controller" "Broadcom Corporation" "NetLink BCM5906M Fast Ethernet PCI Express" -r02 "Lenovo" "Unknown device 3861"
08:06.0 "FireWire (IEEE 1394)" "Ricoh Co Ltd" "R5C832 IEEE 1394 Controller" -p10 "Lenovo" "Unknown device 3829"
08:06.1 "SD Host controller" "Ricoh Co Ltd" "R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter" -r19 "Lenovo" "Unknown device 382a"
08:06.2 "System peripheral" "Ricoh Co Ltd" "R5C843 MMC Host Controller" -r01 "Lenovo" "Unknown device 382b"
08:06.3 "System peripheral" "Ricoh Co Ltd" "R5C592 Memory Stick Bus Host Adapter" -r0a "Lenovo" "Unknown device 382c"
08:06.4 "System peripheral" "Ricoh Co Ltd" "xD-Picture Card Controller" -r05 "Lenovo" "Unknown device 382d"

Slice
post Dec 17 2010, 12:13 PM
Post #965
QUOTE (00diabolic @ Dec 17 2010, 01:33 PM) *
I am really confused about this new fakeSMC. I have been using 2.5 for a while now and decided to give this new version a shot. First off please correct me if I have any part of this process wrong.

Step 1. I went to E/E and deleted fakeSMC 2.5 and deleted kext cashe
Step 2. I took the new FakeSMC from slice and put it in S/L/E <--- is that right? I got KP doing this so I googled away for an answer as to why.

I found that there is another version made by mozodojo AKA Super Zan-Zan that runs from E/E. So I installed this version in E/E and it works and I get my temps as I did before with 2.5. I have an x3100 and would like to use that plugin but now that I have mozodojo version running can I use that plugin?

From what it looks like the 2 projects have merged to make one project. Is that correct? Is this the main tread for that combined project now? Or is it this one? --> http://www.projectosx.com/forum/index.php?showforum=165

I am sorry. There are two major version. Incompatible in plugins.
1. Old one from this thread. It work only from s/l/e. It can KP because of contain plugins that you need no (Radeon, nVclock). Read topic carefully.
2. New one from mozodojo without X3100 plugin yet.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.4, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
00diabolic
post Dec 17 2010, 11:53 PM
Post #966
QUOTE (Slice @ Dec 17 2010, 11:13 PM) *
I am sorry. There are two major version. Incompatible in plugins.
1. Old one from this thread. It work only from s/l/e. It can KP because of contain plugins that you need no (Radeon, nVclock). Read topic carefully.
2. New one from mozodojo without X3100 plugin yet.


Slice... Thank you so much for clearing that up. I will stick with what I got until mozodojo makes a x3100 plugin, hopefully. Also my superIO sensor is PC83785. Does your version cover that chip? mozodojo does not for now.

Without the plugins I think that pretty much means 2.5 is still the best. Maybe I'll watch this development a little longer.

Thanks for all the hard work. This was my first post here and I really thought I missed some info somewhere that explained this a lot better. I did read through this topic but was a little lost.
Slice
post Dec 18 2010, 03:44 AM
Post #967
Attached File  Screen_shot_2010_12_18_at_6.43.40.png ( 17.4K ) Number of downloads: 355
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.4, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
00diabolic
post Dec 18 2010, 04:59 AM
Post #968
QUOTE (Slice @ Dec 18 2010, 02:44 PM) *
Attached File  Screen_shot_2010_12_18_at_6.43.40.png ( 17.4K ) Number of downloads: 355



Your right I got it wrong.. Is there a way to see which super I/O chip I have on my system?

This doc here: http://shop.lenovo.com/ISS_Static/merchand...pecs_041309.pdf

Says I have LPC bus (ENE KB925 Super I/O) Does that make any sense?
Slice
post Dec 18 2010, 06:24 AM
Post #969
QUOTE (00diabolic @ Dec 18 2010, 08:59 AM) *
Your right I got it wrong.. Is there a way to see which super I/O chip I have on my system?

This doc here: http://shop.lenovo.com/ISS_Static/merchand...pecs_041309.pdf

Says I have LPC bus (ENE KB925 Super I/O) Does that make any sense?

This doc is shop-doc but not document for programmers.
KB925 - same absent of datasheets.

You can got some information by Everest but I don't think it will be helpful to make monitoring. You way is ACPIMonitor with manual DSDT patching.
About X3100. It will work with FakeSMC.kext v2.7.2 (rev 405) placed into s/l/e.
Right click on the kext by mouse, wait for contextual menu, and choose Show Package Contents.
Delete Radeon from PlugIns
Attached File  Screen_shot_2010_12_18_at_9.23.10.png ( 48.37K ) Number of downloads: 185
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.4, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
Darwin
post Dec 20 2010, 10:03 AM
Post #970
Is there any hope for a more recent revision of the FakeSMC.kext and its plugins? Perhaps, if someone has compiled it already, he or she would share it with the rest of us. Revision 405 from the front page is more than 3 months old and surely there must have been significant developments since then. Compiling the FakeSMC.kext with all of its plugins is quite time consuming, so why not share and spread the workload around? Thank You!

Edit: Please disregard the aforementioned, I've gone ahead and compiled it myself. Not as time consuming as I thought.

One question though, what is FakeSMCSMBus.kext for? Thanks.

This post has been edited by Darwin: Dec 20 2010, 11:59 AM
Mac OS X 10.7.4 on GPT via Chameleon 2.1 on Dell XPS M1530
CPU: Intel Core 2 Duo - T9300 (2.5GHz/6MB Cache/45 nm)
MEMORY: 4GB Dual Channel DDR2 SDRAM at 667MHz
DISPLAY: WSXGA - 15.4 (1680x1050) & 2MP Camera
VIDEO: 256MB DDR2 - NVIDIA GeForce 8600M GT
Slice
post Dec 21 2010, 06:32 PM
Post #971
QUOTE
One question though, what is FakeSMCSMBus.kext for? Thanks.

It is a template for a possible investigation if someone can do.

The project is closed.
Now new FakeSMC v3.0.0 which is discussed in FakeSMC subforum.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.4, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2

49 Pages V  « < 47 48 49
ClosedStart a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: