ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

 
Start a new topic Add Reply
> How Can I Get 10.6.4 To Recognize My Bt Magicmouse As A Magicmouse?
gushorty
post Jul 16 2010, 03:44 AM
Post #1
Currently it only recognizes it as an "Apple Wireless Mouse", so the mouse preferences don't show any of the MagicMouse features and of course scrolling doesn't work.

I tried installing Apple's WirelessMouseSoftware update, but it tells me that a newer version is being used. Is there something in there that I can extract using Pacifist? Is there a way to inject the MagicMouse device ID during startup? Or .....
Intel D945GCZ Pentium D 820 running in 64-bit
PNY 9500GT 512MB full QE/CI support
eSata AHCI enabled all ports recognized
Running SL 10.6.8 EFI Chameleon 2 rc4 rev684


Minor BlueTooth and Audio problems remaining..
gushorty
post Jul 17 2010, 08:41 PM
Post #2
Well, I have it working now, along with scrolling smile.gif

Not sure exactly what I did, but it has to be something involving the DSDT as that is the only thing I've been working on. The only changes I can think of, that I made, involve the renaming of various labels:

LPC -> LPCB (make sure to rename all instances, including any .LPC)
TMR -> TIMR
FPU -> MATH
RTC0 -> RTC

I believe that's all I did before it decided to become recognized. It is still labeled as "Apple Wireless Mouse" in bluetooth devices though, but the proper preference pane appears now, and scrolling and tapping work.
Intel D945GCZ Pentium D 820 running in 64-bit
PNY 9500GT 512MB full QE/CI support
eSata AHCI enabled all ports recognized
Running SL 10.6.8 EFI Chameleon 2 rc4 rev684


Minor BlueTooth and Audio problems remaining..
gushorty
post Aug 4 2010, 01:11 AM
Post #3
Well, after installing the latest FakeSMC.kext rev391, and rebooting a couple of times after clearing out all caches with Onyx, 10.6.4 now recognizes my BT MagicMouse and allows one finger scrolling, two finger swiping, but freezes for about 20 secs if I try to use three finger tapping with MagicPrefs.

Any ideas (I've removed USBOverdrive and all associated ketxts).
Intel D945GCZ Pentium D 820 running in 64-bit
PNY 9500GT 512MB full QE/CI support
eSata AHCI enabled all ports recognized
Running SL 10.6.8 EFI Chameleon 2 rc4 rev684


Minor BlueTooth and Audio problems remaining..

Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: