ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

 
Start a new topic Add Reply
> Hellp! Acer 7730g Mini Pci Express Problem
Blaze101
post Sep 30 2010, 03:04 PM
Post #1
Hey guys im new here and i have this hugh problem that im not able to repair its just simple to make it, i know it, but really, i did everything to make my wireless card working or even just show up in my system profiler
So here is what i tryed.:

I have IATKOS S3 v2 and installed it on an ACER Aspire 7730g
everything is working like a charm but only my Mini Pci express Wireless Card
wich also is an Original Apple Airport Express(Atheros AR5006X chip) is not working
there are no entrys in system profiler or network preferences.
I installed the IOPCIFamily.kext of slice and chun nan but both didnt work, after the installation of the both kext the boot just hanging up (stand still) says somthing like pci changed brige 4 ..... something
also i tryed to change (_Sun, 0x03) didnt work ether.

SO PLS GUys do someone had this problem or can help me fix it pls im really tired of trying THX for all Help...

EDIT: Now i got it to show on system profiler but the card ist not loading the driver

here is what verbose mode, kextutil and kestload says:

kernel verbose mode with standard driver log.:

Sep 30 20:51:37 Blazes-MacBook-Pro kernel[0]: start [/SourceCache/AirPortDriverAtheros9380/AirPortDriverAtheros9380-423.9.9/src/common/lmac/ath_dev/darwin/AtherosController.cpp:1189] load failed


kextload with standard driver:

Last login: Thu Sep 30 21:35:26 on ttys000
Blazes-MacBook-Pro:~ blaze$ sudo kextload /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext
/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext failed to load - (libkern/kext) requested architecture/executable not found; check the system/kernel logs for errors or try kextutil(8).



kextutil with standard driver:

Blazes-MacBook-Pro:~ blaze$ sudo kextutil /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext
Warnings:
Executable does not contain code for architecture:
x86_64
The booter does not recognize symbolic links; confirm these files/directories aren't needed for startup:
/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext/Contents/CodeDirectory
/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext/Contents/CodeRequirements
/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext/Contents/CodeResources
/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext/Contents/CodeSignature

Can't load /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext - no code for running kernel's architecture.
Failed to load /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext - (libkern/kext) requested architecture/executable not found.
Blazes-MacBook-Pro:~ blaze$

32bit mode kextutil:

Blazes-MacBook-Pro:~ blaze$ sudo kextutil /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext
Warnings:
The booter does not recognize symbolic links; confirm these files/directories aren't needed for startup:
/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext/Contents/CodeDirectory
/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext/Contents/CodeRequirements
/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext/Contents/CodeResources
/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext/Contents/CodeSignature

kernel log verbose with 10.4 drivers.:

Sep 30 23:33:31 localhost kernel[0]: Warning - kext com.apple.driver.AirPortAtheros5424 has immediate dependencies on both com.apple.kernel* and com.apple.kpi.* components; use only one style.
Sep 30 23:33:31 localhost kernel[0]: start [/SourceCache/AirPortDriverAtheros5424/AirPortDriverAtheros5424-201.12/M35a/src/driver/AtherosController.cpp:445] loaded unsuccessfully



This post has been edited by Blaze101: Sep 30 2010, 07:46 PM

Add Reply Start a new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members: