ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

 
Start a new topic Add Reply
> Battery Icon Not Found
micron792
post Dec 5 2010, 09:16 AM
Post #1
I had the battery icon on the 100% fixed, I removed to install voodoobattery.kext kexthelper AppleACPIBatteryManager but on reboot I find myself without the battery icon. I tried to reinstall but VoodooBattery wrong. Does anyone know tell me how to restore the battery icon. Thanks

My System is Acer 5745g I7 Snow Leopard 10.6.3 retail Nawcom update combo 10.6.4
Slice
post Dec 5 2010, 02:02 PM
Post #2
Remove VoodooBattery and install AppleACPIBattery
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.1, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
ZAFFE
post Dec 5 2010, 05:08 PM
Post #3
Slice, I always have a panic with ACPI Battery on any version snow leopard, in what could be the problem?
micron792
post Dec 5 2010, 06:41 PM
Post #4
QUOTE (ZAFFE @ Dec 5 2010, 06:08 PM) *
Slice, I always have a panic with ACPI Battery on any version snow leopard, in what could be the problem?

Yet to me it gives me kernel panik
micron792
post Dec 5 2010, 07:07 PM
Post #5
I tried to install another version Acpi Kernel Panik Battery does not but the battery icon on there, as well as Slice hangs with command-x and if it helps stop the written DSDT FOUND NO. The strange thing is that even if I install VooDooBattery.Kext I have no icon.


This post has been edited by micron792: Dec 5 2010, 07:18 PM
Slice
post Dec 5 2010, 08:49 PM
Post #6
I think you have bad DSDT.
Attached File  Screen_shot_2010_12_05_at_23.46.30.png ( 110.9K ) Number of downloads: 116
Attached File  Screen_shot_2010_12_06_at_0.32.12.png ( 44.06K ) Number of downloads: 93

My battery part
CODE
Device (BAT0)
{
Name (_HID, EisaId ("PNP0C0A"))
Name (_UID, One)
Name (_PRW, Package (0x02)
{
0x1C,
0x03
})
Name (_PCL, Package (0x01)
{
_SB
})
Method (_STA, 0, NotSerialized)
{
And (MIS0, 0x02, Local0)
If (Local0)
{
Return (0x1F)
}

Return (0x0F)
}

Method (_BIF, 0, NotSerialized)
{
Return (BIF (One))
}

Method (_BST, 0, NotSerialized)
{
SX10 ()
SX30 (0x02)
SX30 (One)
SX11 ()
Name (BST0, Package (0x04) {})
Store (SX42 (), Index (BST0, Zero))
Store (SX42 (), Index (BST0, One))
Store (SX42 (), Index (BST0, 0x02))
Store (SX42 (), Index (BST0, 0x03))
SX12 ()
Return (BST0)
}
}
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.1, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
micron792
post Dec 5 2010, 09:58 PM
Post #7
What an idiot I am!! Slice seeing your screenshots I realized that the panel power I had not put the check on the "Show battery status in menu bar" is now OK with VoodooBattery.Kext. Thanks for everything.

Slice excuse you wonder if you can take a look in the Forum section Hardware / Audio could look a Link: http://www.projectosx.com/forum/index.php?...=355&st=660 page 34 1 Dec 2010 Micron792 As jy my kan help los ALC269 NID verandering Info.plist VoodooHDA
Sorry if I take this opportunity but I'm trying to learn. Thanks so much

This post has been edited by micron792: Dec 5 2010, 10:29 PM
fingerr
post Feb 17 2011, 02:03 PM
Post #8
QUOTE (Slice @ Dec 5 2010, 09:49 PM) *
I think you have bad DSDT.

Hi Slice,

I'd like to ask what has to be changed in order iStat dashboard to display battery status?
I have battery icon visible in finder and showing proper values, but iStat show Calculating ...
Do I have to modify DSDT to achieve this?
--
best regards
fingerr
Slice
post Feb 17 2011, 08:59 PM
Post #9
Look here
http://www.projectosx.com/forum/index.php?showtopic=1206
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.1, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
fingerr
post Feb 18 2011, 05:24 PM
Post #10
QUOTE (Slice @ Feb 17 2011, 09:59 PM) *

Thanks for reply Slice. I've checked this thread but haven't found anything related Battery information in iStat Pro. Looks like my notebook doesn't have any embedded controler (at least linux sensors backage can't find any).

And one more thing, when I run smcK-Stat-i it shows cpu speed 3060MHz when idle, and jumps to 7140MHz when running geekbench. Anyone have something similiar? My notebook is Asus U30JC, core i5-560M running SL in 32 bit mode.

Thanks in advance and best regards,
fingerr.
Slice
post Feb 19 2011, 09:54 PM
Post #11
QUOTE (fingerr @ Feb 18 2011, 09:24 PM) *
Thanks for reply Slice. I've checked this thread but haven't found anything related Battery information in iStat Pro.
The iStatPro, attached there, shows battery information if AppleACPIBatteryManager.kext is loaded.
QUOTE
Looks like my notebook doesn't have any embedded controler (at least linux sensors backage can't find any).
Not related. I also have no EC.
QUOTE
And one more thing, when I run smcK-Stat-i it shows cpu speed 3060MHz when idle, and jumps to 7140MHz when running geekbench. Anyone have something similiar? My notebook is Asus U30JC, core i5-560M running SL in 32 bit mode.

Thanks in advance and best regards,
fingerr.

It may be because bad bootloader detects wrong FSB.
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.1, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2

Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: