ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

 
Start a new topic Add Reply
> Firewire Expresscard -- Kernel Panic...
darkuttek
post Dec 9 2010, 07:14 PM
Post #1
Hello everyone!

I'm running Snow Leopard 10.6.4 on a Acer Aspire 7730G and almost everything is working rather smoothly. There is, however, one problem. I'm using this computer for video editing, and for that I need firewire connection (which doesn't exist in this laptop built-in). For this use I bought a DeLock firewire expresscard.

In Linux the card works well through PCI hotplug.

OSX, however, doesn't seem to like this card. Plugging it in or booting with it plugged results in a kernel panic (photo included)
Attached File  S5301745.JPG ( 2.28MB ) Number of downloads: 18


Now, I'd really much like to find out whether this problem has something to do with the Texas Instruments chip or whether this is related to the chipset of this computer (ICH9) -- and if possible, get it fixed. If it is related to this DeLock built card not being supported by Snow Leopard I can of course go and buy more expensive FW 800 -card which I'll be needing, but I'd rather not do that if the problem is with the ExpressCard and pci hotplugging.

Any ideas?

Here is the information of the card according to the lspci -vv in Linux
CODE
02:00.0 PCI bridge: Texas Instruments XIO2000(A)/XIO2200(A) PCI Express-to-PCI Bridge (rev 03) (prog-if 00 [Normal decode])
          Physical Slot: 1
          Flags: bus master, fast devsel, latency 0
          Bus: primary=02, secondary=03, subordinate=03, sec-latency=0
          Memory behind bridge: c0000000-c00fffff
          Capabilities: [50] Power Management version 2
          Capabilities: [60] MSI: Enable- Count=1/16 Maskable- 64bit+
          Capabilities: [80] Subsystem: Device 5678:1234
          Capabilities: [90] Express PCI/PCI-X Bridge, MSI 00
          Capabilities: [100] Advanced Error Reporting
          Kernel modules: shpchp
      
      03:00.0 FireWire (IEEE 1394): Texas Instruments XIO2200(A) IEEE-1394a-2000 Controller (PHY/Link) (rev 01) (prog-if 10 [OHCI])
          Subsystem: Device 5678:1234
          Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16
          Memory at c0004000 (32-bit, non-prefetchable) [size=2K]
          Memory at c0000000 (32-bit, non-prefetchable) [size=16K]
          Capabilities: [44] Power Management version 2
          Kernel driver in use: firewire_ohci
           Kernel modules: firewire-ohci


This post has been edited by darkuttek: Dec 9 2010, 07:16 PM
Slice
post Dec 10 2010, 10:18 PM
Post #2
May be help, may be no
http://www.projectosx.com/forum/index.php?showtopic=552
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.5, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
darkuttek
post Dec 11 2010, 08:39 AM
Post #3
QUOTE (Slice @ Dec 11 2010, 12:18 AM) *


Thanks, got to give it a try! smile.gif
darkuttek
post Jan 3 2011, 12:58 AM
Post #4
QUOTE (darkuttek @ Dec 11 2010, 10:39 AM) *
Thanks, got to give it a try! smile.gif


After trying several different IOPCIFamily kexts and doing some reading, my conclusion is that the problem I'm having is the same problem quite many other Acer people are reporting: for some reason pci bridges are not assigned right addresses. This affects not only expresscard but integrated lan and wifi as well. At the moment laptops which have the problem but which aren't fixed with the available kexts are:
Acer Aspire 7730G
Acer Aspire 7730ZG
Acer Aspire 5739G

All of these have the Mobile Intel PM45 chipset.

Under linux I haven't got any problems with my hardware. Running latest bios.

This is probably the longest and most comprehensive treatment on the subject at the moment:
http://www.projectosx.com/forum/index.php?showtopic=694

I offer a bounty of $75 US through paypal to anyone solving this issue. In case teamcobra is still offering a bounty on this issue as well, fixing this issue will be worth of total $150...
teamcobra
post Jan 3 2011, 02:17 AM
Post #5
Still Here, still offering $75, and still no luck.... Surely someone with skill needs to buy some new toys wink.gif I'll be subscribing to this thread, and am subscribed to the 6930g one. I hope someone takes a serious crack at this, I'd also really like to be able to use my expresscard as well!
kocoman
post Apr 9 2011, 09:33 AM
Post #6
I've tried this kext on a tx1000 HP laptop, (to enable ExpressCard PCIe video card), but it just "reboots" before going into the GUI

It does detect the external video card, but reboots,... and it does the same thing (reboots) without the card (using internal only)

How to debug this?

Linux and Win7 detects it fine.

Running 10.6.5
NOTE:

If you can't reply, do the QUIZ on the MAIN page!!!!
Then you can reply!!

I signed up here 2 years ago, never know why I could not post, until a few days ago.
darkuttek
post May 2 2011, 01:00 AM
Post #7
Please see the latest posts in the topic I link to. I thus close this thread, as I have claimed my own bounty smile.gif
darkuttek
post May 4 2011, 10:33 PM
Post #8
Now really fixed. See here: http://www.projectosx.com/forum/index.php?showtopic=2118

Add Reply Start a new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members: