ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

4 Pages V  < 1 2 3 4 >  
Start a new topic Add Reply
> Nvclockx, NVClockX Plug-in Topic
Slice
post Jul 8 2011, 08:18 PM
Post #41
You want NV50? OK, take it!
Attached File  NVClockX.kext.zip ( 75.95K ) Number of downloads: 253
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.5, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
iLeopod
post Jul 9 2011, 06:29 AM
Post #42
Works!
Thank you.

But the temperature seems the half of the real one.

Is ist possible to show also board temp and fan speed?


This post has been edited by iLeopod: Jul 9 2011, 07:16 AM
chewara
post Aug 7 2011, 07:02 PM
Post #43
Jul 29 18:25:32 localhost kernel[0]: NVClockX: Vendor ID: 10de, Device ID: 10c3
Jul 29 18:25:32 localhost kernel[0]: NVClockX: Architecture: 200
Jul 29 18:25:32 localhost kernel[0]: NVClockX: Unknown Nvidia card
Jul 29 18:25:32 localhost kernel[0]: NVClockX: Memory mapped successfully
Jul 29 18:25:32 localhost kernel[0]: NVClockX: it seems your card isn't officialy supported in FakeSMCnVclockPort yet.
Jul 29 18:25:32 localhost kernel[0]: NVClockX: please tell the author the pci_id of the card for further investigation.
Jul 29 18:25:32 localhost kernel[0]: NVClockX: continuing anyway
Jul 29 18:25:32 localhost kernel[0]: NVClockX: Speed: 0
Jul 29 18:25:32 localhost kernel[0]: NVClockX: 350
Jul 29 18:25:32 localhost kernel[0]: NVClockX: Speed:52954


Thats a EVGA Geforce GT 430 (GT430NV-LF REV 1.0)
1 GB DDR3

any help someone?
oku812
post Aug 19 2011, 02:56 PM
Post #44
GTX460/1GB
any help?

CODE
11/08/19 23:15:30    kernel    NVClockX: NVClock Darwin port by alphamerik (C) 2010
11/08/19 23:15:30    kernel    NVClockX: usr-sse2 (C) 2010
11/08/19 23:15:30    kernel    NVClockX: [Warning] no nVidia graphics adapters found
11/08/19 23:15:30    kernel    NVClockX: [Warning]
11/08/19 23:15:30    kernel    NVClockX: NVClock Darwin port by alphamerik (C) 2010
11/08/19 23:15:30    kernel    NVClockX: usr-sse2 (C) 2010
11/08/19 23:15:30    kernel    NVClockX: Card: 0, Vendor ID: 10de, Device ID: e22, Architecture: 1000000, GF100 [GeForce GTX 460]
11/08/19 23:15:30    kernel    NVClockX: BIOS successfully read
11/08/19 23:15:30    kernel    NVClockX: [Warning] Unhandled init script entry with id '�' at 67c7
shatterhenner
post Aug 20 2011, 09:57 AM
Post #45
QUOTE (oku812 @ Aug 19 2011, 02:56 PM) *
GTX460/1GB
any help?

CODE
11/08/19 23:15:30    kernel    NVClockX: NVClock Darwin port by alphamerik (C) 2010
11/08/19 23:15:30    kernel    NVClockX: usr-sse2 (C) 2010
11/08/19 23:15:30    kernel    NVClockX: [Warning] no nVidia graphics adapters found
11/08/19 23:15:30    kernel    NVClockX: [Warning]
11/08/19 23:15:30    kernel    NVClockX: NVClock Darwin port by alphamerik (C) 2010
11/08/19 23:15:30    kernel    NVClockX: usr-sse2 (C) 2010
11/08/19 23:15:30    kernel    NVClockX: Card: 0, Vendor ID: 10de, Device ID: e22, Architecture: 1000000, GF100 [GeForce GTX 460]
11/08/19 23:15:30    kernel    NVClockX: BIOS successfully read
11/08/19 23:15:30    kernel    NVClockX: [Warning] Unhandled init script entry with id '�' at 67c7



same here!!!!thanx for help
osxfr33k
post Nov 4 2011, 07:42 PM
Post #46
Asus G74SX with Nvidia GTX 560M 3GB Vram

It seems to read my card not sure. Can't find temperature in kernel log?

Nov 4 11:57:40 localhost kernel[0]: NVClockX: Card: 0, Vendor ID: 10de, Device ID: 1251, Architecture: 1000000, GF100 [N12E-GS-A1]
Nov 4 11:57:40 localhost kernel[0]: NVClockX: BIOS successfully read
Nov 4 11:57:40 localhost kernel[0]: NVClockX: [Warning] Unhandled init script entry with id '�' at 6e09
Clover pre 2837
Auto Patched DSDTs
5 towers: Asus Maximux Formula Special Editions with Rampage Formula Bios conversion, Gigabyte GA-EP35-DS4, GA-EP45-UD3P, GA-G41M-ES2, GA-Z68X-UD4-B3, Z77X-UP5-TH, i7-3770k
5 Quad Core Processors: QX6850/Q9650/Q6600/i7-2600K/i7-3770k
MAC PRO EARLY 2008 Xeon 8 Core/10GB RAM/4TB Seagates
Asus G51JX i7-720QM. 8GB Kingston Ram. HM55 Chipset
Asus Gamers Notebook G74SX-XT1, G750jx nearly 100 % osx clone
Dell Laptops D820, D830, XPS M1530, MacBookPro Late 2013 Retina GT750 1TB PCIe SSD
Jingu
post Nov 5 2011, 09:54 AM
Post #47
Got Nvclockx to give me the temperature reading on my Nvidia GT 240M (GT216 architecture)



Using alphamerik's nvclock 0.8b5_7 (experimental) from the "Nvclock Darwin Port + Mapmemory Driver + Source" thread I got:

-- General info --
Card: GT216 [GeForce GT 240M]
Architecture: GA5 A2
PCI id: 0x0a34
Subvendor id: 0x1043
GPU clock: -8589935.000 MHz
Bustype: PCI-Express

-- Sensor info --
Sensor: G84 GPU Internal Sensor
GPU temperature: 59C

That told me that, in my particular case, my GT 240M (GT216 architecture) is actually using a G84 GPU Internal Sensor.

I went into HWSensor source code/NVClock/info.cpp and added my device GT 240M device id 0x0a34 to the list of the GT200 device ids

CODE
int get_gpu_arch(int device_id)
{
int arch;

switch(device_id & 0xfff0)
{
case 0x5e0: /* GT2x0 */
case 0x5f0: /* GT2x0 */
case 0xa60: /* GT2x0 */
case 0xa20:
case 0xa30:
case 0xa34: /* My GT240M */
case 0xa70:
case 0xca0:
case 0xcb0:
arch = GT200;
break;


Then I went into HWSensor source code/NVClock/NV50.cpp and added the GT200 to the G84 sensor check line

CODE
else if((nv_card->arch & (G84 | G86 | G94 | G96 | GT200)) && !(nv_card->caps & GPU_TEMP_MONITORING))
{
nv_card->caps |= GPU_TEMP_MONITORING;
nv_card->sensor_name = (char*)STRDUP("GPU Internal Sensor", sizeof("GPU Internal Sensor"));
nv_card->get_gpu_temp = (int(*)(I2CDevPtr))g84_get_gpu_temp;


I realize this is not entirely proper. Also, this does not mean necessarily it will work for all GT 240M, but in my particular case I can use the G84 sensor sub-routine since my card is reported as using the G84 sensor and it worked!

This post has been edited by Jingu: Nov 5 2011, 10:08 AM
Slice
post Nov 5 2011, 06:44 PM
Post #48
Good find, Jingu!
It is first time I see GT240 working monitoring.
CODE
        case 0xa30:
        case 0xa34: /* My GT240M */

No influence, it is the same.

PS. I want other users to test this version
Attached File  NVClockX.kext_rev_499.zip ( 75.67K ) Number of downloads: 217
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.5, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
Slice
post Nov 6 2011, 05:39 PM
Post #49
Also a version for GT4xx
Attached File  NVClockX.kext_testGT400.zip ( 75.67K ) Number of downloads: 585
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.5, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
Gringo Vermelho
post Nov 7 2011, 01:24 AM
Post #50
Yes! It's nice to finally have this, thanks very much Slice.
There's the same warning message that others are getting, but it loads:
CODE
Nov  6 23:12:59 localhost kernel[0]: NVClockX: NVClock Darwin port by alphamerik (C) 2010
Nov  6 23:12:59 localhost kernel[0]: NVClockX: usr-sse2 (C) 2010
Nov  6 23:12:59 localhost kernel[0]: NVClockX: Card: 0, Vendor ID: 10de, Device ID: e22, Architecture: 1000000, GF100 [GeForce GTX 460]
Nov  6 23:12:59 localhost kernel[0]: NVClockX: BIOS successfully read
Nov  6 23:12:59 localhost kernel[0]: NVClockX: [Warning] Unhandled init script entry with id ' ' at 67c7


Something strange happened with the Winbond SuperIO plugin - after installing NVClockx I lost one case fan in the iStat widget. I had to edit info.plist in the Winbond plugin and up the FANLIMIT setting to 5 to get my 2nd case fan to display again.
So NVClockX interferes with the Winbond plugin's fan detection somehow - but the funny thing is, I'm not getting a GPU fan reading. GPU temp reading works.

I would attach screenshots but for some reason attachments don't work in here.

This post has been edited by Gringo Vermelho: Nov 7 2011, 03:33 AM
ASUS P8Z77-V Pro - EVGA GTX 660 - i5-3570K - 10.9.1 retail - Chameleon 2.2 svn r22xx
Slice
post Nov 7 2011, 09:03 AM
Post #51
All credits to Jingu.
About FAN it is complex problem and I am not ready to check more carefully.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.5, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
iLeopod
post Nov 8 2011, 05:07 PM
Post #52
QUOTE (Slice @ Nov 6 2011, 06:39 PM) *
Also a version for GT4xx
Attached File  NVClockX.kext_testGT400.zip ( 75.67K ) Number of downloads: 585

Working on my GTX570.
id: 0x1081
CooSee
post Nov 9 2011, 09:54 PM
Post #53
QUOTE (Slice @ Nov 5 2011, 08:44 PM) *
Good find, Jingu!
It is first time I see GT240 working monitoring.
CODE
        case 0xa30:
        case 0xa34: /* My GT240M */

No influence, it is the same.

PS. I want other users to test this version
Attached File  NVClockX.kext_rev_499.zip ( 75.67K ) Number of downloads: 217


thx for the New Version, but i get no Temp reading, GPU Diode shows only a
CODE
-
and GPU0 Fan reading is o.k. i think
CODE
400 rpm
pls look here LeadTek WinFast GTX 260 Extreme +

thank you for all your Work rolleyes.gif

CooSee ' Ya
Cooler Master Cosmos S RC-1100 AluminiumBlack - NZXT SENTRY LX Multipanel
Gigabyte GA-EP45-UD3LR - Intel Core 2 Quad Q6600 2.4 GHz - 8 GB DDR II 800 MHz GeIL Value Dual Channel Kit
LeadTek WinFast GTX 260 Extreme+ / 3 x Samsung SpinPoint F1 HD103UJ SATA
Creative Audigy 4 - Logitech Speaker System Z623 2.1
Logitech G110 Keyboard - Logitech MX 518 Mouse
azerq
post Nov 18 2011, 09:13 PM
Post #54
Hi Gringo Vermelho and Hi all !

I've sent you a post related to our previous exchange about the correct insertion of SSDT Tables.
http://www.insanelymac.com/forum/index.php?showtopic=268653

Could you please take a look to it and advice ?

A very great thanks in advance.
Loyd
gxsolace
post Nov 20 2011, 11:07 AM
Post #55
Any chance that this works with a Nvidia GTX 580?
Gringo Vermelho
post Nov 20 2011, 08:39 PM
Post #56
Why don't you try it and see?

If you're worried about breaking your Hackintosh, use a bootable USB stick or boot CD when experimenting with /Extra/Extensions.
ASUS P8Z77-V Pro - EVGA GTX 660 - i5-3570K - 10.9.1 retail - Chameleon 2.2 svn r22xx
gxsolace
post Nov 21 2011, 07:20 AM
Post #57
QUOTE (Gringo Vermelho @ Nov 20 2011, 09:39 PM) *
Why don't you try it and see?

If you're worried about breaking your Hackintosh, use a bootable USB stick or boot CD when experimenting with /Extra/Extensions.


Appears that it does not work.
I've tried.

Was wondering if anyone else had gotten it to work.
Slice
post Dec 3 2011, 09:35 AM
Post #58
QUOTE (gxsolace @ Nov 21 2011, 11:20 AM) *
Appears that it does not work.
I've tried.

Was wondering if anyone else had gotten it to work.

Are you sure you used the kext in conjunction with appropriate version of FakeSMC?
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.5, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
gxsolace
post Dec 6 2011, 07:48 PM
Post #59
QUOTE (Slice @ Dec 3 2011, 10:35 AM) *
Are you sure you used the kext in conjunction with appropriate version of FakeSMC?


I'm using the latest FakeSMC available on this site, with the latest nvclockx posted here as well.

Regi Yassin
post Dec 12 2011, 06:43 PM
Post #60
help, Gigabyte GTX 580 SOC not detected,

CODE
NVClockX: [Warning] no nVidia graphics adapters found
NVClockX: [Warning]
NVClockX: NVClock Darwin port by alphamerik (C) 2010
NVClockX: usr-sse2 (C) 2010
NVClockX: Card: 0, Vendor ID: 10de, Device ID: 1080, Architecture: 1000000, GF100 [GeForce GTX 580]
NVClockX: BIOS successfully read
NVClockX: [Warning] Unhandled init script entry with id '\M^L' at 6bd4



4 Pages V  < 1 2 3 4 >
Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: