Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

Start a new topic Add Reply
> Anval, ACPI Loader
post Dec 14 2010, 02:21 PM
Post #1
As many of u was waiting for this, let me introduce a new friend to your HDD on its way to vanilla.
I call it AnVAL. Big thanks to Andy and the VoodooTeam for the hard work.

AnVal needs YOU to succeed.

Attached File  Unclesamwantyou.jpg ( 21.18K ) Number of downloads: 101
Please help by:
Testing: Every Feedback is welcome. Don't forget your bdmesg.

Update: 01-21-2011
Attached File ( 401.83K ) Number of downloads: 400
reworked: Autoresolution; Thanks to Azimutz for his rework.
reworked: kernel patcher defaults to disabled (make use of PatchKernel to re-enable);
bug-fix: some minor issues

Update: 01-16-2011
added: kernel patcher (to be updated); credits to meklort
added: Sandy Bridge support
reworked: on Phenom/Shanghai's code
bug-fix: nVidia rom's size
added: new key (FixTM) for TM1/TM2 enabling (disabled by default)
bug-fix: Compilie utilities as fat 64 / 32bit binaries; Thanks to meklort

Update: 01-10-2011
added: via support
reworked: amd code
added: intel cpu model 0xC (i7 & atom) support
bug-fix: boot-log size increased (thanks Azi)

Update: 12-31-2010
bug fix: an attempt to get it working for atom & pentium D
bug fix: tried to stabilize T-States support detection
bug fix: hopefully no more sound issues when over-clocking
added: more device-ids for nVidia cards
added: enable TM1 for all cores if one hits #prochot
added: slowly starting support for amd cpus

Update: 12-22-2010
added: T-States auto-generation (GenerateTStates)
added: a fix for incompatible p-states number (mbp4,1 & mba1,1 for now)
added: device-ids for ATI Radeon HD 4650

Update: 12-20-2010
added: png files proper to FreeBSD & OpenBSD (Thanks to Blackosx)
added: support for nvidia's device-id 0x10DE10C3
corrected: minor changes to SMBios default values

Update: 12-14-2010
added: feature to activate Thermal Monitor 1 & 2
added: EIST and IDA are now forced if inactive
added: C2Enhanced, C4Enhanced and Hard C4E (only when using oem ssdts)
added: more SMBios injections
bug fix: GraphicsEnabler not working for 9600M GT

Update: 11-19-2010
bug fix: typo zeroed frequency
bug fix: Turbo boost calculus
bug fix: Uakari FrameBuffer for ATI 5970
bug fix: "over the limit" behavior
added: PStart key to choose the first p-state to begin with

Update: 11-14-2010
bug fix: cpu frequency calculation
bug fix: Vervet FrameBuffer for ATI 5770

added two keys: moreVolt & lessVolt that would affect all the states

Update: 11-13-2010
Attached File ( 3.19K ) Number of downloads: 26
p-states and c-states injections perfected
under/over-volting functionality
max turbo for the i-series
bclk & ratio injection for i-series too
editable number of pstates to load (cparm's idea)
mobile processors detection reworked
model injection corrected
eist and apic features detection added
boot-time temperature plus tjmax injection
lebidou's autodetection for ati, nvidia and intel
display-cfg injection added (hopefully working)
rom "characteristics" and "rom-size" smbios injection
and many more

Update: 07-13-2010
added support for newer intel CPUs (i7/i5/i3)
newer and more accurate CPU injection
a better FSB detection code
busratio injection implemented
healed other ACPI tables dependency on DSDT
more nVidia IDs added

Update: 06-04-2010
added 18seven's Quick-args macro
added ramdisk load capability at boot-time, thanks to Meklort
moved to i386/boot1 and removed checking for boot0

Update: 05-23-2010
Source code made available, from now on, in

Update: 05-14-2010
Heavily reworked on bootloader's code.
Themes are hopefully working again
got rid of old pci.plist
added more ati/nvidia/intel resolution/edid support
merged memory-detection
nVidia Nvcap, courtesy to asere
merged boot0hfs
...and many more

Initial release: 04-28-2010

Supported graphic cards

Manual Installation Procedures:

Snow Leopard

Leopard (Thanks to FKA)

To monitor your cpu's frequency, voltage, temperature... u may need:
Attached File ( 320.01K ) Number of downloads: 82

Enjoy, and keep tuned for next good news.

This post has been edited by valv: Jan 23 2011, 12:25 PM
Reason for edit: removed donations begging as per site policy
post Dec 14 2010, 03:22 PM
Post #2
QUOTE (valv @ Dec 14 2010, 02:21 PM) *

Hi valv.
Just a question.
Your last source match with your new re-brand?
here --> ??

MotherBoard: Asus P6T Deluxe V.1 BIOS version 2101
CPU: Intel Core i7 940 @2.93 stock speed
RAM: (12GB) Corsair Dominator DDR3 1600MHz TR3X6G1600C8D
GPU: Nvidia Quadro FX 5600 1,5 Gb DDR3 (id: 0x10de 0x019d)
OS: (OSX 10.5.8 / 10.6.2) Bootloader: (Chameleon 2 RC5pre8 SATA-1)/ (AsereBNL v.1.1.9 SATA-2)/ My custom DSDT v3.1.4
Geekbench (64 bit mode): OSX 10.5.8 stock speed 10313 / OSX 10.6.2 stock speed 10616
post Dec 14 2010, 03:39 PM
Post #3
QUOTE (iFabio @ Dec 14 2010, 04:22 PM) *
Your last source match with your new re-brand?

yep, it is compiled straight from the branch.

This post has been edited by valv: Dec 14 2010, 03:40 PM
post Dec 31 2010, 04:35 PM
Post #4
updated to 5.0.9
happy new year everybody
post Jan 10 2011, 12:41 PM
Post #5
5.1.1 available on first post
post Jan 22 2011, 09:35 PM
Post #6
QUOTE (valv @ Jan 10 2011, 02:41 PM) *
5.1.1 available on first post


Finally got some time to test your branch smile.gif
Had to spend some time to figure out the new kernel flag... rolleyes.gif
Anyway PatchKernel=Yes did the job, my log:
Config: [hd(0,2)/Extra/] 4044 bytes.
CPU: Mobile Intel® Atom™ CPU N270 @ 1.60GHz
max: 12 current: 6
CPU: Tjmax ~ 105�∞C Temperature= ~ 45�∞C
CPU: Attempting to enable IDA Failed!
CPU: Vendor/Family/ExtFamily: 0x756e6547/0x6/0x0
CPU: Model/ExtModel/Stepping: 0x1c/0x1/0x2
CPU: Multipliers x10: max=120, min=60
CPU: MaxDiv/CurrDiv: 0x0/0x0
CPU: TSCFreq: 1600MHz
CPU: CPUFreq: 1600MHz
CPU: FSBFreq: 133MHz
CPU: Enhanced SpeedStep: 1
CPU: NoCores/NoThreads: 1/2
CPU: Features: 0x36d003a3
Theme: [hd(0,2)]/Extra/Themes/Default
Theme: [hd(0,2)]/Extra/Themes/Default
Found mode 1360x768 in VESA Table
Config: [hd(0,2)/Extra/] 4044 bytes.
Setting boot-uuid to: 72F87C72-70C7-3D10-AD4C-87D6F627E543
header read size 200
mem_base 573b7400
Not enough space to restore image. Press any key to proceed with normal boot.
Loading Darwin 10.6
Loading kernel mach_kernel
Unable to locate _commpage_stuff_routine
LoadDrivers: /System/Library/Caches/
ACPI: [hd(0,2)/Extra/DSDT.aml] 23093 bytes.
Using PCI-Root-UID value: 0
Patched DMI Table
Found SMBIOS System Information Table 1
Customizing SystemID with : 434e4630-3038-4247-4658-c80aa922813e
efi_inject_get_devprop_string NULL trying stringdata
ACPI: [hd(0,2)/Extra/DSDT.aml] 23093 bytes.
ACPI: [hd(0,2)/Extra/SBST.aml] 48 bytes.
ACPI: [hd(0,2)/Extra/ECDT.aml] 83 bytes.
ACPI: [hd(0,2)/Extra/APIC.aml] 104 bytes.
Patched ACPI version 2 DSDT
Starting Darwin x86
Press any key to continue...

Main problem is the hibernate issue mellow.gif
I have to mention that this netbook(HP Mini 311) has built in/soldered 1GB of RAM and one expansion slot for up to 2GB, maybe there is abug on memory amount detection, no idea really...
aikidoka25 did a fix, but it works only for 3GB of RAM, fail on 2GB, we discus this HERE
I have to try with yours an 2GB of RAM, I will report later after RAM swap.

Good news your branch has GUI=No fixed, also I love the rest of the ACPI tables load, have to test Drop function too.
Since we are on this, I have a request, my plans are to integrate at least DSDT in BIOS, for that I need a simple way (chameleon) to load/test custom tables for windows too, what do you think, doable?

Ah, BTW what is this?
Unable to locate _commpage_stuff_routine

L.E. Just tried with 2GB, works, resume is fine, but it does take longer to hibernate, no idea why.
post Jan 23 2011, 02:00 PM
Post #7
Hi king,
glad to know u 've been taking time to test it. Thank u.
Regarding memory detection, u got it right. There still some work needed, especially for the soldered ram.
Also, in the actual state, the ACPI Drop function is usable on select tables only. Thus, am planning to add more flexibility for it on 5.1.5.
Though, loading custom tables into linux/windows systems, as of now, is still a distant dream. File system access is going to be the first stone. Afterwards, we could add offline registry edits (in the case of windows) and load custom hive at boot. So, doable? Yes, I'd like to say.
As of my limited understanding, the "_commpage_stuff_routine" appears if symbol doesn't exist. But that doesn't seem worrisome (to me at-least) as most kernels don't have it.

This post has been edited by valv: Jan 23 2011, 11:39 PM
post Jan 23 2011, 04:20 PM
Post #8
So how do we fix the hibernate issue for 3GB of RAM(1 soldered 2 on DIMM) in a way that would not brick 2GB hibernate..?
post Jan 23 2011, 11:35 PM
Post #9
I'd probably look further at solving this later. but it's not going to be a priority. I personally don't rely that much on hibernation.

This post has been edited by valv: Jan 24 2011, 12:21 PM
post Jan 25 2011, 06:40 AM
Post #10
QUOTE (valv @ Jan 24 2011, 01:35 AM) *
I'd probably look further at solving this later. but it's not going to be a priority. I personally don't rely that much on hibernation.

OK, seems I have to get into this hibernate bug, I will work on your branch and let you know if I find the proper fix.

L.E. A very lame fix is this:
mem_base = getmemorylimit() - allocSize;//TODO: lower this

printf("mem_base %x\n", mem_base);
/* Rek : hibernate fix
if (!((long long)mem_base+allocSize<1024*bootInfo->extmem+0x100000))

// valv: hibfix wink.gif
long long hibfix;
hibfix = mem_base+allocSize<1024*bootInfo->extmem+0x100000;
printf ("Not enough space to restore image. Press any key to proceed with normal boot.\n");
getc ();

Dunno if removing that check is bad or good but hibernate simple works now, both 2 or 3GB...
post Jan 26 2011, 09:07 PM
Post #11
Thank you for pointing this back to me.
I'd most likely remove it on next release, then we would see what other users get.
post Mar 11 2011, 07:38 PM
Post #12

Been trying Anval and so far, it works OK for me. However, I'd like to attempt something more advanced, and need your advice or help.

I have a Dell Inspiron E6510 with an nVidia NVS3100M graphics adapter. My understanding is that it can drive 3 displays, the internal plus two external via the 2 DVI connectors on the docking station. With krazubu's help, I have an NVCAP and 2 display-cfg strings that currently allow me to run the internal display, and one other display on one of the DVI ports (it doesn't matter which one). However, plugging into a 2nd DVI port at the same time makes all screens go black; when I unplug either one of the DVI ports, the remaining two (internal and one DVI) come back to life. I also tried using the Fn+F8 keypress, which is supposed to send the output of the display to an external source, but trying that hung the OS and required a hard reset.

However, is it possible to use Anval to either:

- Inject THREE display-cfg strings so I can run all three displays at once, OR
- Provide injection in some way so that the primary display on the laptop can be mirrored on 1 DVI port, and have a 2nd display running on the other DVI port?

Any help you can provide here would be greatly appreciated; thanks!

This post has been edited by crackmac: Mar 11 2011, 07:39 PM

Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: