ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

9 Pages V  « < 5 6 7 8 9 >  
Start a new topic Add Reply
> Intelcpumonitor, IntelCPUMonitor Plug-in Topic
kyndder
post Jan 25 2012, 03:12 AM
Post #121
QUOTE (Slice @ Jan 24 2012, 06:12 AM) *
One more attempt to make it working
[attachment=3991:IntelCPU...t_rev505.zip]


This revision is also working for me...

Thanks Slice!

Asus P8Z77-V LK Firmware 1001 / Core i5-2300 Sandy Bridge / Geekbench
westwaerts
post Jan 26 2012, 05:55 PM
Post #122
works great on i7. thx
( could it be, that i lost radeon.kext gpu diode for it ?)
First Unit: i7 2600k, GA-Z68MA-D2H-B3, ATI HD 5670
10.7.5
Slice
post Jan 27 2012, 08:42 AM
Post #123
Rev 506 with corrections for Atom Core count and Thread count.
Attached File  IntelCPUMonitor.kext_rev506.zip ( 23.03K ) Number of downloads: 172
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.2, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
juanerson
post Jan 27 2012, 06:01 PM
Post #124
Works great, now is showing correctly the number of threads (CPU T8100). This is the log in console:
CODE
27/01/12 13:11:08,000 kernel: IntelCPUMonitor: CPU family 0x6, model 0x17, stepping 0x6, cores 2, threads 2
27/01/12 13:11:08,000 kernel: IntelCPUMonitor: BusClock=200MHz FSB=800MHz
27/01/12 13:11:08,000 kernel: IntelCPUMonitor: Platform string M82
27/01/12 13:11:08,000 kernel: IntelCPUMonitor: CPU Tjmax 105

Thank you very much.
VIT M2420-01 Core i3-2330M HD3000. ML 10.8.1 & Win7

HP Compaq 6720s hacked F.0D Bios: Upgraded T8100 + 4GB 667 + GMAX3100 (2a02 revC) + Native SpeedStep + DSDT v0.30 + AD1981HD (VoodooHDA) + Rebranded BCM4312. Mac OS X 10.6.8: (Retail) + C2RC5m r1291 + MacBook4,2. Win7
xmen1
post Jan 28 2012, 04:27 PM
Post #125
Hi, when I install plugins fakesmc, IntelCPUMonitor and SuperIOFamily.kext... in the kernel log does not appear to me:
AppleIntelCPUPowerManagement: Turbo Ratios 1144
only appear AppleIntelCPUPowerManagement: initialization complete
AppleIntelCPUPowerManagementClient: ready

but if I remove these plugins already appears:
AppleIntelCPUPowerManagement:Turbo Ratios 1144
AppleIntelCPUPowerManagement: initialization complete
AppleIntelCPUPowerManagementClient: ready
someone can help me? why does this happen? sorry my english.

This post has been edited by xmen1: Jan 28 2012, 04:36 PM
Mobo: Gigabyte GA-P55A-UD3 (rev 1.0) Bios F11 CPU: Intel Core i5-760 HD: OCZ-AGILITY 3 120 GB/Western Cav. Blue 500 GB
Mem: 8GB DDR3 1600 MHz G Skill Network LAN: Lnx2Mac's RTL81xx Audio: Patch ALC888 Graphic: Asus HD 6870 SO's: OS X MLion 10.8.2/Win7/8
Slice
post Jan 29 2012, 08:50 PM
Post #126
Thank you for the report, but I don't know an answer for the question.
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.2, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
xmen1
post Jan 29 2012, 09:37 PM
Post #127
Thanks Slice, but also can not understand why? that plugins will disable the turbo Boost? this affects native power management??

This post has been edited by xmen1: Jan 29 2012, 09:37 PM
Mobo: Gigabyte GA-P55A-UD3 (rev 1.0) Bios F11 CPU: Intel Core i5-760 HD: OCZ-AGILITY 3 120 GB/Western Cav. Blue 500 GB
Mem: 8GB DDR3 1600 MHz G Skill Network LAN: Lnx2Mac's RTL81xx Audio: Patch ALC888 Graphic: Asus HD 6870 SO's: OS X MLion 10.8.2/Win7/8
Slice
post Jan 30 2012, 05:59 AM
Post #128
QUOTE (xmen1 @ Jan 30 2012, 01:37 AM) *
Thanks Slice, but also can not understand why? that plugins will disable the turbo Boost? this affects native power management??

If you look into the sources then you may see that there are no any "disable" operations. So I don't know what is the effect.
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.2, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
3.14r
post Jan 30 2012, 08:31 AM
Post #129
Hi,
I've just tested the 506 version of the IntelCPUMonitor.kext (together with FakeSMC.kext of the same version) and it shows too low temps for the CPU. The CPU is Core Duo T2500. Usual IDLE temps for this CPU are 40-45C. iStat shows 25-29c which is not likely to be the true values. Other CPU info, however is shown correctly.

If anything could be done to fix this?
Thanks
some old harware
Slice
post Jan 30 2012, 11:40 AM
Post #130
QUOTE (3.14r @ Jan 30 2012, 12:31 PM) *
Hi,
I've just tested the 506 version of the IntelCPUMonitor.kext (together with FakeSMC.kext of the same version) and it shows too low temps for the CPU. The CPU is Core Duo T2500. Usual IDLE temps for this CPU are 40-45C. iStat shows 25-29c which is not likely to be the true values. Other CPU info, however is shown correctly.

If anything could be done to fix this?
Thanks

Do the follow.
1. Find in kernel log your detected TjMax. For example
CODE
IntelCPUMonitor: CPU Tjmax 90

The value seems to be wrong for you.
2. Put the computer to sleep for a two hours. It will be cooled to the room temperature. Are you know it with ordinary termometer? For example it is 25C.
3. Wake up and immediately see CPU temperature. You see, for example, 15C.
4. Now calculate the better TjMax
newTjMax = oldTjMax + 25 - 15 = 100
5. Write the value into IntelCPUMonitor.info.plist
CODE
            <key>TjMax</key>
            <integer>100</integer>

6. Delete kernelcache and reboot.
7. Report here, please your results, Including CPU data
CODE
IntelCPUMonitor: CPU family 0x6, model 0x17, stepping 0x6, cores 2, threads 0

Here is my results: wake after long sleep.
Attached File  Screen_shot_2012_05_27_at_11.06.12.png ( 32.35K ) Number of downloads: 36
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.2, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
xmen1
post Jan 30 2012, 09:25 PM
Post #131
QUOTE (Slice @ Jan 30 2012, 05:59 AM) *
If you look into the sources then you may see that there are no any "disable" operations. So I don't know what is the effect.

Ok thanks, Anyway something is wrong, already tested several versions of the plugins, but not solved this problem, just by removing these two plugins.
Mobo: Gigabyte GA-P55A-UD3 (rev 1.0) Bios F11 CPU: Intel Core i5-760 HD: OCZ-AGILITY 3 120 GB/Western Cav. Blue 500 GB
Mem: 8GB DDR3 1600 MHz G Skill Network LAN: Lnx2Mac's RTL81xx Audio: Patch ALC888 Graphic: Asus HD 6870 SO's: OS X MLion 10.8.2/Win7/8
3.14r
post Jan 31 2012, 10:19 AM
Post #132
Slice thanks for the info.

I've checked TjMax with Intel's data (I assume Tjunction=TjMax, is that correct?) and it is 100c. While the kernel log shows this:
CODE
Jan 31 04:48:26 localhost kernel[0]: IntelCPUMonitor: CPU family 0x6, model 0xe, stepping 0x8, cores 2, threads 2
Jan 31 04:48:26 localhost kernel[0]: IntelCPUMonitor: Using efi
Jan 31 04:48:26 localhost kernel[0]: IntelCPUMonitor: BusClock=166MHz FSB=665MHz
Jan 31 04:48:26 localhost kernel[0]: IntelCPUMonitor: Platform string K22
Jan 31 04:48:26 localhost kernel[0]: IntelCPUMonitor: CPU Tjmax 85
So I guess, instead of 85 TjMax should be 100? I've changed the TjMax value in Info.plist to 100 (was 0) and it now kernel log shows this:
CODE
Jan 31 12:01:47 localhost kernel[0]: IntelCPUMonitor: CPU family 0x6, model 0xe, stepping 0x8, cores 2, threads 2
Jan 31 12:01:47 localhost kernel[0]: IntelCPUMonitor: Using efi
Jan 31 12:01:47 localhost kernel[0]: IntelCPUMonitor: BusClock=166MHz FSB=665MHz
Jan 31 12:01:47 localhost kernel[0]: IntelCPUMonitor: Platform string K22
Jan 31 12:01:47 localhost kernel[0]: IntelCPUMonitor: CPU Tjmax 100
and iStatPro reports IDLE temps ~40c which is more likely to be true.

Thanks!
some old harware
Slice
post Jan 31 2012, 10:55 AM
Post #133
So, you have YONAH stepping 8 (?) that isn't known for me so far. I had YONAH stepping 2 and my TjMax=85. I am sure ±5˚.
OK, now I can add your value to the kext but I wish you to make the test with sleep.

No, Tjunction at Intel site is not TjMax. It is a temperature when CPU will dead while TjMax is a calibrated value for thermometer.
We set different TjMax values for different CPUs as found from tests.
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.2, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
3.14r
post Feb 1 2012, 02:26 AM
Post #134
QUOTE (Slice @ Jan 31 2012, 12:55 PM) *
So, you have YONAH stepping 8 (?) that isn't known for me so far. I had YONAH stepping 2 and my TjMax=85. I am sure ±5˚.
OK, now I can add your value to the kext but I wish you to make the test with sleep.
I'd gladly did that test if I had sleep working as it should. Unfortunately my notebook can't wake from sleep. Restart doesn't work either. It just turns off but fails to boot as it should normally do while restarting. I've tested many different fixes for that, but no joy so far. Shutdown, however works (with DSDT fix).

BTW it is SL8VP CPU (taken from MacMini). Here you can see that Intel makes different versions of the same CPU. These versions, in this case have different stepping.

QUOTE
No, Tjunction at Intel site is not TjMax. It is a temperature when CPU will dead while TjMax is a calibrated value for thermometer.
We set different TjMax values for different CPUs as found from tests.
I see... Thanks for the info. It seems TjMax=100 value fix the temp readings. A coincidence I guess smile.gif

One more thing to add. A year ago (while experimenting with OS X install) I've had some old FakeSMC version providing correct readings. Unfortunately I no longer have that kext and can't remember which version it was. The point is, that the above mentioned kext had the correct values set by default.

This post has been edited by 3.14r: Sep 21 2013, 02:17 PM
some old harware
Flashe
post Feb 1 2012, 01:17 PM
Post #135
Hello everyone,

Again me Slice,
The application SMCMonitor don't work i don't know why if IntelCPUMonitor does support my processor or SMCMonitor.


Processor:i7 2630QM (Sandy bridge) 2Ghz.

http://ark.intel.com/products/52219/Intel-...Cache-2_00-GHz)


IntelCPUMonitor:Based on code by mercurysquad,superhai ©2008

01/02/12 13:00:03,000 kernel: User defined TjMax=0
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=1 LocalApicId=0 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=2 LocalApicId=1 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=3 LocalApicId=2 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=4 LocalApicId=3 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=5 LocalApicId=4 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=6 LocalApicId=5 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=7 LocalApicId=6 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=8 LocalApicId=7 Enabled


13:00:25 localhost kernel[0]: IntelCPUMonitor: CPU family 0x6, model 0x2a, stepping 0x7, cores 4, threads 8
13:00:25 localhost kernel[0]: IntelCPUMonitor: Using efi
13:00:25 localhost kernel[0]: IntelCPUMonitor: BusClock=99MHz FSB=399MHz
13:00:25 localhost kernel[0]: IntelCPUMonitor: Platform string T9
13:00:25 localhost kernel[0]: IntelCPUMonitor: CPU0 Tjmax 100
13:00:25 localhost kernel[0]: IntelCPUMonitor: CPU1 Tjmax 100
13:00:25 localhost kernel[0]: IntelCPUMonitor: CPU2 Tjmax 100
13:00:25 localhost kernel[0]: IntelCPUMonitor: CPU3 Tjmax 100


13:00:03,000 kernel: AppleIntelCPUPowerManagement: Turbo Ratios 6689
13:00:03,000 kernel: AppleIntelCPUPowerManagement: (built 21:08:10 Aug 9 2011) initialization complete
13:00:03,000 kernel: RTC: Only single RAM bank (128 bytes)

Can you explain if it of change do in the IntelCPUMonitor or the problem come others (SMCMonitor).


Thanks a lot.
Carte mere : Asus P5K Premuim Wifi Ap /Memoire:Kingston (2*2) 1066 mhz /Processeur : Intel E8400 3 Ghz /Ventirad : Asus Evo /Carte Graphique : Asus (nVidia ) En 9600 Gt Hdmi 512 Mo
3 Disques Dur Maxtor 500 Gigas 32 mo Cache.
uncommah
post Feb 1 2012, 04:00 PM
Post #136
for Intel C2D T9300 with rev.506 it shows 1 core instead of 2. but was correct on previous revisions.
CODE
kernel[0]: IntelCPUMonitor: CPU family 0x6, model 0x17, stepping 0x6, cores 1, threads 2
Asus V1Sn ~ MacBookPro4,1
Intel® Core 2 Duo T9300 (2.5GHz) / DDR2 667 MHz / NVIDIA GeForce 9500M GS 512MB / Mobile Intel® PM965 Express + ICH8 / ALC660 / Intel® Wireless WiFi Link 4965AGN Apple Atheros AR5008 / eSATA (JMicron JMB360) / Intel® 82566MM Gigabit Ethernet
Slice
post Feb 1 2012, 07:50 PM
Post #137
QUOTE (Flashe @ Feb 1 2012, 05:17 PM) *
Hello everyone,

Again me Slice,
The application SMCMonitor don't work i don't know why if IntelCPUMonitor does support my processor or SMCMonitor.


Processor:i7 2630QM (Sandy bridge) 2Ghz.

http://ark.intel.com/products/52219/Intel-...Cache-2_00-GHz)


IntelCPUMonitor:Based on code by mercurysquad,superhai ©2008

01/02/12 13:00:03,000 kernel: User defined TjMax=0
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=1 LocalApicId=0 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=2 LocalApicId=1 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=3 LocalApicId=2 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=4 LocalApicId=3 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=5 LocalApicId=4 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=6 LocalApicId=5 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=7 LocalApicId=6 Enabled
01/02/12 13:00:03,000 kernel: AppleACPICPU: ProcessorId=8 LocalApicId=7 Enabled


13:00:25 localhost kernel[0]: IntelCPUMonitor: CPU family 0x6, model 0x2a, stepping 0x7, cores 4, threads 8
13:00:25 localhost kernel[0]: IntelCPUMonitor: Using efi
13:00:25 localhost kernel[0]: IntelCPUMonitor: BusClock=99MHz FSB=399MHz
13:00:25 localhost kernel[0]: IntelCPUMonitor: Platform string T9
13:00:25 localhost kernel[0]: IntelCPUMonitor: CPU0 Tjmax 100
13:00:25 localhost kernel[0]: IntelCPUMonitor: CPU1 Tjmax 100
13:00:25 localhost kernel[0]: IntelCPUMonitor: CPU2 Tjmax 100
13:00:25 localhost kernel[0]: IntelCPUMonitor: CPU3 Tjmax 100


13:00:03,000 kernel: AppleIntelCPUPowerManagement: Turbo Ratios 6689
13:00:03,000 kernel: AppleIntelCPUPowerManagement: (built 21:08:10 Aug 9 2011) initialization complete
13:00:03,000 kernel: RTC: Only single RAM bank (128 bytes)

Can you explain if it of change do in the IntelCPUMonitor or the problem come others (SMCMonitor).


Thanks a lot.

Sorry but I don't understand what is the question. I see in your kernek-log all is correct.
If you mean 8 CPU but 4 cores then it mean 8 logical CPU and only 4 physical. And we measure temperature only for physical things.

QUOTE (uncommah @ Feb 1 2012, 08:00 PM) *
for Intel C2D T9300 with rev.506 it shows 1 core instead of 2. but was correct on previous revisions.
CODE
kernel[0]: IntelCPUMonitor: CPU family 0x6, model 0x17, stepping 0x6, cores 1, threads 2

Yes, it is a bug in 506. I was corrected them for Atom and randomly created new mistake. My proposition is to use rev505 as you have no Atom.
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.2, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
macandrea
post Feb 1 2012, 09:12 PM
Post #138
Hi everyone, here is my setup:

z68 chipset (ASROCK Z68 PRO3)
i7 2600k processor
MacMini 5,3 in smbios

no processor ssdt, speedstep enabled from UEFI.

When using fakesmc kext only I'm getting the "Turbo Ratios 1234" message on AICPUPM initialization, but I'm not reaching turbo states at all
->PStatesReached: 16 17 24 30 32 34

If using fakesmc + intelcpumonitor I'm not getting any turbo ratios message but I'm getting proper turbo states:
->PStatesReached: 16 17 28 33 35 36 37

I'm using version 507 for both kexts. Any idea of what might be the reason?

Thank you Slice for your great work!!
Flashe
post Feb 1 2012, 10:38 PM
Post #139
QUOTE (Slice @ Feb 1 2012, 08:50 PM) *
Sorry but I don't understand what is the question. I see in your kernek-log all is correct.
If you mean 8 CPU but 4 cores then it mean 8 logical CPU and only 4 physical. And we measure temperature only for physical things.



Ok,thanks for the quick reply.My question is the application SMCMonitor does not display info on the processor why ?

This photo display GPU frequency,CPU temp,CPU frequency,Northbridge temp,CPU Voltage,Memory voltage ect ect...

Photo post message 113 by eliquel.




For me does not display info on hardware (processor). Sorry my english poor.
Carte mere : Asus P5K Premuim Wifi Ap /Memoire:Kingston (2*2) 1066 mhz /Processeur : Intel E8400 3 Ghz /Ventirad : Asus Evo /Carte Graphique : Asus (nVidia ) En 9600 Gt Hdmi 512 Mo
3 Disques Dur Maxtor 500 Gigas 32 mo Cache.
Slice
post Feb 4 2012, 04:59 AM
Post #140
Corrected core count. Soory for the mistake in rev 506.
Attached File  IntelCPUMonitor.kext_rev508.zip ( 22.39K ) Number of downloads: 1187
Пожалуйста, прочитайте ЧаВо!
i3-2120 GA-H61M-S1, Radeon HD6670, ALC887(VoodooHDA 2.8.4), OS⌘10.9.2, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2

9 Pages V  « < 5 6 7 8 9 >
Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: