ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

9 Pages V  « < 6 7 8 9 >  
Start a new topic Add Reply
> Intelcpumonitor, IntelCPUMonitor Plug-in Topic
westwaerts
post Feb 5 2012, 09:15 AM
Post #141
SMCUtils shows strange P&C States

1600, 4200, 4300, .... 5801

whos wrong ? me or ?

(btw how to attach pics here ?)

This post has been edited by westwaerts: Feb 5 2012, 09:20 AM
First Unit: i7 2600k, GA-Z68MA-D2H-B3, ATI HD 5670
10.7.5
Slice
post Feb 5 2012, 10:01 AM
Post #142
QUOTE (westwaerts @ Feb 5 2012, 01:15 PM) *
SMCUtils shows strange P&C States

1600, 4200, 4300, .... 5801

whos wrong ? me or ?

(btw how to attach pics here ?)

What is SMCutil?
CODE
MacDell:~ slice$ SMC_util2 -l
  #KEY  [ui8 ]  (bytes 00 00 00 1b)
  MSSD  [si8 ]  (bytes 03)

1600 and so on is not possible here.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.7), OS⌘10.9.5, OS⌘ 10.7.5 Clover HWSensors3 Realtek LAN v3.1.2
westwaerts
post Feb 5 2012, 07:50 PM
Post #143
QUOTE (Slice @ Feb 5 2012, 11:01 AM) *
What is SMCutil?
CODE
MacDell:~ slice$ SMC_util2 -l
  #KEY  [ui8 ]  (bytes 00 00 00 1b)
  MSSD  [si8 ]  (bytes 03)

1600 and so on is not possible here.


SMC Monitor 0.2 ( oldnapalm) showed me that
MRS Dumper ( flaked) showed me only 1600 and 3400 p-states active.
IOReg shows 19 performance states, but they dont work.

How does P-states work with i7, i am a little confused, also seems to freeze to 1600 after sleep.
First Unit: i7 2600k, GA-Z68MA-D2H-B3, ATI HD 5670
10.7.5
Slice
post Feb 6 2012, 11:43 AM
Post #144
Look into
System/Library/Extensions/IOPlatformPluginFamily.kext/Contents/PlugIns/ACPI_SMC_PlatformPlugin.kext/Contents/Resources/iMac12_2.plist
and compare with my settings
CODE
      <key>ConfigArray</key>
      <array>
        <dict>
          <key>model</key>
          <string>MacBook2,1</string>
            <key>restart-action</key>
            <dict>
                <key>cpu-p-state</key>
                <integer>0</integer>
            </dict>
        </dict>
      </array>

It depends on your chosen MacModel.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.7), OS⌘10.9.5, OS⌘ 10.7.5 Clover HWSensors3 Realtek LAN v3.1.2
rene
post Feb 13 2012, 07:11 PM
Post #145
http://www.freepic.nl/img=6a2976f0e8

http://www.freepic.nl/img=9e606d1cbf
http://www.freepic.nl/img=a029d23c04


This revision works also for me. (GA-Z68X-UD3H-B3 i7-2600K).

Slice, thank you so much for your hardwork.

This post has been edited by rene: Feb 13 2012, 07:22 PM
GA-Z68X-UD3H-B3 i7-2600K; 8GB; 8800GT 512MB
westwaerts
post Feb 15 2012, 07:50 PM
Post #146
@slice

thx i worked the wrong p-states out. added a SSDT for my i7, so all values are correct now.

but what did you mean by

<key>restart-action</key>
<dict>
<key>cpu-p-state</key>
<integer>0</integer>

i only have the ringFreqTables in config array

This post has been edited by westwaerts: Feb 15 2012, 07:52 PM
First Unit: i7 2600k, GA-Z68MA-D2H-B3, ATI HD 5670
10.7.5
Slice
post Feb 16 2012, 08:29 AM
Post #147
I mean you have to add this lines into your plist.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.7), OS⌘10.9.5, OS⌘ 10.7.5 Clover HWSensors3 Realtek LAN v3.1.2
magnifico
post Feb 18 2012, 11:42 AM
Post #148
Hi slice
Please look my kernel log why i have fsb 401 ?
I have installed your kext 5.08

CODE
User defined TjMax=0
Feb 18 10:42:07 localhost kernel[0]: IT87x: found ITE IT8728F
Feb 18 10:42:07 localhost kernel[0]: IntelCPUMonitor: CPU family 0x6, model 0x2a, stepping 0x7, cores 4, threads 8
Feb 18 10:42:07 localhost kernel[0]: IntelCPUMonitor: Using efi
Feb 18 10:42:07 localhost kernel[0]: IntelCPUMonitor: BusClock=100MHz FSB=401MHz
Feb 18 10:42:07 localhost kernel[0]: IntelCPUMonitor: Platform string T9
Feb 18 10:42:07 localhost kernel[0]: IntelCPUMonitor: CPU0 Tjmax 98
Feb 18 10:42:07 localhost kernel[0]: IntelCPUMonitor: CPU1 Tjmax 98
Feb 18 10:42:07 localhost kernel[0]: IntelCPUMonitor: CPU2 Tjmax 98
Feb 18 10:42:07 localhost kernel[0]: IntelCPUMonitor: CPU3 Tjmax 98


Thanks friend rolleyes.gif
Asrock z87 oc formula / i7 4770k @4,7 Ghz \SSD Samsung 840 Pro 128 GB\ 2x128GB SuperSSpeed S301(SLC) RAID OSX Software\ Samsung 840 EVO 120 GB\Nvidia 660 Gigabyte OC \Corsair Vengeance 4x4GB (16GB) DDR3 1600
CloverUEFI mode [/b] Score GeekBench said the flea nut to give me time and I will pound
Slice
post Feb 18 2012, 01:10 PM
Post #149
As well as TjMax=98 but not 100.
There are deviations.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.7), OS⌘10.9.5, OS⌘ 10.7.5 Clover HWSensors3 Realtek LAN v3.1.2
magnifico
post Feb 18 2012, 01:13 PM
Post #150
QUOTE (Slice @ Feb 18 2012, 02:10 PM) *
As well as TjMax=98 but not 100.
There are deviations.


So ?

For you work perfect?
Asrock z87 oc formula / i7 4770k @4,7 Ghz \SSD Samsung 840 Pro 128 GB\ 2x128GB SuperSSpeed S301(SLC) RAID OSX Software\ Samsung 840 EVO 120 GB\Nvidia 660 Gigabyte OC \Corsair Vengeance 4x4GB (16GB) DDR3 1600
CloverUEFI mode [/b] Score GeekBench said the flea nut to give me time and I will pound
Slice
post Feb 19 2012, 08:35 AM
Post #151
QUOTE (magnifico10 @ Feb 18 2012, 05:13 PM) *
So ?

For you work perfect?

I see 798MHz instead of 800 and 57C instead of ... 60? 55? How do I know the real one?
Don't know why I need more accuracy.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.7), OS⌘10.9.5, OS⌘ 10.7.5 Clover HWSensors3 Realtek LAN v3.1.2
magnifico
post Feb 19 2012, 10:24 AM
Post #152
QUOTE (Slice @ Feb 19 2012, 09:35 AM) *
I see 798MHz instead of 800 and 57C instead of ... 60? 55? How do I know the real one?
Don't know why I need more accuracy.


slice, what you need, what should I do?
My cpu overclocked to 47x100 ( sandy bridge i7 2600k )
47 = fsb
100 = bclk

You need see my smc monitor ?

This post has been edited by magnifico10: Feb 19 2012, 10:28 AM
Asrock z87 oc formula / i7 4770k @4,7 Ghz \SSD Samsung 840 Pro 128 GB\ 2x128GB SuperSSpeed S301(SLC) RAID OSX Software\ Samsung 840 EVO 120 GB\Nvidia 660 Gigabyte OC \Corsair Vengeance 4x4GB (16GB) DDR3 1600
CloverUEFI mode [/b] Score GeekBench said the flea nut to give me time and I will pound
Slice
post Feb 19 2012, 09:20 PM
Post #153
QUOTE (magnifico10 @ Feb 19 2012, 02:24 PM) *
slice, what you need, what should I do?
My cpu overclocked to 47x100 ( sandy bridge i7 2600k )
47 = fsb
100 = bclk

You need see my smc monitor ?

No.
Your BusClock is extracted from DeviceTree/efi/platform. See IORegistryExplorer to understand.
Attached File  Screen_shot_2012_02_20_at_1.14.24.png ( 19.27K ) Number of downloads: 60

And FSB = BusClock*4.
CODE
/*
* Copyright (c) 1998-2009 Apple Computer, Inc. All rights reserved.

            busSpeedMTs = cpuInfo->externalClock;
            busSpeedMTs *= 4;  // Assume quad-pumped FSB
            DEBUG_LOG("SMBIOS: FSB speed (MT/s) = %u\n", busSpeedMTs);

47 in your case is multiplier.

What do you want to tell me?
IntelCPUMonitor just shows you real data.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.7), OS⌘10.9.5, OS⌘ 10.7.5 Clover HWSensors3 Realtek LAN v3.1.2
osxfr33k
post Mar 12 2012, 01:58 AM
Post #154
So is the bus Clock and FSB correct? Mine reads about the same as magnifico10, but my TJMax is 100. The values would seem correct if multiplied by 4, since 4 cores right? If not how do we correct it so it does show the correct Bus clock and FSB? There is no way it has a bus clock only 400. I have the 2600QM which is 4 cores and the bus should be around 1600 yes or no?

This post has been edited by osxfr33k: Mar 12 2012, 05:20 AM
Clover pre 2837
Auto Patched DSDTs
5 towers: Asus Maximux Formula Special Editions with Rampage Formula Bios conversion, Gigabyte GA-EP35-DS4, GA-EP45-UD3P, GA-G41M-ES2, GA-Z68X-UD4-B3, Z77X-UP5-TH, i7-3770k
5 Quad Core Processors: QX6850/Q9650/Q6600/i7-2600K/i7-3770k
MAC PRO EARLY 2008 Xeon 8 Core/10GB RAM/4TB Seagates
Asus G51JX i7-720QM. 8GB Kingston Ram. HM55 Chipset
Asus Gamers Notebook G74SX-XT1, G750jx nearly 100 % osx clone
Dell Laptops D820, D830, XPS M1530, MacBookPro Late 2013 Retina GT750 1TB PCIe SSD
Slice
post Mar 12 2012, 11:37 AM
Post #155
bus, cores, chameleon...
CODE
/*
* Copyright (c) 1998-2009 Apple Computer, Inc. All rights reserved.

            busSpeedMTs = cpuInfo->externalClock;
            busSpeedMTs *= 4;  // Assume quad-pumped FSB
            DEBUG_LOG("SMBIOS: FSB speed (MT/s) = %u\n", busSpeedMTs);

Your bus speed is 100MHz, FSB=BUS*4=400MHz. www.intel.com
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.7), OS⌘10.9.5, OS⌘ 10.7.5 Clover HWSensors3 Realtek LAN v3.1.2
osxfr33k
post Mar 13 2012, 03:14 AM
Post #156
QUOTE (Slice @ Mar 12 2012, 05:37 AM) *
bus, cores, chameleon...
CODE
/*
* Copyright (c) 1998-2009 Apple Computer, Inc. All rights reserved.

            busSpeedMTs = cpuInfo->externalClock;
            busSpeedMTs *= 4;  // Assume quad-pumped FSB
            DEBUG_LOG("SMBIOS: FSB speed (MT/s) = %u\n", busSpeedMTs);

Your bus speed is 100MHz, FSB=BUS*4=400MHz. www.intel.com



I am completely lost here. I see in Ghz not Mhz. These values seem way off to me. Do you have a link that tells differently? Intel shows Ghz.

My Core 2 Duo 2.6GHZ processor shows 800Mhz for Bus Speed. No way should the Sandy Bridge 2630QM should be half as much as the Core2Duo Processor.

This post has been edited by osxfr33k: Mar 13 2012, 03:17 AM
Clover pre 2837
Auto Patched DSDTs
5 towers: Asus Maximux Formula Special Editions with Rampage Formula Bios conversion, Gigabyte GA-EP35-DS4, GA-EP45-UD3P, GA-G41M-ES2, GA-Z68X-UD4-B3, Z77X-UP5-TH, i7-3770k
5 Quad Core Processors: QX6850/Q9650/Q6600/i7-2600K/i7-3770k
MAC PRO EARLY 2008 Xeon 8 Core/10GB RAM/4TB Seagates
Asus G51JX i7-720QM. 8GB Kingston Ram. HM55 Chipset
Asus Gamers Notebook G74SX-XT1, G750jx nearly 100 % osx clone
Dell Laptops D820, D830, XPS M1530, MacBookPro Late 2013 Retina GT750 1TB PCIe SSD
Slice
post Mar 13 2012, 08:59 AM
Post #157
Yes, Core2Duo often has BusSpeed=200 and FSB=800.
SandyBridge usually has BusSpeed=100 and FSB=400.
Just different definitions what different brands assume as BusSpeed. We should use Apple's understanding, not Asus.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.7), OS⌘10.9.5, OS⌘ 10.7.5 Clover HWSensors3 Realtek LAN v3.1.2
westwaerts
post Apr 2 2012, 09:22 AM
Post #158
@slice
i changed value in fakesmc RPit to k92, but intelCPU overwrites it to T9 ?
( model platform or CPU platform )

no problems with it, just playing round with smc values
( since we dont know much about it)
First Unit: i7 2600k, GA-Z68MA-D2H-B3, ATI HD 5670
10.7.5
Slice
post Apr 2 2012, 02:09 PM
Post #159
QUOTE (westwaerts @ Apr 2 2012, 01:22 PM) *
@slice
i changed value in fakesmc RPit to k92, but intelCPU overwrites it to T9 ?
( model platform or CPU platform )

no problems with it, just playing round with smc values
( since we dont know much about it)

You are right, this is a mistake.Should be customizable by info.plist.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.7), OS⌘10.9.5, OS⌘ 10.7.5 Clover HWSensors3 Realtek LAN v3.1.2
uncommah
post Apr 4 2012, 11:23 AM
Post #160
RPlt [8-ch8*] also must be in hex not string in plist.
Asus V1Sn ~ MacBookPro4,1
Intel® Core 2 Duo T9300 (2.5GHz) / DDR2 667 MHz / NVIDIA GeForce 9500M GS 512MB / Mobile Intel® PM965 Express + ICH8 / ALC660 / Intel® Wireless WiFi Link 4965AGN Apple Atheros AR5008 / eSATA (JMicron JMB360) / Intel® 82566MM Gigabit Ethernet

9 Pages V  « < 6 7 8 9 >
Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: