ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

 
Start a new topic Add Reply
> Working Downgrade Of Nvidia Drivers In Sl?
macfoern
post Feb 27 2011, 04:54 PM
Post #1
Hi,

is there a solution of a working nvidia graphics driver downgrade from 10.6.5+ to 10.6.4?

If i changed drivers 256.00.35f03 (10.6.7) to 19.5.8f01 (10.6.4) i got my system to boot with no errors/panics.
But the graphics are messed up. Background is fully black and dock/statusbar is fully white.
The system is fully running with CE/QI @ 2560x1600 and "useable".
I used EFI-String and Ven/Dev-ID inseration in NVDANV50Hal.kext

Is there a way to downgrade graphics framework?

Kexts i have changed so far...

GeForce.kext
GeForce7xxxGLDriver.bundle
GeForceGA.plugin
GeForceGLDriver.bundle
GeForceVADriver.bundle
NVDANV40Hal.kext
NVDANV50Hal.kext
NVDAResman.kext

I do this to get back GTX295 support in 10.6.5+

Cheers

This post has been edited by macfoern: Feb 27 2011, 05:11 PM
Intel Core2 Extreme QX9650 @ 4GHz (12x333/1,4v)
Gigabyte EP35-DS3R (rev. 2.1/Bios F4/100% DSDT-fixed)
8GB A-Data Vitesta Extreme Edition 1066+ DDR2 (5-6-6-15/2,3v)
Gainward NVidia GeForce GTX 295 1792MB Single PCB
SL 10.6.4 64-Bit / Win7 Enterprise x64
Apple PowerPC G5 Tower, Cinema Display 30", Aluminium Keyboard + Magic Mouse
KWODO
post Feb 28 2011, 12:10 AM
Post #2
QUOTE (macfoern @ Feb 27 2011, 05:54 PM) *
Hi,

is there a solution of a working nvidia graphics driver downgrade from 10.6.5+ to 10.6.4?

If i changed drivers 256.00.35f03 (10.6.7) to 19.5.8f01 (10.6.4) i got my system to boot with no errors/panics.
But the graphics are messed up. Background is fully black and dock/statusbar is fully white.
The system is fully running with CE/QI @ 2560x1600 and "useable".
I used EFI-String and Ven/Dev-ID inseration in NVDANV50Hal.kext

Is there a way to downgrade graphics framework?

Kexts i have changed so far...

GeForce.kext
GeForce7xxxGLDriver.bundle
GeForceGA.plugin
GeForceGLDriver.bundle
GeForceVADriver.bundle
NVDANV40Hal.kext
NVDANV50Hal.kext
NVDAResman.kext

I do this to get back GTX295 support in 10.6.5+

Cheers


GOT IT TO WORK.. Downgrading Drivers and OpenGL Framework...from 10.6.5-10.6.7 to 10.6.4.
http://www.mediafire.com/?5h6ob99i7zcj620

This post has been edited by KWODO: Feb 28 2011, 12:11 AM
ciiooo
post Mar 9 2011, 04:18 PM
Post #3
QUOTE (KWODO @ Feb 28 2011, 01:10 AM) *
GOT IT TO WORK.. Downgrading Drivers and OpenGL Framework...from 10.6.5-10.6.7 to 10.6.4.
http://www.mediafire.com/?5h6ob99i7zcj620


Thank you very much guapeton

Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: