ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

 
Start a new topic Add Reply
> Integrated Fingerprint Reader, AuthenTec Inc. AES2501A
bautzen
post Aug 23 2011, 01:10 PM
Post #1
Hi to all, I'm looking for a solution to this problem for my fingerprint Reader.
I own an HP nc6400 (intel version) that has the follow hardware:

(extract from Everest)
Device Properties:
Driver Description AuthenTec Inc. AES2501A
Driver Date 28/08/2007
Driver Version 7.9.0.4
Driver Provider AuthenTec, Inc.
INF File oem25.inf
Hardware ID USB\Vid_08ff&Pid_2580&Rev_0623
Location Information Fingerprint Sensor

Under System Profiler it has recognized correctly as:
DeviceID: 0x2580 (9600 in Decimal)
VendorID: 0x08FF (2303 in Decimal)


I know that there is a Software suite from UPEK that enable the sensor scanner but only for 2 specific models (extracted from Info.plist of the ProtectorSuite/TrueSuite 1.x and 2.x):
DeviceID: 0x2016 (8214 in Decimal)
VendorID: 0x0483 (1155 in Decimal)
0x147e (5246 in Decimal)

I have just test modifing these values but without success: the app is not able to found the fingerprint device.

I have download all these versions:
ProtectorSuiteMac1_0.dmg HERE
ProtectorSuiteMac1_1.dmg HERE
ProtectorSuiteMac1_2.dmg HERE
TrueSuite_2.0.186.dmg

Decompressing ProtectorSuite1_x with 7zip, I can found in this location: ProtectorSuiteMac1_2\2\Protector Suite\ProtectorSuite.pkg\Contents\Archive.pax\Archive\Library\Application Support\Upek\Drivers\llusb.bundle\Contents\MacOS

this file: llusb

In TrueSuite 2 it doesn't exist!!!!

If I open it using Hexedit I can locate some matches with DeviceID 2016 and VendorID 0483,1476. Nothing about my DeviceID 2580.
Other interested things are:
... Expected Device type (VID %#x, PID %#x)....
... Found Expected Device (VID %#x, PID %#x) ....
... Open Device (VID %#x, PID %#x) ....

UPEK in 2010 bought AuthenTec Inc and the new chip is made from Thomson (example: Touchstrip TCRD4C - USB 147e:2016 etc)

Could I exchange all 2016 with 2580 and 0483 with 08ff??
How could I make inside the pkg? Do I need Xcode o Pacifist?

Thanks for the help

Patrick

P.S.
I attach the llusb Attached File  llusb.zip ( 37.17K ) Number of downloads: 11


This post has been edited by bautzen: Aug 23 2011, 01:15 PM
bautzen
post Aug 24 2011, 08:02 AM
Post #2
What about this way? FPRINT PROJECT

I have found this message on internet about a personal porting of fprint on OSX 10.5.6 HERE

I haven’t knowledge about compile/decompile code sad.gif

Could someone help me and other AuthenTec's owner to enable this cool function?

Regards

Patrick
Aural Architect
post Nov 18 2013, 08:13 AM
Post #3
Any chance you still have any of those software packages archived? I've been having a terrible time trying to get ahold of any of the Mac versions of Authentec/Upek software (except for the newest version of TrueSuite which is not helpful)...

If you still have those PS dmgs or old TrueSuite dmgs & you would be willing to share them with me somehow, I would be most grateful!

I'm really still quite upset with Apple about the way/reason they bought the Authentec- and then especially the way they handled shutting it down- totally screwed over all of their customers! I have 5 of their devices as well as several softwares licenses purchased separately for access to all the features, two I bought JUST before the news of the take-over came out. Now I have no support or updates on either the Windows or OS X platform.

Anyway, the main goal I'm trying to accomplish is just to be able to use ANY one of my devices as an authentication method for LassPass on the OS X platform.


If anyone reading this has any ideas, advice, solutions, I would be so thankful & pleased!

Thanks so much!
ASUS P6T Deluxe v2 w/i7 @920 + 12GB Corsair XTC Gold DDR3 (@1600)
HIS ATI HD4670 Q-Ice Turbo 512GB GDDR3 dual-DVI & HIS ATI HD4650 512GB HDMI, DVI & VGA out : with 2 Acer 23" (H233H) wide monitors (not fully functional)
LG Super Multi Blue Drive (CH08LS10), Patriot 64GB Warp 2 SSD (S-ATA), plus about 6TB storage on other S-ATA HDs (and a couple USB, e-SATA & Firewire externals)
Firewire NOT working

Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: