ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

 
Start a new topic Add Reply
> Usb Audio - Iousbfamily Unable To Enumerate Device, IOUSBFamily failing to load USB Audio Device, Chameleon issue?
rockingturtle
post Sep 28 2011, 05:48 AM
Post #1
Hey Guys,

I just finished setting up lion on my Acer 5745G and it seems to be working real well [main thread : http://www.projectosx.com/forum/index.php?showtopic=1503]

For audio, the VHDA is working fine for me for output but I am getting a lot of static in the mic, I have tried fiddling with the prefpane settings but the noise doesn't go away.

I also have a USB HeadSet which I used when I was on 10.6.4 and it worked fine. But I am facing issues in getting it to work in Lion. Following are things I did and the results:

1) When I boot the system with USB Audio Dongle connected, its detected correctly and I am able to use it [so this implies its supported in Lion]
2) When I disconnect the dongle and reconnect it, it doesn't work, I installed the USB debug kexts from apple and attached the output [].
3) The dongle is working fine if I connect it to a 10.6 Snow leopard Virtual Machine running on Windows 7.
4) The dongle was working fine in 10.6.4, I have an external HDD on which I mirrored my 10.6.4 install before installing lion from scratch. I created the Lion install USB on the same hdd and upgraded the Chameleon Bootloader. Now when I boot it into 10.6.4 using this hdd, the dongle shows the same problem as in Lion.
5) All my USB devices are shown as inbuilt in System Information, I also have DSDT fixes for them, sleep works fine now.
6) I tried using USBBusFix but that doesn't help.
7) When I connect any other device to the same USB port, it functions properly.

USB Kexts:

CODE
com.apple.iokit.IOUSBHIDDriver 4.4.0 52 KB 48 KB 0x5fcf5000
com.apple.iokit.IOUSBUserClient 4.4.0 16 KB 12 KB 0x56fad000
com.apple.iokit.IOUSBFamily 4.4.0 472 KB 468 KB 0x57504000
com.apple.driver.AppleUSBMergeNub 4.4.0 24 KB 20 KB 0x5fc85000
com.apple.driver.AppleUSBEHCI 4.4.0 208 KB 204 KB 0x5ee42000
com.apple.driver.AppleUSBHub 4.4.0 180 KB 176 KB 0x5f7ce000
com.apple.driver.AppleUSBComposite 3.9.0 28 KB 24 KB 0x5fc7e000
com.apple.iokit.IOUSBMassStorageClass 3.0.0 64 KB 60 KB 0x5ff7e000
com.apple.driver.AppleUSBCDC 4.1.15 16 KB 12 KB 0x56f7c000


High level Error Message that I get:

CODE
11.659 [1] [0x80a0400] The IOUSBFamily was not able to enumerate a device.


More detailed output in the attached file.


Any idea what might be wrong ?

My initial thought is that its something to do with chameleon as it was working fine earlier in 10.6.4. Stopped working my cloned 10.6.4 install when I upgraded the chameleon boot loader. Anyone aware of such an issue.

Thanks in advance.
Rock
rockingturtle
post Sep 28 2011, 05:48 AM
Post #2
Attached File  USB_Debug_Output_acer5745G_USBAudioDevice.rtf ( 8.1K ) Number of downloads: 6


Attaching the USB Debug Output.
rockingturtle
post Sep 28 2011, 06:27 PM
Post #3
Guys..any suggestions on the above...

-Rock
rockingturtle
post Sep 30 2011, 10:38 AM
Post #4
After some trial and error I have been able to find a workaround. If I connect a USB hub to my laptop with the USB audio device already attached (note the usb must already be plugged into the hub).. it works !! tried couple of times (with reboot also) and worked fine.

Carrying a USB hub is clumsy though sad.gif any idea what might be wrong? is there a way to power down a USB device / port completely ?

I am guessing this might be a USB power state or smthing kind of a issue....

This post has been edited by rockingturtle: Sep 30 2011, 10:41 AM
rockingturtle
post Dec 15 2011, 09:35 AM
Post #5
Turned out that the USB device was faulty, I got a different USB Audio Dongle and it seems to work without problemo....

Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: