ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

54 Pages V  « < 24 25 26 27 28 > »   
Start a new topic Add Reply
> Uefi Booting On Ami Aptio Uefi Boards, experiences with other UEFI implementations are welcome
THe KiNG
post Aug 31 2012, 08:34 PM
Post #501
@dmazar

Top job again!

Test done with GA-Z77X-UP4 TH Beta BIOS F8d(the problematic one), all stuff included in UEFI BIOS except VBoxAppleSim with FlexRatio patch and AptioFix that I compiled myself from Clover svn and loaded from shell before boot:

I am happy to report that test where passed in all possible scenarios:
- ATI HD5870 Posted / HD4000 Auto(same as Disabled) / Reserved Memory space for Thunderbolt 128MB(default)
- ATI HD5870 Posted / HD4000 Auto(same as Disabled) / Reserved Memory space for Thunderbolt 512MB
- ATI HD5870 Posted / HD4000 Enabled / Reserved Memory space for Thunderbolt 128MB(default)
- ATI HD5870 Posted / HD4000 Enabled / Reserved Memory space for Thunderbolt 512MB
- ATI HD5870 / HD4000 Posted / Reserved Memory space for Thunderbolt 128MB(default)
- ATI HD5870 / HD4000 Posted / Reserved Memory space for Thunderbolt 512MB
- HD4000 Only / Reserved Memory space for Thunderbolt 128MB(default)
- HD4000 Only / Reserved Memory space for Thunderbolt 512MB

NVRAM logs, Firmware Memory Map from each test and VBoxAppleSim+AptioFix that I used(if anyone want to try same) attached:

Thanks!

Attached File  DriversUsed.zip ( 16.65K ) Number of downloads: 82

Attached File  UP4TH_F8D_Aptio_UEFI_Dumps.zip ( 25.95K ) Number of downloads: 22
STLVNUB
post Aug 31 2012, 08:42 PM
Post #502
QUOTE (THe KiNG @ Sep 1 2012, 06:34 AM) *
Test done with GA-Z77X-UP4 TH Beta BIOS F8d(the problematic one), all stuff included in UEFI BIOS except VBoxAppleSim with FlexRatio patch and AptioFix that I compiled myself from Clover svn and loaded from shell before boot:

What exactly is all stuff included in UEFI BIOS if you don't mind sharing.
Azrock Z77 Pro3, G1610 AMD HD7750 Clover/Ozmosis
Toshiba A660-0MR00R I7-7740QM GT330M 8 Gig Clover

dmazar
post Aug 31 2012, 09:05 PM
Post #503
QUOTE (Takio @ Aug 31 2012, 07:59 PM) *
Yay, got my Lion + Mountain Lion booted with UEFI on my Asus Maximus Extreme-Z with Bios 3304 (PM Patched)

With IGP enabled, it hangs right after loading kernel cache, i never got rid of this problem until i read about the IGP issues in last posts. I disabled the IGP and now everything works, except sleep that works with chameleon only.

Fresh installation of Clover R600 + DSDT for my Board.

smile.gif

Congrats!
Regarding sleep - maybe some issue with config.plist? If you have prepared DSDT, then make sure you have FixDsdtMask option set to 0 in ACPI section. You may also try disabling usb injection with USBInjection=No in PCI section.
HW: Asus P8P67-M, Intel Core i5-2300, 4GB, XFX HD-567X-ZHH3 SW: SL, L, ML: Clover UEFI boot
THe KiNG
post Aug 31 2012, 09:05 PM
Post #504
QUOTE (STLVNUB @ Aug 31 2012, 11:42 PM) *
What exactly is all stuff included in UEFI BIOS if you don't mind sharing.

Sure, I said earlier, I will say again:
Replaced Filesystem with EnhancedFatDxe for faster dumps...
Inserted:
- HfsPlus(Apple)
- Partition(Apple)
- FatBinary(Clover)
- Modded SMBios for MacPro3,1(AMIBCP)
dmazar
post Aug 31 2012, 09:09 PM
Post #505
QUOTE (THe KiNG @ Aug 31 2012, 10:34 PM) *
I am happy to report that test where passed in all possible scenarios:

Great! Till tomorrow ... when you flash the bios again blink.gif tongue.gif
HW: Asus P8P67-M, Intel Core i5-2300, 4GB, XFX HD-567X-ZHH3 SW: SL, L, ML: Clover UEFI boot
dmazar
post Aug 31 2012, 09:12 PM
Post #506
QUOTE (Chumnick @ Aug 31 2012, 05:52 PM) *
and if the parameter AUTO or DISABLE get a stop on ...

We can try to trace where it stops. Try this one: Attached File  StopEarlyTest.tar.lzma ( 11.81K ) Number of downloads: 3

There will be no DebugLog in NVRAM, just prints to screen. Tell me what is the last line you see when it stops or post a screenshot.
HW: Asus P8P67-M, Intel Core i5-2300, 4GB, XFX HD-567X-ZHH3 SW: SL, L, ML: Clover UEFI boot
THe KiNG
post Aug 31 2012, 09:18 PM
Post #507
QUOTE (dmazar @ Sep 1 2012, 12:09 AM) *
Great! Till tomorrow ... when you flash the bios again blink.gif tongue.gif

I really hope Gigabyte wont break things again...
If they do I will send a nuke to the HQ(j/k). tongue.gif
dmazar
post Aug 31 2012, 09:30 PM
Post #508
By the way, this board does not need full AptioFix. 90% of the code is not needed. Only maybe when Intel graphics is enabled and ML is booted without slide=0 (because of mem map: reserved 0000000020000000). If you are interested, I can prepare speciffic driver for this (and probably similar) board next week.
HW: Asus P8P67-M, Intel Core i5-2300, 4GB, XFX HD-567X-ZHH3 SW: SL, L, ML: Clover UEFI boot
Chumnick
post Aug 31 2012, 09:31 PM
Post #509
QUOTE (THe KiNG @ Aug 31 2012, 09:34 PM) *
Attached File  DriversUsed.zip ( 16.65K ) Number of downloads: 82

Hi King and dmazar,
with your drivers i can boot if the parameter AUTO or DISABLE, but initially receive this message [attachment=4952:King_drv.png], then Clover menu and then boot the system!

This post has been edited by Chumnick: Aug 31 2012, 09:32 PM
ASUS P8Z68 Deluxe/Gen3, Intel i7-2600k, 16Gb 1133Mh DDR3, Sapphire Radeon HD 6870 1024Mb, OSZ Vertex3 SSD 240Gb, MacOS X 10.8, Clover, iMac 12,2
Gigabyte GA-Z77X-UP5 TH, Intel i7 3770k, 16Gb 1600Mh, ASUS GeForce GTX 670 2048 MB, Intel SSD 120Gb, MacOS X 10.8, Clover, iMac 12,2
THe KiNG
post Aug 31 2012, 09:32 PM
Post #510
QUOTE (dmazar @ Sep 1 2012, 12:30 AM) *
By the way, this board does not need full AptioFix. 90% of the code is not needed. Only maybe when Intel graphics is enabled and ML is booted without slide=0 (because of mem map: reserved 0000000020000000). If you are interested, I can prepare speciffic driver for this (and probably similar) board next week.

I think is not productive to have separate driver for it, as long it works for everybody I am fine wink.gif
BTW I tested only 10.7.5 beta, not ML(trying to save some hair on my head..)
Takio
post Aug 31 2012, 09:36 PM
Post #511
QUOTE (dmazar @ Aug 31 2012, 11:05 PM) *
Congrats!
Regarding sleep - maybe some issue with config.plist? If you have prepared DSDT, then make sure you have FixDsdtMask option set to 0 in ACPI section. You may also try disabling usb injection with USBInjection=No in PCI section.


"FixDsdtMask=0" and "USBInjection=No" didn't work, system goes into sleep and with "USBInjection=No" i can wakeup the machine with my keyboard or mouse but got a black screen. Mainboard status led shows A0 = which means the system is back from sleep mode.


This post has been edited by Takio: Aug 31 2012, 09:58 PM
Asus Maximus IV Extreme-Z (Bios 3304 PM Patched)
Corsair CML16GX3M4A1600C9 4x4 GB | Asus ENGTX580 Direct CU II
Corsair Force GT SSD 120GB x 2 | Original Apple IR, Bluetooth, WiFi Module
THe KiNG
post Aug 31 2012, 09:39 PM
Post #512
QUOTE (Chumnick @ Sep 1 2012, 12:31 AM) *
Hi King and dmazar,
with your drivers i can boot if the parameter AUTO or DISABLE, but initially receive this message [attachment=4952:King_drv.png], then Clover menu and then boot the system!

I didn't tested with Clover, the reason I did this is I needed a way to minimize any possible bugs/alteration that could change the AptioFix results.
If you test with Clover VBoxAppleSim is not needed, if not you ned to hack your BIOS and do what I explained earlier.

OsxAptioFixDrv.efi was compiled from Clover svn source but on Windows(VS2010), the reason I don't use OS X for compile is that gcc even with redbull wont get same smaller size as with MSFT(anyone can check the size)
The size is vital when we deal with UEFI BIOS hacks...
Chumnick
post Aug 31 2012, 09:47 PM
Post #513
QUOTE (dmazar @ Aug 31 2012, 10:12 PM) *
We can try to trace where it stops. Try this one: Attached File  StopEarlyTest.tar.lzma ( 11.81K ) Number of downloads: 3

There will be no DebugLog in NVRAM, just prints to screen. Tell me what is the last line you see when it stops or post a screenshot.

With great pleasure to present [attachment=4953:IMG_0090.JPG]
ASUS P8Z68 Deluxe/Gen3, Intel i7-2600k, 16Gb 1133Mh DDR3, Sapphire Radeon HD 6870 1024Mb, OSZ Vertex3 SSD 240Gb, MacOS X 10.8, Clover, iMac 12,2
Gigabyte GA-Z77X-UP5 TH, Intel i7 3770k, 16Gb 1600Mh, ASUS GeForce GTX 670 2048 MB, Intel SSD 120Gb, MacOS X 10.8, Clover, iMac 12,2
Al3XKOol
post Aug 31 2012, 09:53 PM
Post #514
Debuglog whit new OsxAptioFixDrv.efi

after fisrt boot stop most of the time, need unplug AC after reboot/power off

Attached File  debuglast.txt ( 1.15K ) Number of downloads: 5
Al3XKOol
post Aug 31 2012, 09:59 PM
Post #515
Clover Spanish translation

Is correct?
Attached File  es.lproj.zip ( 12.2K ) Number of downloads: 0

Attached File  main.c.zip ( 18.02K ) Number of downloads: 0
dmazar
post Aug 31 2012, 10:39 PM
Post #516
Added OsxLowMemFixDrv to Clover SVN -can be used on InsydeH2O UEFI. For example: Clover + HFSPlus + OsxFatBinaryDrv + OsxLowMemFixDrv. Confirmed long time ago by akbar02 here.
HW: Asus P8P67-M, Intel Core i5-2300, 4GB, XFX HD-567X-ZHH3 SW: SL, L, ML: Clover UEFI boot
dmazar
post Aug 31 2012, 10:41 PM
Post #517
QUOTE (Al3XKOol @ Aug 31 2012, 11:59 PM) *
Clover Spanish translation

Better upload translations to Clover thread.

By the way, did you tried with the AptioFix driver from THe KiNG's post 501? Compiled on Win - maybe there is a difference.
HW: Asus P8P67-M, Intel Core i5-2300, 4GB, XFX HD-567X-ZHH3 SW: SL, L, ML: Clover UEFI boot
dmazar
post Aug 31 2012, 10:57 PM
Post #518
QUOTE (Chumnick @ Aug 31 2012, 11:47 PM) *
With great pleasure to present

This is with Graphics parameter AUTO or DISABLE? And when using the same options and driver compiled by THe KiNG, then it does not stop, but boots your OS?

I can see from the screen that it stops during executing some assembler code for storing 64 bit state (GDTR, IDTR ...). I do not know what to fix there. If this code always blocks in GCC compiled version (mine) and works in Win compiled (THe KiNG's), I would say that it is a bug in GCC version of the code. But this same code works for you when you have Intel graphics enabled!? This is strange and I have no explanation for now.

Well, I can only recommend to use Win compiled version.
HW: Asus P8P67-M, Intel Core i5-2300, 4GB, XFX HD-567X-ZHH3 SW: SL, L, ML: Clover UEFI boot
Al3XKOol
post Aug 31 2012, 11:13 PM
Post #519
QUOTE (dmazar @ Aug 31 2012, 11:41 PM) *
By the way, did you tried with the AptioFix driver from THe KiNG's post 501? Compiled on Win - maybe there is a difference.


Stop on root device uuid.....
Slice
post Sep 1 2012, 05:00 AM
Post #520
QUOTE (THe KiNG @ Sep 1 2012, 01:39 AM) *
I didn't tested with Clover, the reason I did this is I needed a way to minimize any possible bugs/alteration that could change the AptioFix results.
If you test with Clover VBoxAppleSim is not needed, if not you ned to hack your BIOS and do what I explained earlier.

OsxAptioFixDrv.efi was compiled from Clover svn source but on Windows(VS2010), the reason I don't use OS X for compile is that gcc even with redbull wont get same smaller size as with MSFT(anyone can check the size)
The size is vital when we deal with UEFI BIOS hacks...

Left is your, right is my, compiled in OSX
Attached File  ______________2012_09_01___8.59.43.png ( 89.26K ) Number of downloads: 21

Version 608
Attached File  ______________2012_09_01___9.02.31.png ( 47.54K ) Number of downloads: 15
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.4, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2

54 Pages V  « < 24 25 26 27 28 > » 
Add Reply Start a new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members: