ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

 
Start a new topic Add Reply
> Lenovo s10e, progress to making a perfect netbook install
Hagar
post May 4 2009, 11:56 PM
Post #1

Toggle Visability

Lenovo S10e


This is just a post for me to document my installation process on a netbook for the first time.

tried XPC, got EHCI handoff error
made bootable usb stick with chameleon2 r431 and added the ehci fix option.
booted from usb stick, launched retail 10.5.6 (imaged onto 8gb usb stick) and formatted "PRELOAD" as HSF+
copied /System/Installation/Packages to the new partition, dropped in hacked osinstall.mpkg and installed.

tested a few things, took images of the rescue partition, wiped os x & reinstalled xp imaged the install, wiped the drive and tried recovering the partitions: the rescue partition went in fine, the install not, and I couldn't find a way to make it boot the rescue partition, so the recovery failed, probably due to losing the lenovo bootloader.

booted the same way, partitioned GPT & installed off the 8gb stick. installed chameleon2

Having thought through the right way to do this, I decided to just whack at it with what was available & ended up installing:

in /Extra/Extensions (kextcached) :

AHCIPortInjector.kext \
IOAHCIBlockStorageInjector.kext VoodooBattery.kext | Included with chameleon 2
ATAPortInjector.kext /
AppleDecrypt.kext Although somehow I ended up with the spammy version
IOAudioFamily.kext \
OSvKernDSPLib.kext |voodoohda 0.2.2 prefpane version + vanilla kexts for dependencies
VoodooHDA.kext /
AppleACPIPowerSource.kext \ Got these from this pack: http://uploaded.to/?id=9djapn
AppleACPIThermal.kext / No idea what they're doing there at this stage :/
(if that's your driver pack & you want credit, get in touch, I got the link from a friend)

and in /S/L/E:

GMA950 & integratedframebuffetr kexts from the /driver/display/no-natit-with-brightness-control-no-mirror folder in that pack
VoodooPS2
VoodooBattery

for the wifi I edited the Info.plist of the bcom4311 kext to include 4315 and it works.

I added a usb ethernet dongle in place of the non-working BC5906M (an apple one, they're cheap & work)

so basically I've got a quick-n-dirty hack with:

scratchy/stuttery sound
no sleep
no mirrored display
in pretty short order.

Next I need to sort out the remaining issues & start plotting a route to a cleaner hack.

Well, I got it to the point that everything worked (not ethernet, of course, and sound was crackly, and no mirrored display) and then it ate itself. 3 or 4 kernel panics and now no boot.. such is the way of dirty hacks

Well, I resurrected it by booting from the install usb-stick and running some fsck etc.

I've reshuffled the contents of /Extre, now it has AppleAzaliaAudio.kext (to use with auidoeee) and dsmos (so I avoid a zillion lines in the verbose boot.

so: sound output works, as long as I run audioeee as root and use it to select outputs. sleep works, but I have to kill bluetooth & wifi to get it to sleep, and on wakeup I have no sound and must reload the BCM4311.kext to get wifi back. additionally I have a few odd system hangups, and some quite pretty kernel panics:

Attached File  DSC00319.JPG ( 491.16K ) Number of downloads: 18
Attached File  DSC00320.JPG ( 425.36K ) Number of downloads: 9
Attached File  DSC00323.JPG ( 456.11K ) Number of downloads: 11



Switching to voodoopowermini solved the KP´s (I could have done it with a plist edit, so superhai said, I´ll dig out the logs when I get home)

as part of trying to get the trackpad working the way I wanted I ended up with quite a few freezes & reboots and incidentally moved voodooPS2Controller.kext to /Extra where it seems happy. The main issue (for me) with voodooPS2 is that if I turn on tap/drag it messes up tap/click, thinking every single tap is the start of a tap/drag hence making every tap have to be a double-tap. turning it off means using the trackpad buttons for dragging & text selection. there may yet be a setting that fixes this, I haven´t found it.

so: annoyances:

trackpad: tap/click/drag: voodoops2 needs tweaking or potentially some other driver?
sound: neither solution is fully satisfactory, I´m blindly hoping some voodooHDA development "makes it work" for me.
sleep/hibernate: still need to kill wifi for sleep, and reload the bcm4311.kext each time. also azalia doesn´t survive sleep. need to give hibernate a closer look. Also some means of automating the unloading/reloading of stuff for sleep.
power/fan: not quite sure whats going on here, seems to use a bit much power still. I´ll check for bios updates.

the keymapping isnt 100% but it´ll do.


And then there was 10.5.7..

Still trying to get the hang of sleep, powermanagement and fan control, these are new things to me as I've mainly been doing desktop machines for the last couple of years.

one new development is a modification of a modification: a hack (by meklort) to the IOAudioFamily.kext by that was modified to work on the Dell mini 9. not entirely sure what's been done to it, but it allows Azalia to load & work for output without using AudioEEE. for the time being, it's a useful option.
Attached File  IOAudioFamily.kext.zip ( 83.56K ) Number of downloads: 28
details here

anyhow, the sun is shining and life is too good to sit around here.. bbl.

This Time We're Doing it RIGHT


Slice
post May 24 2009, 05:00 PM
Post #2
QUOTE
for the wifi I edited the Info.plist of the bcom4311 kext to include 4315 and it works.

Did you try to modify the info.plist to follow
CODE
            <key>TruePowerOff</key>
            <false/>

This is better for me for shutdown problem. (the same BCM4315)
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.5, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
Hagar
post Jun 4 2009, 03:33 PM
Post #3
[DRAFT 4] updated with 10.5.7 & splashtop

Basic rough-n-ready triple-boot ubuntu netbook remix, 10.5.6 and XP USE AT YOUR OWN RISK

Summary:

This backs up your existing XP install with os x, reformats and installs ubuntu netbook remix, then os x, and finally restores your backup for XP from os x.

Requirements:

s10e as set up with windows xp
4 usb sticks: 1 for chameleon(small), 1 for ubuntu(1gb min), one for backups(4gb min) and one for 10.5.6 retail(8 gb min)
a working usb ethernet adapter or wireless network

you will lose:
Splashtop, recovery partition, 10.5.7 untested

Preparation:
image your retail DVD to the 8gb usb stick with disk util in os x or transmac in windows "the retail stick"

create a chameleon 2 boot stick with windows or linux or osx and add the Extra Folder from Attached File  Extra.zip ( 5.46MB ) Number of downloads: 9
, and OsinstallExtra.mpkg from here "the preboot stick"

download ubunto netbook remix from here and image it to a usb stick as per here "the ubuntu stick"

the fourth stick can be fat32 or hfs+ "the backup stick"

Procedure:

1: making a backup (I'm sure there are other ways of doing this, better suggestions are welcome)

Insert the preboot stick in one usb port, and the retail stick in the other, boot from the preboot stick and select the retail stick.

hit enter to get past language selection and from utilities select disk utility

Eject the preboot stick and insert the backup stick

Select the volume "PRELOAD" (or whatever your XP partition is called) and save it as a compressed disk image on the backup stick (this may take a while) optionally you can do the same for disk0s2 which is the recovery partition

reboot,
remove all sticks ( you may want to verify the disk images you just backed up if you have an os x machine available)

2: partitioning the harddrive and installing ubuntu netbook remix (this is the point of no return)

insert the ubuntu stick and boot from it. select install ubuntu netboo remix to hard drive, select manual partitioning, and partition with mbr:
4 primary partitions:
  1. a fat32 for windows first,
  2. another for os x,
  3. an ext3 for linux
  4. and finally a small one for linux swap

I used (roughly) 40gb,60gb, 20gb, 5gb

install ubuntu making absolutely sure you hit "advanced" on the last pane before install and select to install grub to /dev/sda3

complete ubuntu install, reboot

Ubuntu Setup:

insert the preboot stick and boot from it, select "Linux" and with any luck you will boot ubuntu.
once in ubuntu, let the updater run, and do:

CODE
apt-get install hfsplus hfsprogs ntfsprogs
      fdisk /dev/sda

and set the type of partition 1 to 07 (ntfs) and partition 2 to AF (hfs+) with the "t" command and set the hfs partition bootable with "a"
then
CODE
mkfs.ntfs /dev/sda1
to format the windows partition to ntfs

3: installing OS X:

Boot up off the preboot stick, with the retail stick in the other port, and select it in chameleon.

press enter to get past the language selection, open disk utility, and erase the second partition to HFS+,
quit disk utility and open terminal
type:
CODE
/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer
to launch the installer,
select OsinstallExtra.mpkg from the preboot stick and open.
install to the disk you just formatted.
when done (fialiure due to inability to make bootable is normal & can be ignored) reboot.

*Note that the "Extra" package under customise is a dummy for a pkg you can add to install your own stuff, and should be deselected

boot up from the preboot stick and select the partition you just installed on.

OS X Setup:
you should see a message saying your screen is to small for setup assistant. click OK
(as this means setup isn't done yet, do the following:)
go to system preferences: Users and add a new asinistrator with the name & password of your choice log out and log in as this user. delete the "Administrator" user completely, set your login preferences. you may also want to go into "sharing" and set a computer name.
repair permissions on your os x partition and reboot

Install Chameleon 2 to your hard drive (I recommend doing it manually) and copy the Extra folder off the preboot stick to your os x partition.

reboot off the harddrive to see whether all is well with chameleon, boot os x.


4: Restoring the XP backup
download and install the 10-day trial of Paragon NTFS and install it, you will need to reboot.

mount the image of the xp disk you made earlier, and open a terminal, as root, do cp -R /Volumes/ThatDiskImage/* /Volumes/TheNTFSPartition

this may take some time.

To get Splashtop working, you will need to boot into XP and reinstall Quickstart with the installer from Here

Finally: reboot,

You should get the splashtop screen, click the "boot" button and you should have chameleon offering you os x, windows, and linux. they should all now work.

The os x this installs is totally untouched except for paragon ntfs, which you can now uninstall if you prefer, making it a perfect starting point for further testing.

Contents:
The com.apple.Boot.plist contains a device-property entry for the GMA950
(to check it out, copy the sting to a file and convert it to a plist with gfxutil)

The choice of kexts is pretty quick-n-dirty, they consist of: vanilla 10.5.6 kexts with the following mods:

AppleAirPortBrcm4311.kext has had 4315 added in its info.plist

AppleUSBEHCI.kext has had OSBundleCompatibleVersion set to 1.0 in its Info.plist

IOAudioFamily.kext is meklort's version from AudioEEE - no idea if this confers any advantage

The remaining vanilla kexts are there to satisfy dependencies.

The FixedIntel* kexts are Dense's mods. higher ioprobescore and rename should make them update-resistant, haven't tested.

the rest are Voodoo by superhai, kaitek, fassl and all the rest of the good guys

If you want to look closer etc I suggest using mkextunpack to unpack the kexts to /Extra/Extensions

To Do:
in the first instance, look at clamshelldisplay and bluetooth sleep and .7 updating which seem not to be working fine-tune some of the kext options. (disabler) investigate power management & fan control.
improvements to webcam and sound function would be useful
and of course, DSDT possibilities (for the potential "not-so-quick-n-dirty" solution)

then there's making a nice chameleon theme and a custom package to run from the installer for one-shot operation..

[edit]
added prasys's blutooth dev. ID hack, that gave me an on/off option on bluetooth smile.gif unfortunately turning it off in software doesn't enable sleep.

experimentally replaced the patched IOAudioFamily with the vanilla item, no noticeable change
tried slice's broadcom shutdown fix, didn't notice any advantage, so I set it back

updating to .7 now as there's no point further tweaking an old version.
[update: the this setup survives the.7 uptdate - just I'm going to replace the kexts bit by bit with .7 versions & see how far I get.

OK here's my .mkext for .7, seems to work about like .6 but fan control is working better [edit] and I messed up clamshelldisplay somehow, it won't load at boot.

Attached File  Extensions.mkext.zip ( 2.89MB ) Number of downloads: 23


This uses keld's binpatched 10.5.7 gma950 kexts rather than Dense's, update-proof ones. all the vanilla is updated to .7 and repatched with the same plist edits as above.
This Time We're Doing it RIGHT



Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: