ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

67 Pages V  « < 52 53 54 55 56 > »   
Start a new topic Add Reply
> Voodoohda Driver, Fully working!
Zambo27
post Feb 18 2012, 06:57 PM
Post #1061
sorry but i don't know how sad.gif
it is something to write inside info.plist or i have to use some others program to fix it?
Slice
post Feb 19 2012, 02:41 PM
Post #1062
QUOTE (Zambo27 @ Feb 18 2012, 10:57 PM) *
sorry but i don't know how sad.gif
it is something to write inside info.plist or i have to use some others program to fix it?

I have searched across the forum and found that alc269 may have very different configuration. So you must make your own info.plist.
Go to the first post and read carefully all instructions and tricks here.
As first step you should get your dump and analyze it using THeKiNG manual.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.4, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
jusasweet69
post Feb 20 2012, 11:58 PM
Post #1063
Hello I'm looking for a bit of help getting my sound to work right.
I have read the tutorial done by king a few times and feel like i have it down correctly but I must be missing something.
My sound device is the VIA1708 not (the S version) I have seen posted. i have 5 jacks front green, pink back green, pink, and blue.
i have modded the info.plist as in my upload but am still not having success with it.
voodooHDA is only showing me a SPDIF(orange) in my voodoo dump connections and in sound prefs.
Can somebody please assist me and guide me i the right direction as to what i seem to be missing.
my current dumps and files are attached
Thanks for the assistance

Attached File  card0_codec_0_copy.txt ( 6.36K ) Number of downloads: 4

Attached File  Voodoo_getdump.txt ( 21.15K ) Number of downloads: 10

Attached File  Info.plist.txt ( 3.41K ) Number of downloads: 18


This post has been edited by jusasweet69: Feb 21 2012, 04:16 AM
tish371
post Feb 22 2012, 10:02 PM
Post #1064
Hello. After weeks of reading, understanding and trying to get voodoohda to work perfectly on ALC260 sound chip i came here to ask for help. My problem i that i cant get Line out and headphones to work at the same time, nor make them auto detect... in sound options i allways see only one output the one that i give the first default association. I have a built in speaker too, but no mater what i do i can only get one output... the output that is set to the first in default association

here are my dumps and pincofing
Attached File  codec_dump.txt ( 25.11K ) Number of downloads: 9

Attached File  ext_codec_dump.txt ( 10.9K ) Number of downloads: 5

Attached File  linux_codec_dump.txt ( 2.44K ) Number of downloads: 7

Attached File  plist.txt ( 4.94K ) Number of downloads: 9


This post has been edited by tish371: Feb 24 2012, 11:18 AM
Slice
post Feb 23 2012, 04:53 PM
Post #1065
QUOTE (jusasweet69 @ Feb 21 2012, 03:58 AM) *
Hello I'm looking for a bit of help getting my sound to work right.
I have read the tutorial done by king a few times and feel like i have it down correctly but I must be missing something.
My sound device is the VIA1708 not (the S version) I have seen posted. i have 5 jacks front green, pink back green, pink, and blue.
i have modded the info.plist as in my upload but am still not having success with it.
voodooHDA is only showing me a SPDIF(orange) in my voodoo dump connections and in sound prefs.
Can somebody please assist me and guide me i the right direction as to what i seem to be missing.
my current dumps and files are attached
Thanks for the assistance

Attached File  card0_codec_0_copy.txt ( 6.36K ) Number of downloads: 4

Attached File  Voodoo_getdump.txt ( 21.15K ) Number of downloads: 10

Attached File  Info.plist.txt ( 3.41K ) Number of downloads: 18

Look at your voodoo-dump
CODE
nid 28 0x410110f2 as 15 seq  2      Line-out  None jack  1 loc  1 color   Black misc 0 [DISABLED]
nid 29 0x01a19036 as  3 seq  6    Microphone  Jack jack  1 loc  1 color    Pink misc 0
nid 30 0x0181303e as  3 seq 14       Line-in  Jack jack  1 loc  1 color    Blue misc 0
nid 31 0x010140f0 as 15 seq  0      Line-out  Jack jack  1 loc  1 color   Green misc 0
nid 32 0x422140ff as 15 seq 15    Headphones  None jack  1 loc  2 color   Green misc 0 [DISABLED]
nid 33 0x02a19038 as  3 seq  8    Microphone  Jack jack  1 loc  2 color    Pink misc 0
nid 34 0x410160f1 as 15 seq  1      Line-out  None jack  1 loc  1 color  Orange misc 0 [DISABLED]
nid 35 0x410120f4 as 15 seq  4      Line-out  None jack  1 loc  1 color    Grey misc 0 [DISABLED]
nid 36 0x99370137 as  3 seq  7            CD Fixed jack  7 loc 25 color Unknown misc 1
nid 37 0x074461f0 as 15 seq  0     SPDIF-out  Jack jack  4 loc  7 color  Orange misc 1
nid 38 0x47c421f0 as 15 seq  0      SPDIF-in  None jack  4 loc  7 color    Grey misc 1 [DISABLED]

nid 31, 37 are not working because group 15 (0x010140f0)
Other outputs are DISABLED because of location 4 (0x422140ff)

First line in first post
First of all read information from THeKiNG about correct Pin Config
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.4, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
jusasweet69
post Feb 24 2012, 12:21 AM
Post #1066
Slice thank you for your assistance i have all the devices enabled but i honestly dont understand all the group and association stuff.
i have attached a file showing my work from what you have told me in the previous post and i have read THeKING's tutorial several times. I don't know why I cant understand this stuff but I seem to be getting close but just not there.
Attached is also a dump of it with my changes and some screens.

Attached File  My_Work.txt ( 3.1K ) Number of downloads: 12

Attached File  VoodoHDA_dump.txt ( 25.86K ) Number of downloads: 14

Attached File  Info.plist.txt ( 4.43K ) Number of downloads: 10

Attached File  Screen_Shot_2012_02_23_at_6.48.50_PM.JPG ( 67.72K ) Number of downloads: 56
Attached File  Screen_Shot_2012_02_23_at_6.48.57_PM.JPG ( 67.71K ) Number of downloads: 38
benjaminaloha
post Feb 29 2012, 02:58 PM
Post #1067
I edit the same post a third time, because I tried a lot with the node patches and I achieved some aim.

Well, I had a very strange problem with my VoodooHDA 0.2.56 Driver. First all worked for me. Headphones and spdif, line out didn't tested. Suddenly spdif stopped working. Ok, after some reading Itested some node patches. The Problem was, the SPDIF inpunt and output had the same Default Association and Sequence Numbers. So I changed one of them and it worked.

The digital output sound quality is fine with 0.2.56, the headphonesound not that good. Because I couldn't use the prefpane to optimize the sound and I just wanted to have the most actual Version of VoodooHDA, I tested the 0.2.72 one. After the first installation just the headphones and line out worked. SPDIF not. So I began to try some node patches. I tested different variations. Finally I got two versions of a working 0.2.72 driver.

1) Headphones or SPDIFThe
2) (SPDIF) or (Stereo Output = green line out) or (Stereo Output and Headphones).

in the 2) version I put SPDIF node with one Line Out node into a new Default Assosiaction group. Headphones into another new one and the green line out stayed where it was.

I use 1) and to get short overview of the changes I made I post the nid pin configurations from the getdump terminal output with the lines frome before and after the node patched changes

CODE
nid 25 0x01011012 as  1 seq  2      Line-out  Jack jack  1 loc  1 color   Black misc 0
nid 26 0x01a19036 as  3 seq  6    Microphone  Jack jack  1 loc  1 color    Pink misc 0
nid 27 0x0181303e as  3 seq 14       Line-in  Jack jack  1 loc  1 color    Blue misc 0
nid 28 0x01014010 as  1 seq  0      Line-out  Jack jack  1 loc  1 color   Green misc 0
nid 29 0x0221401f as  1 seq 15    Headphones  Jack jack  1 loc  2 color   Green misc 0
nid 30 0x02a19038 as  3 seq  8    Microphone  Jack jack  1 loc  2 color    Pink misc 0
nid 31 0x90370137 as  3 seq  7            CD Fixed jack  7 loc 16 color Unknown misc 1
nid 32 0x074311f0 as 15 seq  0     SPDIF-out  Jack jack  3 loc  7 color   Black misc 1
nid 33 0x47c421f0 as 15 seq  0      SPDIF-in  None jack  4 loc  7 color    Grey misc 1
nid 34 0x01016011 as  1 seq  1      Line-out  Jack jack  1 loc  1 color  Orange misc 0
nid 35 0x01012014 as  1 seq  4      Line-out  Jack jack  1 loc  1 color    Grey misc 0


to

CODE
nid 25 0x01011014 as  1 seq  4      Line-out  Jack jack  1 loc  1 color   Black misc 0
nid 26 0x41a19026 as  2 seq  6    Microphone  None jack  1 loc  1 color    Pink misc 0 [DISABLED]
nid 27 0x0181302e as  2 seq 14       Line-in  Jack jack  1 loc  1 color    Blue misc 0
nid 28 0x41014035 as  3 seq  5      Line-out  None jack  1 loc  1 color   Green misc 0 [DISABLED]
nid 29 0x00221430 as  3 seq  0    Headphones  Jack jack  2 loc  0 color   Black misc 4
nid 30 0x42a19028 as  2 seq  8    Microphone  None jack  1 loc  2 color    Pink misc 0 [DISABLED]
nid 31 0x40370127 as  2 seq  7            CD  None jack  7 loc  0 color Unknown misc 1 [DISABLED]
nid 32 0x07431110 as  1 seq  0     SPDIF-out  Jack jack  3 loc  7 color   Black misc 1
nid 33 0x47c421ff as 15 seq 15      SPDIF-in  None jack  4 loc  7 color    Grey misc 1 [DISABLED]
nid 34 0x41016012 as  1 seq  2      Line-out  None jack  1 loc  1 color  Orange misc 0 [DISABLED]
nid 35 0x41012013 as  1 seq  3      Line-out  None jack  1 loc  1 color    Grey misc 0 [DISABLED]


The sound isn't that good, but it works. I also didn't try to optimize it, just nice to have it working now. The SPDIF isn't shown as SPDIF output in the Preferences. Its name is complex output.

My key strategy

1) SPDIF node together with a Line Out node in the same Default Association group
2) seperating SPDIF node from the Headphones node

Many variations didn't work: all in Default Association group 1. H and S together in DAg 1. And so on.

If you already posted a similar way, sorry, didn't read all sites.

Little Edit: The bass isn't working at beginning. In the audio/midi is Complex Output setted up with 96hz, just configure it with 48hz and it will work. The Vectorize/SSE2 Feature has to be enabled and then it will work fine.

My audiochip VT1708b

aloha

This post has been edited by benjaminaloha: Mar 24 2012, 09:51 AM
shadyemil
post Mar 1 2012, 10:50 AM
Post #1068
hey Slice,
first of all thank you for this very helpful topic
i am trying to fix my audio or get the right kexts for it for a bout 4 years, but i didn't success till now
and i hope if you can help me cause am very desperate ( despite following your steps )
here is an image for my sound cards



and here is their id's



the problem is i can't control the volume from the touch buttons ( the mute, increasing or decreasing volume level )

and it doesn't switch to the headphones when i put them and vise versa and i've to change them manually
so pleeeeeeeeeease help me sad.gif
No.6
post Mar 6 2012, 02:34 PM
Post #1069
Hey, I've already startet a thread here with my problem, but since nobody answered there I'll post it here again:

I've a Acer emachines E732ZG Notebook, and eveerything seems to work good with OSX 10.7 except for the sound: It just works just after sleep/wake..
Has anybody an idea what the problem could be, or any other suggestions? Any help would be very appreciated =)
Slice
post Mar 9 2012, 07:42 PM
Post #1070
QUOTE (No.6 @ Mar 6 2012, 06:34 PM) *
Hey, I've already startet a thread here with my problem, but since nobody answered there I'll post it here again:

I've a Acer emachines E732ZG Notebook, and eveerything seems to work good with OSX 10.7 except for the sound: It just works just after sleep/wake..
Has anybody an idea what the problem could be, or any other suggestions? Any help would be very appreciated =)

The idea is to implement some INI method into DSDT.
But you said impossible thing. The voodooHDA driver latest version do the same init at start and after sleep-wake. Set verbose into info plist and look into kernel.log.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.4, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
No.6
post Mar 10 2012, 08:23 PM
Post #1071
QUOTE (Slice @ Mar 9 2012, 08:42 PM) *
The idea is to implement some INI method into DSDT.
But you said impossible thing. The voodooHDA driver latest version do the same init at start and after sleep-wake. Set verbose into info plist and look into kernel.log.


Mhm, then the problem must be somewhere else, like I said, sound is only working after sleep/wake.. is it possible, that there's a problem with another kext then? Any ideas?

I've tested installing Snow Leopard today, same Problem there and with 10.8 too..

This post has been edited by No.6: Mar 12 2012, 12:18 AM
Slice
post Mar 19 2012, 10:07 AM
Post #1072
QUOTE (No.6 @ Mar 11 2012, 12:23 AM) *
Mhm, then the problem must be somewhere else, like I said, sound is only working after sleep/wake.. is it possible, that there's a problem with another kext then? Any ideas?

The idea is
QUOTE
Set verbose into info plist and look into kernel.log.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.4, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
Noyfb
post Mar 21 2012, 08:44 PM
Post #1073
Hi

10.7.2
AD1988B
VooDooHDA.kext 2.7.3

Log Errors:
I installed vodooHDA 2.7.3 with verbose on and noticed these,
12-03-21 4:03:10.000 PM kernel: VoodooHDADevice[0xffffff806bf23000]::init
12-03-21 4:03:10.000 PM kernel: VoodooHDADevice[0xffffff806bf6e000]::init
12-03-21 4:04:43.506 PM VoodooHdaSettingsLoader: No Info.plist file in application bundle or no NSPrincipalClass in the Info.plist file, exiting
12-03-21 4:04:43.518 PM com.apple.launchd.peruser.501: (org.voodoo.driver.voodoohdahelper[281]) Exited with code: 1


With 2.7.2 this error came up every time: related to previous error?
12-03-21 3:14:23.106 PM org.voodoo.driver.voodoohdahelper: error: can't read settings
I think it's a file permission error but what is weird since it created the file in the first place.


Rear and Front green outputs works but:
When set on auto sensing the front port is always master and the rear is slave. It should be the other way around. Changing the f in plist does nothing.
I'm still debating with myself if auto switching is a good thing on a desktop. I think auto switching is only useful when you have easy access for plugging and unplugging your headphones.
Besides you can always use the front jack as an extra output for remote speakers as an example.

Microphone sensing still does not work.

If this is any help great if not, mhen.

This post has been edited by Noyfb: Mar 21 2012, 08:48 PM
Fabio1971
post Mar 25 2012, 07:39 PM
Post #1074
Hello I have a motherboard Asus P5Q Pro Turbo with a GTX 470 video card do I go HDMI as an output.
Audio sound card is VIA ® VT1708S 8.
2.7.3 How Voodahda.Kext use the code to add is posted or wrong.
Thank you in advance on the aid.

QUOTE
<key>IOKitPersonalities</key>
<dict>
<key>SoundCard</key>
<dict>
<key>CFBundleIdentifier</key>
<string>org.voodoo.driver.VoodooHDA</string>
<key>IOClass</key>
<string>VoodooHDADevice</string>
<key>IOMatchCategory</key>
<string>VoodooHDADevice</string>
<key>IOPCIPrimaryMatch</key>
<string>0x284b8086</string> -- place here deviceID of your sound card (Chipset HDA device, not a codecID!)
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>IOUserClientClass</key>
<string>VoodooHDAUserClient</string>
<key>NodesToPatch</key>
<array/>
<key>VoodooHDAVerboseLevel</key>
<integer>1</integer>
</dict>
<key>HDMI</key>
<dict>
<key>CFBundleIdentifier</key>
<string>org.voodoo.driver.VoodooHDA</string>
<key>IOClass</key>
<string>VoodooHDADevice</string>
<key>IOMatchCategory</key>
<string>VoodooHDADevice</string>
<key>IOPCIPrimaryMatch</key>
<string>0x033f1002</string> -- place here deviceID of your HDMI device on video card
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>IOUserClientClass</key>
<string>VoodooHDAUserClient</string>
<key>NodesToPatch</key>
<array/>
<key>VoodooHDAVerboseLevel</key>
<integer>1</integer>
</dict>
</dict>


I7 960 - P6T Deluxe - GTX 470 - Corsair 12GB - SSD 120 Vertex Agility - 2x 1T WD
Fabio1971
post Mar 31 2012, 09:44 PM
Post #1075
Hello you step on Getdump
Give me a help to go to hdmi card GTX 470
thanks

Attached File  Getdump_Piper69.txt.zip ( 4.45K ) Number of downloads: 2


This post has been edited by piper69: Mar 31 2012, 09:45 PM
I7 960 - P6T Deluxe - GTX 470 - Corsair 12GB - SSD 120 Vertex Agility - 2x 1T WD
wieniu
post Apr 5 2012, 08:27 PM
Post #1076
Hello
Sorry for my English (google translator)
He asked for help for vodooHDA i speedstep after sleep

I voodooHDA 2.7.3 running sound and microphone.
CPU clock speed changes. speedstep is OK
after waking no speedstep, the processor is working full

Without voodooHDA after waking speedstep works well is ok

Generally the biggest problem is with the power mangament (speedstep) after waking up when the system is voodoohda

Please help in solving a problem with sound and speedstep after waking.

DSDT is from MaLd0n
My Info.plist ...
QUOTE
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>BuildMachineOSBuild</key>
<string>11A511</string>
<key>CFBundleDevelopmentRegion</key>
<string>English</string>
<key>CFBundleExecutable</key>
<string>VoodooHDA</string>
<key>CFBundleIdentifier</key>
<string>org.voodoo.driver.VoodooHDA</string>
<key>CFBundleInfoDictionaryVersion</key>
<string>6.0</string>
<key>CFBundleName</key>
<string>VoodooHDA</string>
<key>CFBundlePackageType</key>
<string>KEXT</string>
<key>CFBundleShortVersionString</key>
<string>2.7.3</string>
<key>CFBundleSignature</key>
<string>????</string>
<key>CFBundleVersion</key>
<string>2.7.3</string>
<key>DTCompiler</key>
<string>4.2</string>
<key>DTPlatformBuild</key>
<string>4B110</string>
<key>DTPlatformVersion</key>
<string>GM</string>
<key>DTSDKBuild</key>
<string>10J567</string>
<key>DTSDKName</key>
<string>macosx10.6</string>
<key>DTXcode</key>
<string>0410</string>
<key>DTXcodeBuild</key>
<string>4B110</string>
<key>IOKitPersonalities</key>
<dict>
<key>VoodooHDA</key>
<dict>
<key>CFBundleIdentifier</key>
<string>org.voodoo.driver.VoodooHDA</string>
<key>IOClass</key>
<string>VoodooHDADevice</string>
<key>IOMatchCategory</key>
<string>VoodooHDADevice</string>
<key>IOPCIPrimaryMatch</key>
<string>0x3b568086</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>IOUserClientClass</key>
<string>VoodooHDAUserClient</string>
<key>InhibitCache</key>
<true/>
<key>MixerValues</key>
<dict>
<key>Mic</key>
<string>90</string>
<key>Monitor</key>
<string>0</string>
<key>PCM</key>
<string>99</string>
<key>IMix</key>
<string>99</string>
<key>Line</key>
<string>99</string>
<key>Rec</key>
<string>99</string>
<key>Speaker</key>
<string>99</string>
<key>iGain</key>
<string>0</string>
<key>IMix</key>
<string>99</string>
</dict>
<key>NodesToPatch</key>
<array/>
<key>Noise</key>
<integer>2</integer>
<key>Vectorize</key>
<true/>
<key>VoodooHDAEnableHalfMicVolumeFix</key>
<false/>
<key>VoodooHDAEnableHalfVolumeFix</key>
<false/>
<key>VoodooHDAEnableMuteFix</key>
<false/>
<key>VoodooHDAEnableVolumeChangeFix</key>
<false/>
<key>VoodooHDAVerboseLevel</key>
<integer>0</integer>
</dict>
</dict>
<key>OSBundleLibraries</key>
<dict>
<key>com.apple.iokit.IOAudioFamily</key>
<string>1.1fc9</string>
<key>com.apple.iokit.IOPCIFamily</key>
<string>2.1</string>
<key>com.apple.kpi.iokit</key>
<string>9.0.0</string>
<key>com.apple.kpi.libkern</key>
<string>9.0.0</string>
<key>com.apple.kpi.mach</key>
<string>9.0.0</string>
<key>com.apple.kpi.unsupported</key>
<string>9.0.0</string>
</dict>
</dict>
</plist>

ASUS G51JX-X5 10.7.3 Lion Intel Core i7 720QM 6GB 500GB 15.6IN FHD GeForce GTS360M
HM55, Intel 5 Series Chipset, ALC663, AR8131, AR9285,
Slice
post Apr 8 2012, 08:42 AM
Post #1077
What about you?
I and thousands users use VoodoHDA, sleep and wake without losing speedstep.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.4, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
wieniu
post Apr 8 2012, 09:06 AM
Post #1078
Just do not know.
everything works OK, the only problem with speedstep after sleeping when voodoohda
I do not know where the problem is

This post has been edited by wieniu: Apr 8 2012, 09:08 AM
ASUS G51JX-X5 10.7.3 Lion Intel Core i7 720QM 6GB 500GB 15.6IN FHD GeForce GTS360M
HM55, Intel 5 Series Chipset, ALC663, AR8131, AR9285,
manmal
post Apr 9 2012, 03:59 PM
Post #1079
hello, there is an annoying problem with voodoohda driver.
There are some software that refuses even to start with it (waveburner or protools 9)!
"Error while initializing audio engine"...
May you please explain me why? Is it possible to fix it? Any solution?
thanks!
Finger
post May 10 2012, 09:56 PM
Post #1080
I have finally managed to fix AC3/DTS pass-through in VoodooHDA.
For those of you with decent audio equipment - enjoy wink.gif

Attached File  VoodooHDA.zip ( 157.41K ) Number of downloads: 354


This post has been edited by Finger: May 13 2012, 10:27 PM

67 Pages V  « < 52 53 54 55 56 > » 
Add Reply Start a new topic
5 User(s) are reading this topic (5 Guests and 0 Anonymous Users)
0 Members: