ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

 
Start a new topic Add Reply
> AC97 sound driver (10.5 compiled), include ATI IXP, VIA AC97, Intel, AMD, AD1988
Slice
post Jul 14 2009, 07:28 AM
Post #1
Look into ioreg for the lines
ioreg -l | grep PNPVendorID
CODE
   | |   |   +-o IOAC97CodecDevice@0  <class IOAC97CodecDevice, registered, matched, active, busy 0, retain count 6>
    | |   |   | | {
    | |   |   | |   "PNPVendorID" = "ADS74"
    | |   |   | | }
    | |   |   | |

and apply this name into info.plist of one of plugins
Attached File  AppleAC97Audio.kext.zip ( 127.83K ) Number of downloads: 576

Attached File  ATIAppleAC97Audio_5.src.zip ( 202.03K ) Number of downloads: 228
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.5, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
Hara Taiki
post Aug 3 2009, 06:09 PM
Post #2
Where do we put that into info.plist?

Mine shows as "CMI83".
Slice
post Aug 4 2009, 09:35 PM
Post #3
QUOTE (Hara Taiki @ Aug 3 2009, 06:09 PM) *
Where do we put that into info.plist?

Mine shows as "CMI83".

First of all you need to correct DeviceID for primary PCI into
AppleAC97Audio.kext/Contents/PlugIns/AppleAC97AudioVIA.kext/Contents/Info.plist
CODE
            <key>IOPCIPrimaryMatch</key>
            <string>0x30591106</string>  <-- this is your VIA device

I am not sure but you can try to apply you string here
AppleAC97Audio.kext/Contents/PlugIns/AppleAC97CodecAD198x.kext/Contents/Info.plist
CODE
            <key>PNPVendorID</key>
            <string>ADS75 ADS74 ADS73 ADS72 CMI83</string> <-- here

May be no...
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.5, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
Hara Taiki
post Aug 5 2009, 03:43 AM
Post #4
I tried that, all I ended up with was sound only coming from the left channel and still no working software volume and balance controls.

This post has been edited by Hara Taiki: Aug 5 2009, 03:43 AM
Slice
post Aug 5 2009, 06:46 AM
Post #5
QUOTE (Hara Taiki @ Aug 5 2009, 03:43 AM) *
I tried that, all I ended up with was sound only coming from the left channel and still no working software volume and balance controls.

It means sources for AppleAC97AudioVIA needs to be corrected according to datasheet and numerous testing. Not sure I am clever enough to do that.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.5, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2
Nick14
post Oct 30 2009, 11:51 PM
Post #6
I've got sound out but my speakers works with the headset jack at the same time:o anyway too mute the speakers when headset is plugin ? smile.gif i got ADI1980
kmand
post Jul 9 2010, 05:16 PM
Post #7
Is there a version for Snow Leopard (10.6.2) 32 bit?
Slice
post Sep 6 2010, 12:48 PM
Post #8
QUOTE (kmand @ Jul 9 2010, 09:16 PM) *
Is there a version for Snow Leopard (10.6.2) 32 bit?

It must work in 32 bit.
At insanely there is a 64bit version.
i3-2120 GA-H61M-S1 UEFI, Radeon HD6670-UEFI, ALC887(VoodooHDA 2.8.6), OS⌘10.9.5, OS⌘ 10.7.5 Clover FakeSMC_plugins_3.3.1 Realtek LAN v3.1.2

Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: