ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

14 Pages V  « < 10 11 12 13 14 >  
Start a new topic Add Reply
> [HOW TO] Patch AppleHDA - Knowledge Base, Guide for how to fix/use original AppleHDA
manmal
post Nov 2 2011, 07:12 PM
Post #221
hi guyz! Is it possible to patch applehda for this codec (alc269vb) for lion(1071,1072) in your opinion?

Codec: Realtek ALC269VB
Address: 0
AFG Function Id: 0x1 (unsol 1)
Vendor Id: 0x10ec0269
Subsystem Id: 0x10431063

May you help me to do it please?

i also have pinout config (from vista/7 already swapped) and dump from linux (in attachment).
Which dsdt modification should i do ?

thanks!
mal

Attached File  codec0.txt ( 8.92K ) Number of downloads: 48

Attached File  pinconfig.txt.txt ( 476bytes ) Number of downloads: 59
Ajhu
post Nov 6 2011, 12:05 AM
Post #222
I don't understand what to do in this step


QUOTE
To get your codec dump use the shipped voodoohdahelper tool with -dump flag (./voodoohdahelper -dump)


And seriously where can i get voodoohdahelper tool? i googled it and couldn't find it anywhere!

This post has been edited by Ajhu: Nov 6 2011, 12:07 AM
Gringo Vermelho
post Nov 6 2011, 04:02 PM
Post #223
Work on your Google skillz, I found it in 20 seconds.

Attached File  VHDAHelper.zip ( 20.72K ) Number of downloads: 332

ASUS P8Z77-V Pro - EVGA GTX 660 - i5-3570K - 10.9.1 retail - Chameleon 2.2 svn r22xx
mirv
post Nov 11 2011, 07:49 PM
Post #224
I'm so close in getting this working in Lion for ALC882 . However, the kexts have changed in Lion therefore this guide doesn't quite work anymore.. I'm not sure if its that ConfigData param but it seems though the false == codecFound refers to its not finding the codec for the card
mirv
post Nov 11 2011, 07:57 PM
Post #225
also am i missing something or does the guide not say what you need the dump from voodoohelper for?
Noiprox
post Nov 15 2011, 11:11 PM
Post #226
Hello,

I have been working on this for several weeks now, attempting to get my ALC883 audio working in Lion (Specifically it is onboard audio in my LG R500 laptop) but it seems to be a little harder to get working than the standard ALC883. I have attempted all versions of VoodooHDA but they all give me kernel panics. In Snow Leo they also gave me panics or mic feedback but I was able to use a modified AppleHDA in Snow Leo to get it working. I have used all available modifications, rollbacks, bin patching etc I can find but still no luck.

I will attach a copy of my original DSDT pulled from the bios that does contain a simple HDEF as well as one with HDEF removed and some with pinconfigs I have attempted.

The ones with pinconfigs result in correct information in the System Information of Lion but nothing I do can resolve the "No Output Devices Found" in the sound options.

I'll also attach the codec dump and verbs from linux and IOREG output from the working Snow Leo and non-working Lion and also the working Snow Leo AppleHDA/HDEnabler and the non-working Lion AppleHDA.

If anyone can point me in the right direction of anything else to try it would be appreciated as at this point I seem to be out of luck.

Thank you,

Attached File  R500.zip ( 3.59MB ) Number of downloads: 10
terramir
post Nov 27 2011, 10:21 PM
Post #227
QUOTE (THe KiNG @ Dec 30 2010, 05:42 AM) *
The guide is incomplete with a purpose, to make you think.
It cover the most important stuff, rest is a child play once you understand...
I know most want to be serve with A-Z guide, but if all would be like that, then no new hacker will born and only few people would be interested to develop/find/hack, rest would wait to be served.

Yes you tried and failed, I did the same first time, and 599 time, but on 600 try I got it working and finally understand.
You don't need to try that much, as I said most of the part is covered, once you get the verbs part finished, looking on codecgraph will be easy to get the rest of the part.

@ codecowboy I dunno how to prepare food, that dosen't mean you will see me on food forums asking for someone to prepare my food, if you wanna eat proper stuff you must learn how to do it, or order prepared food (read apple).

And I do encourage you to use it. smile.gif

Good luck!

@King Really ! Even if this guide was complete it would still teach and get them to learn the problem in the osx community as large you not the only guilty one, there are three kinds of info in the community which hinder the progress of the osx community at large which is sad, because I think we could have a lot more systems up and running perfectly if this was not the case
#1 The info is incomplete and assuming that others reading have knowledge that actually can't even be found googling for 10 days or when it's available it requires that you read stuff that is 400 pages long (think intel apci spec for dsdt editing)
#2 the info stops before it is finished and then you have to go hunting for the rest and when you can't find it you have to beg people to finish the work for you which really bites. (this is what you did and well it's not cool) that people then have to download other peoples dsdt's and audio dumps and then reverse engineer patches from other people in order to fix this properly on codecs that no one has supported yet.
#3 The whole tutorial consists of do this this and this and use these files you download here and there with no explanation which also bites, because nothing is learned this way.
I agree with you that spoon feeding is not the point but there is insufficient base knowledge available in order to complete what you have had people start, unless you find people that posted their audio dumps and then download patches that other people did and then check where they modify things but the problem is that this way you could mess things up so seriously that you could fry 100's of dollars worth of hardware.
and on another note voodooHDA is not a better solution, matter of fact it is a very bad solution it causes conflicts and kernel panics galore, it is probably the only solution for many folks because no-one has bothered to create a complete tutorial but it causes more problems and loses us real talent in the long run.
People give up on the scene because they cannot learn the basics required I am a little more persistent and I will learn this if it's the last thing I do, but when I finally have I will put the info in one place so people can actually learn this stuff. What you have given is a frustration tool that loses us more then we as a community at large gain.
We gained tmongol aka VCH888 through yours and other tutorials but we probably lost 100's of other talents and 1000's of contributors because they just couldn't make it work stably and gave up sad.gif
This is my opinion if you want to ban me for it from this forum so be it but it's called freedom of speech
terramir
PS: I lost a complete system because I had to use someone else's patched Kext and something went wrong if this tutorial was complete I would have done it the right way and not lost that 160 dollar ion motherboard. worked great for about three weeks then the whole thing fry'ed during one video playback and voodooHDA did not work to do anything but stuttering.
sanky
post Jan 2 2012, 10:16 AM
Post #228
QUOTE (Monkeys @ Sep 18 2011, 08:39 AM) *
I'm looking for some advice getting my conexant cx20585 working with the appleHDA for my Lenovo G560 laptop. I've got the internal speaker and headphones working perfectly, my problem now are the microphones.

I've fixed the verbs and added them to the configdata and added the correct nodes under pathmaps etc. I think I must be very close to having things working because when I load up Ableton Live, and record some sound, i do actually get some extremely quite sound coming through, and I know it's coming from the mic because when I tap on the mic area I can see the little green bars going up and down very slightly but its not really sound just sort of a very faint crackling that gets louder when I tap on the mic or yell into it..

It seems like there is no amplification of the mic signal or something, so only the very small signal is coming through. Also under audio preferences under the inputs tab there is no volume slider, it shows 'this device has no input controls'. So I think that has something to do with it, and i think there is a setting under the pathmaps that needs to be changed, but i have no idea what.

If anyone has heard or come across anything like this before and has any suggestions about what I can do to fix it I would greatly appreciate it! I've tried a bunch of different configurations with pathmaps but am at a bit of a loss as to where to go next.

Here's my linux dump and appleHDA if u want to take a look at them:

[attachment=3801:cx20585.zip]


Hi i also have a Lenovo G460 with Conexant CX20585 running 10.7.2 and have managed to get the audio working with voodoohda 2.7.3. Everything works- mic, speakers, headphone jack and mic jack and also auto switching but i get random KP's due to voodooHDA. I have corrected the pin configurations also. can u please attach again your applehda. Thanks
xtraa
post Jan 7 2012, 03:35 AM
Post #229
QUOTE (terramir @ Nov 27 2011, 10:21 PM) *
@King Really !

...Full quote...

stuttering


Full ack. You totally nailed it with a perfect line of reasoning. smile.gif

xtraa

This post has been edited by xtraa: Jan 7 2012, 03:39 AM
January 19th, 2006: The day we discovered that EFI-Bootloaders would be possible:
http://www.insanelymac.com/forum/topic/717...oolkit/?p=44912
Ash
post Jan 23 2012, 08:51 PM
Post #230
I've Patched AppleHDA (10.7.2) from information in existing legacy kext (Snow Leopard). This is for ALC269 dev id [10ec:0269] but shows up as [8086:1c20] 8086:1c20 Name: 6 Series/C200 Series Chipset Family High Definition Audio Controller. HDMI shows up as: - Codec: Intel CougarPoint HDMI, Address: 3, AFG Function Id: 0x1 (unsol 0), Vendor Id: 0x80862805.

With the new patched kext I have no sound and need help debugging. i've included the kext, platforms.xml, layout269.xml, info.plist in AppleHDAHardwareConfig.kext also I've included all codec dumps from my laptop unfortunately my codec does not work well with the verbit script and I find it hard to manipulate the layouts and platforms as my internal/external mic does not work please provide feedback.

Just for those who are not too sure about patching AppleHDA in Lion: -

SL kext v1.8.0 onwards (roughly) all info for layouts and platforms that used to live in AppleHDA.kext/Contents/Plugins/AppleHDAPlatformDriver.kext/info.plist. Now exists in AppleHDA.kext/Contents/Resources/platforms.xml and layoutXXX.xml substitute XXX with layout id.

So in brief you need to have correct: -
1. layout12.xml (12 is a commonly used in mods)
2. platform.xml
3. info.plist in AppleHDAHardwareConfig.kext needs to have correct codec id (in decimal) and layout id.
4. Binpatch AppleHDA binary to have your PCI device id (in hex) e.g. 85 08 EC 10 for ALC885 [10ec:0885] replace 85 08 EC 10 with your dev id in hex.

Kind Regards,
Ash

Attached File  AppleHDA_ALC269_feedback.zip ( 1.63MB ) Number of downloads: 159


EDIT:- if we can get this working, HDMI Audio should follow as I have included the relavent DSDT edits and HDMI shows up in system profiler in audio (built-in)

This post has been edited by Ash: Jan 24 2012, 04:03 AM
MSI P67A-GD55 (B3) with BIOS 4.3B9 | Intel Core i5-3470 | Corsair Dominator 16GB (4x4GB) DDR3-1600 | Powercolor PCS+ AMD HD7870 2GB MYST Edition | nVidia Geforce 8600GTS | HDD's: Samsung HD753LJ 750GB, Hitachi HDS721010CLA332 1TB, Seagate ST2000DL003-9VT166 2TB, Optiarc DVD RW AD 7201S | USB 3.0: NEC uPD720200A
OS: Mac OS X 10.8.3 | Mac OS X 10.7.5 | Windows 8 Pro (x64) | Windows 7 Enterprise (x86) | Ubuntu 12.10
Bootloader Setup: UEFI/BIOS Dual Boot: - GPT Hybrid MBR | Clover UEFI | GRUB UEFI | Windows Boot Manager UEFI | Clover Bootsector | Chameleon Bootsector | BOOTMGR(MBR)

Packard Bell EasyNote TS11HR | Intel Core i3-2310 | 4GB (2x2GB) DDR3-1333 | Intel HD3000 Mobile | HDD's: Toshiba MK5061GSYN 500GB, Seagate ST9500325AS 500GB | External Superdrive | Broadcom BT2046 (Internal)
OS: Mac OS X 10.8.2 | Mac OS X 10.7.5 | Windows 8 Pro (x64) | Windows 7 Ultimate (x86) | Ubuntu 12.10.
Bootloader Setup: UEFI/BIOS Dual Boot
acero
post Feb 10 2012, 12:24 PM
Post #231
hi,
a little patch for alc888S vc laptop with 10.6.8 applehda,it s not really needed as mine power fine after wake from sleep but i like it to power on boot.

i changed a jump at offset 1278A7 from 7435 to 7535 in hda binary.
it s a function that set power state ,search immediate value ,705(used to set power state),you find a main function : (ZN12AppleHDANode13setPowerStateEmb)
,there 6 results for search.
i tried already to tweak 885 power state with no effect,this patch was my last try and work so far....sound at startup.

if someone have a better idea to patch and i ll be happy to read it.

i do not refund your dead audio if you kill it. huh.gif
bye.

This post has been edited by acero: Feb 22 2012, 08:25 AM
Specter
post Feb 14 2012, 10:32 PM
Post #232
Hello everybody. I have a MSI X58 Pro-E and it has the ALC889 codec, but I have used lots of patched AppleHDA for ALC889 and I still can't hear anything, although the IORegistry information doesn't show any problems.

Can anyone help me to patch it and make it works?

Thanks in advance.

PD: I'm using the last stable version of Lion, 10.7.3.

This post has been edited by Specter: Feb 14 2012, 10:33 PM
Specter
post Feb 26 2012, 11:53 AM
Post #233
QUOTE (Specter @ Feb 14 2012, 11:32 PM) *
Hello everybody. I have a MSI X58 Pro-E and it has the ALC889 codec, but I have used lots of patched AppleHDA for ALC889 and I still can't hear anything, although the IORegistry information doesn't show any problems.

Can anyone help me to patch it and make it works?

Thanks in advance.

PD: I'm using the last stable version of Lion, 10.7.3.


Could anybody help me, please??
maleorderbride
post Feb 29 2012, 03:19 AM
Post #234
I am trying to get ALC898 working.

I have learned quite a bit with King's guide, MasterChief's, and some comments from Kizwan. However, I have not gotten AppleHDA to work with my ALC898.

I have system profiler and system preferences showing up as I desire for inputs/outputs, but no audio makes it out.

I have edited the Info.plist with my fixed verbs, appleHDA binary for my deviceID (0x10ec0899), edited AppleHDAController for my deviceID.

Added a Layout.xml and path map in Platforms.xml.

The only node I am trying to get working right now is my green rear 2.1 jack (but everything else is laid out as well).

Green jack is:
0x14 with connections at 0x0c*. 20 ->12->2 in path map, but still no audio. Results are the same with both of the below attempts.

Files:

Current Attempt: AppleHDA, assertion errors, IOreg
http://dl.dropbox.com/u/6316213/ALC898_Toleda2_Results.zip

Original Attempt:
AppleHDA with all edits, IOreg, CodecDump, CodecDump.svg: http://dl.dropbox.com/u/6316213/Attempt_9.zip


This seems to be the specific sound assertion that is related to the problem:

Mar 1 15:24:18 Cyras-Mac-Pro kernel[0]: Sound assertion "false == streamInfo->IsActive" failed in AppleHDAController at line 5729 goto Exit
Mar 1 15:24:18 Cyras-Mac-Pro kernel[0]: Sound assertion "false == streamInfo->IsActive" failed in AppleHDAController at line 5813 goto Exit
Mar 1 15:24:18 Cyras-Mac-Pro kernel[0]: Sound assertion "0 != fController->getAudioStreamLinkPositionInBuffer ( this, &position )" failed in IOHDAStream at line 401 goto handler

A few hits in google, but nothing that seems promising.

Is anyone familiar with this assertion or have any ideas I could try?

This post has been edited by maleorderbride: Mar 1 2012, 11:29 PM
tmacyunn1
post Mar 3 2012, 10:38 AM
Post #235
@manmal
I have the same audio card with you, but i check your out which has different codec data with me. I have get my ALC269 at intel 6 serial chip audio card work with internal speaker, internal microphone, headphone, work out(external microphone disabled so as HDMI audio doesn't work too.). And it works only with 10.6.2 version AppleHDA, i try to use others doesn't get good luck.
Also i think this card is so weird, for example, I must boot Mac OS X first can get internal speaker and headphone auto switch work, or only can internal speaker work, there is one more thing that the 10.6.2 version driver doesn't work with the kernel flags as UseKernelCache=No, that is to say, if you use the kernel parameter, you will get auto restart, it is so annoyed about it.
I see you codec, i think the right way of patching is:
CODE
Output:
0x02>0x0c>0x21 //HP OUT
0x03>0x0d>0x1B  //Internal Speaker

Input
0x19>0x23>0x08 //Internal Mic (change to LineIn or disable)
0x18>0x22>0x09 //External Mic

The Pin default data fix can be done by reading the King's topic ,also i will upload mine, too.
Last, i recommend that you use the 10.6.2 version AppleHDA to do it so, if you succeed with it ,then you can try 10.6.x or 10.7.x version.

@Ash
I see your codec graph and the path map, you got wrong link in the Mic combine, the Node 25 is a [N/A] device, so i suggest you try this below :
CODE
Output (decimal):
2>12>20     //Internal speaker
3>13>33     // HP out

Input:
9>34>24    // External Mic (change to LineIn or disable)
8>35>27    // Internal Mic


Here is my work.
Attached File  Screen_Shot_2012_03_03_at_6.25.38_PM.png ( 50.15K ) Number of downloads: 118

Attached File  Screen_Shot_2012_03_03_at_6.26.47_PM.png ( 46.47K ) Number of downloads: 86

Attached File  Screen_Shot_2012_03_03_at_6.26.36_PM.png ( 52.17K ) Number of downloads: 79


This post has been edited by tmacyunn1: Mar 3 2012, 10:39 AM
Windows 7 x64 SP1+ Mavericks 10.9.0
CPU : I5-2450m Ram : 8G=4*2G Graphics : HD3000(Disabled AMD6630m BY DSDT) Ethernet: RTL8136 Wireless: AR9280 Audio Card: ALC269 Clover version: 2330
.
tmacyunn1
post Mar 3 2012, 10:54 AM
Post #236
Sorry the screenshot is large than limitation, upload again. ALC269
Windows 7 x64 SP1+ Mavericks 10.9.0
CPU : I5-2450m Ram : 8G=4*2G Graphics : HD3000(Disabled AMD6630m BY DSDT) Ethernet: RTL8136 Wireless: AR9280 Audio Card: ALC269 Clover version: 2330
.
Marchrius
post Mar 6 2012, 06:28 PM
Post #237
Hi all! smile.gif

My name is Matteo (aka Marchrius)

I have an ALC888 on an Acer Aspire 6930G.

I have an AppleHDA.kext patched (2.1.3f7) for my card.

The PinConfig, form Windows is:
[code][/code]

The Ubuntu 11.10 dump file is:
Attached File  Audio_ALC888.txt ( 14.72K ) Number of downloads: 15


The CodecID in DSDT is 888 (0x78 0x03 0x00 0x00)

In Preferences>Audio I have:
Attached File  screen1.tiff ( 72.94K ) Number of downloads: 15

Attached File  screen2.tiff ( 69.14K ) Number of downloads: 7


The audio is good. The Speaker and the Headphone works (no switch, I must change the preference in Sudio settings). The Line In (Blue) and Internal Mic don't works. (The Mic in (Pink) works).

How I can resolve this problem? :/
Aspire 6930G 16" (MacBook Pro 5.2 17"): CPU: T9300 @ 2.50GHz - RAM: Samsung DDR2 2x2GB - GFX: 9600M GT DDR2 1024 MB - HDD: WD5000BEVT - HDA + HDMI: ALC888 + 0x10DE0006 - WIFI: BCM4312 Branded Apple - ETH: Atheros AR8121/AR8113/AR8114 - 10.6.8 / 10.7.4 up to 10.8.5 up to 10.9 GM / 10.9 DP8
Guida Mountain Lion su Aspire 6930G Acer Aspire 6930G project Pandora's Box - USB/DVD Maker
[twitter]hackbook_pro[/twitter]
Ash
post Apr 3 2012, 02:35 AM
Post #238
QUOTE (tmacyunn1 @ Mar 3 2012, 11:38 AM) *
@manmal
I have the same audio card with you, but i check your out which has different codec data with me. I have get my ALC269 at intel 6 serial chip audio card work with internal speaker, internal microphone, headphone, work out(external microphone disabled so as HDMI audio doesn't work too.). And it works only with 10.6.2 version AppleHDA, i try to use others doesn't get good luck.
Also i think this card is so weird, for example, I must boot Mac OS X first can get internal speaker and headphone auto switch work, or only can internal speaker work, there is one more thing that the 10.6.2 version driver doesn't work with the kernel flags as UseKernelCache=No, that is to say, if you use the kernel parameter, you will get auto restart, it is so annoyed about it.
I see you codec, i think the right way of patching is:
CODE
Output:
0x02>0x0c>0x21 //HP OUT
0x03>0x0d>0x1B  //Internal Speaker

Input
0x19>0x23>0x08 //Internal Mic (change to LineIn or disable)
0x18>0x22>0x09 //External Mic

The Pin default data fix can be done by reading the King's topic ,also i will upload mine, too.
Last, i recommend that you use the 10.6.2 version AppleHDA to do it so, if you succeed with it ,then you can try 10.6.x or 10.7.x version.

@Ash
I see your codec graph and the path map, you got wrong link in the Mic combine, the Node 25 is a [N/A] device, so i suggest you try this below :
CODE
Output (decimal):
2>12>20     //Internal speaker
3>13>33     // HP out

Input:
9>34>24    // External Mic (change to LineIn or disable)
8>35>27    // Internal Mic


Here is my work.
Attached File  Screen_Shot_2012_03_03_at_6.25.38_PM.png ( 50.15K ) Number of downloads: 118

Attached File  Screen_Shot_2012_03_03_at_6.26.47_PM.png ( 46.47K ) Number of downloads: 86

Attached File  Screen_Shot_2012_03_03_at_6.26.36_PM.png ( 52.17K ) Number of downloads: 79

@tmacyunn1

Thanks for the great info.

Spot on there: -

QUOTE
CODE
Output (decimal):
2>12>20     //Internal speaker
3>13>33     // HP out

Input:
9>34>24    // External Mic (change to LineIn or disable)
8>35>27    // Internal Mic


I cannot get Internal mic to work I tried boost and enable amp but no luck. in legacy kext external mic/line-in works.

Now I am able to modify pathmaps and get them Working
I can confirm using lion 10.7.3 kext Binpatch worked, HDMI audio works, Internal Speakers and Headphones work.
just no input. really not sure whats going on need help sorting out pathmaps for input especially internal mic.

Here's my kext for ALC271X for 10.7.3: - Attached File  ALC271X.zip ( 1.61MB ) Number of downloads: 47


inside are verbs from windows, linux dumps and voodoohda dump
MSI P67A-GD55 (B3) with BIOS 4.3B9 | Intel Core i5-3470 | Corsair Dominator 16GB (4x4GB) DDR3-1600 | Powercolor PCS+ AMD HD7870 2GB MYST Edition | nVidia Geforce 8600GTS | HDD's: Samsung HD753LJ 750GB, Hitachi HDS721010CLA332 1TB, Seagate ST2000DL003-9VT166 2TB, Optiarc DVD RW AD 7201S | USB 3.0: NEC uPD720200A
OS: Mac OS X 10.8.3 | Mac OS X 10.7.5 | Windows 8 Pro (x64) | Windows 7 Enterprise (x86) | Ubuntu 12.10
Bootloader Setup: UEFI/BIOS Dual Boot: - GPT Hybrid MBR | Clover UEFI | GRUB UEFI | Windows Boot Manager UEFI | Clover Bootsector | Chameleon Bootsector | BOOTMGR(MBR)

Packard Bell EasyNote TS11HR | Intel Core i3-2310 | 4GB (2x2GB) DDR3-1333 | Intel HD3000 Mobile | HDD's: Toshiba MK5061GSYN 500GB, Seagate ST9500325AS 500GB | External Superdrive | Broadcom BT2046 (Internal)
OS: Mac OS X 10.8.2 | Mac OS X 10.7.5 | Windows 8 Pro (x64) | Windows 7 Ultimate (x86) | Ubuntu 12.10.
Bootloader Setup: UEFI/BIOS Dual Boot
manmal
post Apr 9 2012, 04:07 PM
Post #239
@tmacyun , @ash

Thanks a lot tmacyun!!
I have it working (but no input too) but i have a really annoying problem : after resume from sleep audio disappears and i don't know how to reactivate it.
Any suggestion how to fix it to have audio working after resume-from-sleep?
thanks!
Mal
DineshMG
post Apr 25 2012, 03:15 PM
Post #240
QUOTE (Ash @ Apr 3 2012, 02:35 AM) *
@tmacyunn1

Thanks for the great info.

Spot on there: -



I cannot get Internal mic to work I tried boost and enable amp but no luck. in legacy kext external mic/line-in works.

Now I am able to modify pathmaps and get them Working
I can confirm using lion 10.7.3 kext Binpatch worked, HDMI audio works, Internal Speakers and Headphones work.
just no input. really not sure whats going on need help sorting out pathmaps for input especially internal mic.

Here's my kext for ALC271X for 10.7.3: - Attached File  ALC271X.zip ( 1.61MB ) Number of downloads: 47


inside are verbs from windows, linux dumps and voodoohda dump


Hi,

I have made the inputs as well working for ALC269 but I have used your patched AppleHDA bin inside MacOS folder. So, if I try to
patch kextmyself then its not working at all. So, I would like to know how did you bin patched AppleHDA bin? Can you provide
details about what you have done to the AppleHDA bin and which version is it? If you provide this then I can help you to fix
your codec as well since we have very well similarities in pin configs. Looking forward for your information on bin patch of
your attached AppleHDA bin.


14 Pages V  « < 10 11 12 13 14 >
Add Reply Start a new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members: