ProjectOSX

Welcome Guest!

Returning User? Login here.

Want membership privileges? Register here.

 
Start a new topic Add Reply
> Snow On Asus Eeepc 1000h
gt170
post Oct 17 2009, 08:25 AM
Post #1
das ist nur als grobe Anleitung gedacht für alle, die sich schon mit der Materie beschäftigt haben und wissen, wo sie sonst Details klären können:

Snow Leopard auf dem eeePC 1000H:

Man nehme ein Image der Snow Leopard Install DVD und einen funktionierenden Mac/Hackintosh.
Das stelle man auf einem USB-Stick (ich habe eine SD-Karte genommen) wieder her, den man als
1 Partition (Mac OS Journaled …; Option: GUUID) formatiert hat.

Dann bei Info über den Stick das Häkchen ganz unten rausnehmen (ignore permissions …) & gleich sich selbst schreib/leserechte geben.

Dann eine Datei ersetzen, damit die ganzen HW-Prüfungen wegfallen:
http://www.mediafire.com/download.php?3cmyydjovrl in finder > go to folder > /Volumes/*Name Deines USB Snow Installsticks*/System/Installation/Packages ersetzen.

Anschließend mit dem Netbookbootmaker (http://code.google.com/p/netbook-installer/) den Stick modifizieren (peinlich genau drauf achten, dass man wirklich auf dem Snow-Stick den Patch durchführt!!!) .

Jetzt noch einen Extras Ordner anlegen und folgende kexts reinlegen:
disabler, fakesmc, dsmos, nullCPUpowermanagement, smbios, die ps2 kexts, sleepenabler, openhaltrestart, voodooHDA (aus dem prefpaneordner http://redirectingat.com/?id=292X457&u...oglecode.com%2F samt der prefpane installieren), ICHfix
außerdem ein ordentliches dsdt.aml sowie kexthelper und den asus Hotkeys enabler 0.4 (http://ipis-osx.wikidot.com/forum/t-141750/new-improved-hotkey-enabler (ich nutze vermutlich das …0.4 Paket) oder http://thireus.dareyourmind.net/Asus%20EEE...abler.mpkg.zip)
falls ihr mit der orig. WLAN-Karte (die kann übrigens draftN!) arbeitet, dann noch dieses Ralink install dmg (STA_RT2860 D-1.1.2.0 UI-1.7.1.0_2009_02_17.dmg von der Ralink-Seite) dazu.

kexts sucht ihr hier z.B: http://cid-8b65993ef55cf014.skydrive.live....x/.Public/OSx86 wenn nicht anders angegeben.
dsdt: http://www.infinitemac.com/f7/asus-hotkey-for-1000h-t1947/ vielleicht nutze ich auch den hier aus der Anleitung: http://www.enik.ch/2009/03/osx-leopard-105...-the-eee-1000h/ (auf jeden Fall habe ich den Wake-fix und die hell/dunkel Hotkeys und den powerbuttonfix).

Bios-Update hattet ihr ja schon gemacht oder holt das jetzt nach. Dann jetzt dafür sorgen, dass euer eeePC vom Stick bootet (Disk menue im bios ...). und dann die Installation beginnen.
Man muss manchmal etwas raten, wo die Buttons sind (leicht außerhalb des Screens), aber ich habe es auch geschafft.
Vor dem Reboot (50 Minuten etwa) dann im Bios wieder die Bootreihenfolge sanieren.
Nach dem Neustart könnt ihr nun die nötigen Kexts nachinstallieren.

Bei mir hat es so prima geklappt. Wobei ich allerdings auf sauber laufende 10.5.8 Installation drübergebügelt habe. Bluetooth kann ich noch nicht abschalten, sonst läuft alles (LAN-Port nicht getestet).
Zu guter Letzt noch Quartz einschalten:
sudo defaults write /Library/Preferences/com.apple.windowserver QuartzGLEnabled -boolean YES



(beim Test war Quartz auf Snow damit gar nicht angeschaltet - also tut Snow das von alleine ...)

Update auf 10.6.1 könnt ihr problemlos machen. Allerdings müsst ihr dann den Bluetoothfix wieder installieren: http://ipis-osx.wikidot.com/forum/t-162049 bzw. http://dl.free.fr/getfile.pl?file=/pC32BaOf (und dort auf "Télécharger ce fichier
" klicken - dann habt ihr auch gleich die ganzen Extensions, die ihr ohenhin braucht).
Wie gehabt mit Kexthelper installieren.

anscließend könnt ihr euch hier informieren, wie es um Schneeleoparden bestellt ist: http://www.youtube.com/watch?v=Hk7P8VQFfGg

Lasst mal hören, ob es bei euch so geklappt hat, wie bei mir!!!

Mai2010:
Inzwischen habe ich mit 10.6.3 neuinstalliert. Dazu znächst die Prozedur wie oben. Dann Netbookinstaller 0.8.4RC1 laufen lassen. Dann das 10.6.3.1 Comboupdate drüberinstalliert und neu gestartet. Der Netbookinstaller bastelt dann beim Boot alles zurecht und schwups läuft die Sache.
Falls Chamaeleon mal nicht von dem Laufwerk bootet, was ihr wollt, dann die com.apple.boot.plist im Extra-Ordner (der ist versteckt samt des Subordners GeneralExtensions, den ihr bestücken müsst) editieren - Stichwort rd=disk0s1). Am besten via Terminal ... Noch habe ich Problemchen mit Sleep. Aber sonst läuft es.


Falls ihr doch mal händisch die Rechte reparieren müsst im Terminal:
sudo chown -R root:wheel /Volumes/OSX/System/Library/Extensions
sudo chown -R root:wheel /Volumes/OSX/Extra
sudo chown root:admin /Volumes/OSX
sudo chmod -R 755 /Volumes/OSX/System/Library/Extensions
"OSX" müsst ihr natürlich durch den Namen des jeweiligen Laufwerks bei euch ersetzen.

This post has been edited by gt170: May 13 2010, 03:52 PM
gt170
post Nov 28 2009, 11:01 PM
Post #2
we tried it today on a new 1000H (1902 BIOS to old for this motherloard) and it didn't boot from the stick. each other way failed at some point. so you better go for an eeepc with bios 1902.
gt170
post Jan 29 2010, 04:47 PM
Post #3
QUOTE (gt170 @ Nov 29 2009, 12:01 AM) *
we tried it today on a new 1000H (1902 BIOS to old for this motherloard) and it didn't boot from the stick. each other way failed at some point. so you better go for an eeepc with bios 1902.


correction: it worked now on the precious eeepc. no idea what was the problem.
we defined the sdcard to be harddisk1 and no harddisk2 in bios.
and it worked just fine (using UUID partition format and the plain standard OSX 10.6 DVD moved to SDcard and manipulated with netbookbootmaker ...)
Prelator
post Feb 8 2010, 09:54 AM
Post #4
Hallo

ich habe ein Problem:

wenn ich die bootcd einlege und dann die optionen -x angebe und boote bleibt er nach ca. 3 sec nach beginn des laden des setups stehen.

ich habe eine mac snow leopard retail installations dvd

Was mache ich falsch?


This post has been edited by Prelator: Aug 27 2012, 02:45 PM
gt170
post Feb 19 2010, 05:58 PM
Post #5
QUOTE (Prelator @ Feb 8 2010, 10:54 AM) *
Hallo

ich habe ein Problem:

wenn ich die bootcd einlege und dann die optionen -x angebe und boote bleibt er nach ca. 3 sec nach beginn des laden des setups stehen.

ich habe eine mac snow leopard retail installations dvd

Was mache ich falsch?



niemand hat behauptet dass ein boot/install von der original-DVD auf diese Weise funktioniert.
Tut es auch nicht. Wenn es ginge, dann hätte ich ja nicht die Anleitung verfassen müssen.
Guest_channal1_*
post Jul 29 2011, 02:30 AM
Post #6
THANK YOU
i think i should thank you very much for you can waste lot of time to write this post .....
thank you again for your sharing..
discount coach handbagspp fitting
microsoft office professional 2010
Sp33dy
post Apr 13 2012, 05:47 PM
Post #7
Retail Install sollte aber mitlerweile mit Empire EFI realisierbar sein... ^^

Habe eine Retail Install auf meinem Lenovo S10 gemacht, und lief bis auf die fehlenden Kext's fuer diverse Hardware ohne Probleme smile.gif




PS: Sorry fuer die Leichenschaendung...
Sorry for my english. I use google to translate...

 MacBook Pro 15" late '08 ~ OS X 10.6.8 / Win 7 x64 Ultimate - 2x 2,4 Ghz - 4 GB Ram - 500 GB + 600GB USB
ASUS M2N32-SLI Deluxe | AMD 5600+ X2 | GF8600GT ~ OSx86 10.6.2 - 2x 2,8 Ghz - 4 GB Ram - 320 GB
Shuttle XPC - SG33G5 | Intel P4 | GF8600GT - OSx86 10.6.2 - 1x 3 Ghz - 4 GB Ram - 160 GB
Lenovo S10 - 4333-A12 | Intel ATOM N270 - OSx86 10.6.8 / WinXP - 1x 1,6 Ghz - 1 GB Ram - 160 GB

Add Reply Start a new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members: